<!DOCTYPE html><html class="no-js" lang="en-US" prefix="og: http://ogp.me/ns#"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1.0"><link rel="profile" href="http://gmpg.org/xfn/11" /><link rel="pingback" href="http://www.steelersdepot.com/xmlrpc.php" /><title>2017 Offseason Questions: What Recent Draft Pick Was Your Biggest Letdown? - Steelers Depot</title><meta name="description" content="The 2016 season is unfortunately over, and the Pittsburgh Steelers are now embarking upon their latest offseason journey, heading back to the UPMC Rooney S"/><link rel="canonical" href="http://www.steelersdepot.com/2017/06/2017-offseason-questions-recent-draft-pick-biggest-letdown/" /><link rel="publisher" href="https://plus.google.com/+DaveBryan"/><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="2017 Offseason Questions: What Recent Draft Pick Was Your Biggest Letdown? - Steelers Depot" /><meta property="og:description" content="The 2016 season is unfortunately over, and the Pittsburgh Steelers are now embarking upon their latest offseason journey, heading back to the UPMC Rooney S" /><meta property="og:url" content="http://www.steelersdepot.com/2017/06/2017-offseason-questions-recent-draft-pick-biggest-letdown/" /><meta property="og:site_name" content="Steelers Depot" /><meta property="article:tag" content="Curtis Brown" /><meta property="article:section" content="Article" /><meta property="article:published_time" content="2017-06-30T05:00:52+00:00" /><meta property="article:modified_time" content="2017-06-30T04:30:17+00:00" /><meta property="og:updated_time" content="2017-06-30T04:30:17+00:00" /><meta property="og:image" content="http://www.steelersdepot.com/wp-content/uploads/2017/06/Curtis-Brown-Ravens.jpg" /><meta property="og:image:width" content="1024" /><meta property="og:image:height" content="689" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="The 2016 season is unfortunately over, and the Pittsburgh Steelers are now embarking upon their latest offseason journey, heading back to the UPMC Rooney S" /><meta name="twitter:title" content="2017 Offseason Questions: What Recent Draft Pick Was Your Biggest Letdown? - Steelers Depot" /><meta name="twitter:site" content="@Steelersdepot" /><meta name="twitter:image" content="http://www.steelersdepot.com/wp-content/uploads/2017/06/Curtis-Brown-Ravens.jpg" /><meta name="twitter:creator" content="@mmarczi" /><link rel='dns-prefetch' href='//www.steelersdepot.com' /><link rel='dns-prefetch' href='//s0.wp.com' /><link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Steelers Depot &raquo; Feed" href="http://www.steelersdepot.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Steelers Depot &raquo; Comments Feed" href="http://www.steelersdepot.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Steelers Depot &raquo; 2017 Offseason Questions: What Recent Draft Pick Was Your Biggest Letdown? Comments Feed" href="http://www.steelersdepot.com/2017/06/2017-offseason-questions-recent-draft-pick-biggest-letdown/feed/" /> <script type="text/javascript">/*<![CDATA[*/window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.steelersdepot.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8"}};!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);/*]]>*/</script> <style type="text/css">img.wp-smiley,img.emoji{display:inline !important;border:none !important;box-shadow:none !important;height:1em !important;width:1em !important;margin:0
.07em !important;vertical-align:-0.1em !important;background:none !important;padding:0
!important}</style><link rel='stylesheet' id='wpts_ui_css-css'  href='http://www.steelersdepot.com/wp-content/plugins/wordpress-post-tabs/css/styles/default/style.css?ver=1.6.2' type='text/css' media='all' /><link rel='stylesheet' id='wp-pagenavi-css'  href='http://www.steelersdepot.com/wp-content/plugins/wp-pagenavi/pagenavi-css.css?ver=2.70' type='text/css' media='all' /><link rel='stylesheet' id='parent-style-css'  href='http://www.steelersdepot.com/wp-content/themes/mh_newsdesk/style.css?ver=4.8' type='text/css' media='all' /><link rel='stylesheet' id='mh-style-css'  href='http://www.steelersdepot.com/wp-content/themes/mh_newsdesk-child/style.css?ver=1.1.0' type='text/css' media='all' /><link rel='stylesheet' id='mh-font-awesome-css'  href='//maxcdn.bootstrapcdn.com/font-awesome/4.3.0/css/font-awesome.min.css' type='text/css' media='all' /><link rel='stylesheet' id='mh-google-fonts-css'  href='//fonts.googleapis.com/css?family=PT+Serif:300,400,400italic,600,700|Oswald:300,400,400italic,600,700' type='text/css' media='all' /><link rel='stylesheet' id='simple-social-icons-font-css'  href='http://www.steelersdepot.com/wp-content/plugins/simple-social-icons/css/style.css?ver=2.0.1' type='text/css' media='all' /><link rel='stylesheet' id='slb_core-css'  href='http://www.steelersdepot.com/wp-content/plugins/simple-lightbox/client/css/app.css?ver=2.6.0' type='text/css' media='all' /><link rel='stylesheet' id='social-logos-css'  href='http://www.steelersdepot.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' /><link rel='stylesheet' id='jetpack_css-css'  href='http://www.steelersdepot.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.0' type='text/css' media='all' /><link rel='https://api.w.org/' href='http://www.steelersdepot.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.steelersdepot.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.steelersdepot.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 4.8" /><link rel='shortlink' href='http://wp.me/pPyaZ-1WMN' /><link rel="alternate" type="application/json+oembed" href="http://www.steelersdepot.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.steelersdepot.com%2F2017%2F06%2F2017-offseason-questions-recent-draft-pick-biggest-letdown%2F" /><link rel="alternate" type="text/xml+oembed" href="http://www.steelersdepot.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.steelersdepot.com%2F2017%2F06%2F2017-offseason-questions-recent-draft-pick-biggest-letdown%2F&#038;format=xml" /> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>(adsbygoogle=window.adsbygoogle||[]).push({google_ad_client:"ca-pub-7138622909378284",enable_page_level_ads:true});</script> <script data-cfasync="false" type="text/javascript">(function(w,d){var s=d.createElement('script');s.src='//delivery.adrecover.com/15913/adRecover.js';s.type='text/javascript';s.async=true;(d.getElementsByTagName('head')[0]||d.getElementsByTagName('body')[0]).appendChild(s);})(window,document);</script><script type='text/javascript'>window._taboola=window._taboola||[];_taboola.push({article:'auto'});_taboola.push({listenTo:'render',handler:function(p){TRC.modDebug.logMessageToServer(2,"wordpress-integ");}});_taboola.push({additional_data:{sdkd:{"os":"Wordpress","osv":"4.8","sdkt":"Taboola Wordpress Plugin","sdkv":"1.0.9"}}});!function(e,f,u){e.async=1;e.src=u;f.parentNode.insertBefore(e,f);}(document.createElement('script'),document.getElementsByTagName('script')[0],'//cdn.taboola.com/libtrc/steelersdepot/loader.js');</script><style type='text/css'>img#wpstats{display:none}</style><style type="text/css">.social-nav a:hover, .logo-title, .entry-content a, a:hover, .entry-meta .entry-meta-author, .entry-meta a, .comment-info, blockquote, .pagination a:hover
.pagelink{color:#f1c000}.main-nav li:hover, .slicknav_menu, .ticker-title, .breadcrumb a, .breadcrumb .bc-text, .button span, .widget-title span, input[type=submit], table th, .comment-section-title .comment-count, #cancel-comment-reply-link:hover, .pagination .current, .pagination
.pagelink{background:#f1c000}blockquote,input[type=text]:hover,input[type=email]:hover,input[type=tel]:hover,input[type=url]:hover,textarea:hover{border-color:#f1c000}.widget-title, .pagination a.page-numbers:hover, .dots:hover, .pagination a:hover .pagelink,.comment-section-title{background:#000}.commentlist .depth-1, .commentlist .bypostauthor
.avatar{border-color:#000}.main-nav, .main-nav ul li:hover>ul,.mh-footer{background:#000}.header-top, .header-nav ul li:hover>ul,.footer-ad-wrap,.footer-1,.footer-2,.footer-3,.footer-bottom{background:#000}.social-nav
a{color:#000}.footer-widgets .widget-title{background:#000}</style><link rel="shortcut icon" href="http://www.steelersdepot.com/wp-content/uploads/2015/07/favicon.ico"> <!--[if lt IE 9]> <script src="http://www.steelersdepot.com/wp-content/themes/mh_newsdesk/js/css3-mediaqueries.js"></script> <![endif]--><style type="text/css" media="screen">.simple-social-icons ul li a, .simple-social-icons ul li a:hover, .simple-social-icons ul li a:focus{background-color:#999 !important;border-radius:3px;color:#fff !important;border:0px
#fff solid !important;font-size:18px;padding:9px}.simple-social-icons ul li a:hover, .simple-social-icons ul li a:focus{background-color:#666 !important;border-color:#fff !important;color:#fff !important}.simple-social-icons ul li a:focus{outline:1px
dotted #666 !important}</style></head><body class="post-template-default single single-post postid-464305 single-format-standard mh-right-sb"><div id="mh-wrapper"> <header class="mh-header"><div class="header-wrap clearfix"><div class="mh-col mh-1-3 header-logo"> <a href="http://www.steelersdepot.com/" title="Steelers Depot" rel="home"><div class="logo-wrap" role="banner"> <img src="http://www.steelersdepot.com/wp-content/uploads/2015/07/cropped-cropped-depot-logo1.png" height="100" width="384" alt="Steelers Depot" /></div> </a></div> <aside class="mh-col mh-2-3"><div class="header-ad"><div class="textwidget"><p><script id="mNCC" language="javascript">/*<![CDATA[*/medianet_width="728";medianet_height="90";medianet_crid="782279489";medianet_versionId="111299";(function(){var isSSL='https:'==document.location.protocol;var mnSrc=(isSSL?'https:':'http:')+'//contextual.media.net/nmedianet.js?cid=8CU2WB7LL'+(isSSL?'&https=1':'');document.write('<scr'+'ipt type="text/javascript" id="mNSC" src="'+mnSrc+'"></scr'+'ipt>');})();/*]]>*/</script></p></div></div></aside></div><div class="header-menu clearfix"> <nav class="main-nav clearfix"><div class="menu-header-container"><ul id="menu-header" class="menu"><li id="menu-item-37673" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-37673"><a href="http://www.steelersdepot.com">Home</a></li><li id="menu-item-154806" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154806"><a href="http://www.steelersdepot.com/category/news/">Steelers News</a></li><li id="menu-item-38055" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38055"><a href="http://www.steelersdepot.com/steelers-news/">Steelers Wire</a></li><li id="menu-item-163626" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-163626"><a href="http://www.steelersdepot.com/category/podcast/">Podcast</a></li><li id="menu-item-38056" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38056"><a href="http://www.shareasale.com/r.cfm?b=375840&#038;u=275818&#038;m=7124&#038;urllink=&#038;afftrack=">Steelers Merchandise</a></li><li id="menu-item-38057" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38057"><a href="http://www.jdoqocy.com/click-2334271-10858765?sid=&#038;url=http://www.ticketliquidator.com/tix/Pittsburgh-Steelers-tickets.aspx?utm_source=CJID&#038;utm_medium=2334271">Tickets</a></li><li id="menu-item-240752" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-240752"><a>NFL Draft Info</a><ul class="sub-menu"><li id="menu-item-456507" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-456507"><a href="http://www.steelersdepot.com/2017-nfl-scouting-combine-results-tracker/">2017 NFL Combine Results</a></li><li id="menu-item-240753" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-240753"><a href="http://www.steelersdepot.com/2016/03/steelers-2016-pre-draft-visit-tracker/">2016 Pre-Draft Visits</a></li><li id="menu-item-225936" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-225936"><a title="2016 NFL Combine Results" href="http://www.steelersdepot.com/2016-nfl-scouting-combine-results/">2016 NFL Combine Results</a></li></ul></li><li id="menu-item-38058" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38058"><a href="http://www.dpbolvw.net/click-2334271-10539967?url=http%3A%2F%2Fwww.zinio.com%2Fwww%2Fbrowse%2Fproduct.jsp%3FproductId%3D500215550%26affId%3Dcj%26rf%3Dcjaffcatalog&#038;cjsku=500073101">Steelers Digest</a></li><li id="menu-item-158274" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-158274"><a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&#038;hosted_button_id=XZ97MFHPQZYX4">Donate</a></li></ul></div>		</nav><div class="header-sub clearfix"> <section id="ticker" class="news-ticker mh-col mh-2-3 clearfix"> <span class="ticker-title">Hot Topics</span><ul class="ticker-content"></ul> </section>						<aside class="mh-col mh-1-3 header-search"><form role="search" method="get" class="search-form" action="http://www.steelersdepot.com/"> <label> <span class="screen-reader-text">Search for:</span> <input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" /> </label> <input type="submit" class="search-submit" value="Search" /></form>			</aside></div></div> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');ga('create','UA-11437002-3','auto');ga('send','pageview');</script> </header><div class="mh-section mh-group"><div id="main-content" class="mh-content"> <nav class="breadcrumb"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="http://www.steelersdepot.com" itemprop="url" class="bc-home"><span itemprop="title">Home</span></a></span> <span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="http://www.steelersdepot.com/category/article/" itemprop="url"><span itemprop="title">Article</span></a></span></nav> <article id="post-464305" class="post-464305 post type-post status-publish format-standard has-post-thumbnail hentry category-article tag-curtis-brown"> <header class="entry-header clearfix"><h1 class="entry-title">2017 Offseason Questions: What Recent Draft Pick Was Your Biggest Letdown?</h1> </header><div class="entry-thumbnail"> <img width="777" height="437" src="http://www.steelersdepot.com/wp-content/uploads/2017/06/Curtis-Brown-Ravens-777x437.jpg" class="attachment-content-single size-content-single wp-post-image" alt="" srcset="http://www.steelersdepot.com/wp-content/uploads/2017/06/Curtis-Brown-Ravens-777x437.jpg 777w, http://www.steelersdepot.com/wp-content/uploads/2017/06/Curtis-Brown-Ravens-180x101.jpg 180w, http://www.steelersdepot.com/wp-content/uploads/2017/06/Curtis-Brown-Ravens-260x146.jpg 260w, http://www.steelersdepot.com/wp-content/uploads/2017/06/Curtis-Brown-Ravens-373x210.jpg 373w, http://www.steelersdepot.com/wp-content/uploads/2017/06/Curtis-Brown-Ravens-120x67.jpg 120w" sizes="(max-width: 777px) 100vw, 777px" /></div><p class="entry-meta"> <span class="entry-meta-author vcard author">By <a class="fn" href="http://www.steelersdepot.com/author/matthew-marczi/">Matthew Marczi</a></span> <span class="entry-meta-date updated">June 30, 2017 at 05:00 am</span></p><div class="entry-content clearfix"> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-7138622909378284" data-ad-slot="9778711637" data-ad-format="auto"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script> <br><p><em>The 2016 season is unfortunately over, and the <strong>Pittsburgh Steelers</strong> are now embarking upon their latest offseason journey, heading back to the UPMC Rooney Sports Complex, formerly known and still referred to as the ‘South Side’ facility of Heinz Field. While the postseason is now behind us, there is plenty left to discuss.</em></p><p><em>And there are plenty of questions left unanswered as well. The offseason is just really the beginning phase of the answer-seeking process, which is lasts all the way through the Super Bowl for teams fortunate enough to reach that far.</em></p><p><em>You can rest assured that we have the questions, and we will be monitoring the developments in the offseason as they develop, and beyond, looking for the answers as we look to evaluate the makeup of the Steelers as they try to navigate their way back to the Super Bowl, after reaching the AFC Championship game last season for the first time in more than half a decade.</em></p><p><strong>Question:</strong> Which recent Steelers draft pick turned out to be a worse player than you expected him to be?</p><p>In case you may not have noticed, this is the flip side to the question that I posed yesterday. Of the Steelers’ recent draft picks of, say, this decade, which draft pick (or draft picks) more than the rest disappointed you the most, relative to how you expected them to perform?</p><div class="insert-post-ads" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-7138622909378284" data-ad-slot="6153397631" data-ad-format="auto"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script> <br></div><p>As I prefaced the question yesterday, this is a <em>personal</em>, <em>subjective</em> question about what you thought of certain players and how they would translate to the NFL during the draft and pre-draft process. This isn’t a question about draft pedigree and relative success in comparison to that.</p><p>For many people, that will eliminate players such as <strong>Jarvis Jones</strong> and <strong>Dri Archer</strong>, arguably their two worst picks in that time frame relative to the value of the draft pick used on them. The fact is that there was a good number of people who were extremely pessimistic about either of them turning into players. So that is the sort of answer I’m getting at.</p><p>As for myself, I certainly thought that <strong>Curtis Brown</strong> would be a whole lot better than he ended up proving to be, and I think now that I brought him up he may well be a popular answer. Though a bit light in the shorts, Brown had height, speed, and the ability to play the ball, but it never came together mentally.</p><p>Another popular choice, I imagine, will be <strong>Shamarko Thomas</strong>, in no small part due to the fact that he cost a third-round draft pick in order to make the trade for the fourth-round pick the Steelers used on him.</p><p>Other names that may spring to mind are <strong>Jordan Zumwalt</strong>, <strong>Alameda Ta’amu</strong>, <strong>Jason Worilds</strong>, <strong>Markus Wheaton</strong>, and <strong>Chris Carter</strong>. I expect more than one will mention <strong>Senquez Golson</strong>, but, of course, he hasn’t gotten on the field yet two years into his career due to injuries. That in itself is a disappointment, but not based on evaluation of performance.</p><div id='taboola-below-article'></div><script type='text/javascript'>window._taboola=window._taboola||[];_taboola.push({mode:'thumbnails-a',container:'taboola-below-article',placement:'below-article',target_type:'mix'});</script><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-464305" class="share-twitter sd-button share-icon" href="http://www.steelersdepot.com/2017/06/2017-offseason-questions-recent-draft-pick-biggest-letdown/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-464305" class="share-facebook sd-button share-icon" href="http://www.steelersdepot.com/2017/06/2017-offseason-questions-recent-draft-pick-biggest-letdown/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-464305" class="share-google-plus-1 sd-button share-icon" href="http://www.steelersdepot.com/2017/06/2017-offseason-questions-recent-draft-pick-biggest-letdown/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span>Google</span></a></li><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon" href="http://www.steelersdepot.com/2017/06/2017-offseason-questions-recent-draft-pick-biggest-letdown/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-pinterest"><a rel="nofollow" data-shared="sharing-pinterest-464305" class="share-pinterest sd-button share-icon" href="http://www.steelersdepot.com/2017/06/2017-offseason-questions-recent-draft-pick-biggest-letdown/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span>Pinterest</span></a></li><li class="share-end"></li></ul></div></div></div><div class="entry-tags clearfix"><span>TOPICS:</span><a href="http://www.steelersdepot.com/tag/curtis-brown/" rel="tag">Curtis Brown</a></div></div> </article><div class="mh-share-buttons mh-group"><div class="mh-col mh-1-4 mh-facebook"> <a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=http://www.steelersdepot.com/2017/06/2017-offseason-questions-recent-draft-pick-biggest-letdown/&t=2017 Offseason Questions: What Recent Draft Pick Was Your Biggest Letdown?', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><span class="mh-share-button"><i class="fa fa-facebook fa-2x"></i>SHARE</span></a></div><div class="mh-col mh-1-4 mh-twitter"> <a href="#" onclick="window.open('http://twitter.com/share?text=2017 Offseason Questions: What Recent Draft Pick Was Your Biggest Letdown? -&url=http://www.steelersdepot.com/2017/06/2017-offseason-questions-recent-draft-pick-biggest-letdown/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><span class="mh-share-button"><i class="fa fa-twitter fa-2x"></i>TWEET</span></a></div><div class="mh-col mh-1-4 mh-pinterest"> <a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=http://www.steelersdepot.com/2017/06/2017-offseason-questions-recent-draft-pick-biggest-letdown/&media=http://www.steelersdepot.com/wp-content/uploads/2017/06/Curtis-Brown-Ravens.jpg&description=2017 Offseason Questions: What Recent Draft Pick Was Your Biggest Letdown?', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><span class="mh-share-button"><i class="fa fa-pinterest fa-2x"></i>PIN</span></a></div><div class="mh-col mh-1-4 mh-googleplus"> <a href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=http://www.steelersdepot.com/2017/06/2017-offseason-questions-recent-draft-pick-biggest-letdown/', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank"><span class="mh-share-button"><i class="fa fa-google-plus fa-2x"></i>SHARE</span></a></div></div>			<nav class="post-nav-wrap" role="navigation"><ul class="post-nav clearfix"><li class="post-nav-prev"> <a href="http://www.steelersdepot.com/2017/06/2017-steelers-dont-many-air-miles-go-sleep/" rel="prev"><i class="fa fa-chevron-left"></i>Previous post</a></li><li class="post-nav-next"> <a href="http://www.steelersdepot.com/2017/06/zachary-orrs-free-agency-visit-tour-may-not-include-trip-back-baltimore/" rel="next">Next post<i class="fa fa-chevron-right"></i></a></li></ul> </nav><h4 class="widget-title"><span>About the Author</span></h4> <section class="author-box clearfix"><div class="author-box-avatar"><a href="http://www.steelersdepot.com/author/matthew-marczi/"><img alt='' src='http://1.gravatar.com/avatar/7fa7ee85674b58205a210a9bb2891f7d?s=100&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/7fa7ee85674b58205a210a9bb2891f7d?s=200&amp;d=mm&amp;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' /></a></div><h5 class="author-box-name"><a href="http://www.steelersdepot.com/author/matthew-marczi/">Matthew Marczi</a></h5><div class="author-box-desc">Passionate Steelers fan with a bit of writing ability. Connoisseur of loud music. Follow me on Twitter @mmarczi.</div> </section><div id="disqus_thread"><div id="dsq-content"><ul id="dsq-comments"><li class="comment even thread-even depth-1" id="dsq-comment-682263"><div id="dsq-comment-header-682263" class="dsq-comment-header"> <cite id="dsq-cite-682263"> <span id="dsq-author-user-682263">Steve</span> </cite></div><div id="dsq-comment-body-682263" class="dsq-comment-body"><div id="dsq-comment-message-682263" class="dsq-comment-message"><p>IMHO &#8211; Jarvis Jones was the biggest miss for the Steelers in the draft. Also Was very surprised when Jason Worlds retired. Just in his prime. Hopefully someday he has no regrets.</p></div></div></li><li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-682265"><div id="dsq-comment-header-682265" class="dsq-comment-header"> <cite id="dsq-cite-682265"> <span id="dsq-author-user-682265">steelpastor</span> </cite></div><div id="dsq-comment-body-682265" class="dsq-comment-body"><div id="dsq-comment-message-682265" class="dsq-comment-message"><p>Uncle Jarvis for certain.</p></div></div></li><li class="comment even thread-even depth-1" id="dsq-comment-682266"><div id="dsq-comment-header-682266" class="dsq-comment-header"> <cite id="dsq-cite-682266"> <span id="dsq-author-user-682266">Jake Marion</span> </cite></div><div id="dsq-comment-body-682266" class="dsq-comment-body"><div id="dsq-comment-message-682266" class="dsq-comment-message"><p>Mike Adams the tackle.</p></div></div></li><li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-682267"><div id="dsq-comment-header-682267" class="dsq-comment-header"> <cite id="dsq-cite-682267"> <span id="dsq-author-user-682267">The Tony</span> </cite></div><div id="dsq-comment-body-682267" class="dsq-comment-body"><div id="dsq-comment-message-682267" class="dsq-comment-message"><p>Limas Sweed all day</p></div></div></li><li class="comment even thread-even depth-1" id="dsq-comment-682268"><div id="dsq-comment-header-682268" class="dsq-comment-header"> <cite id="dsq-cite-682268"> <span id="dsq-author-user-682268">Marcel Chris Chauvet</span> </cite></div><div id="dsq-comment-body-682268" class="dsq-comment-body"><div id="dsq-comment-message-682268" class="dsq-comment-message"><p>I&#8217;ll absolutely second that oponion.</p></div></div></li><li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-682269"><div id="dsq-comment-header-682269" class="dsq-comment-header"> <cite id="dsq-cite-682269"> <span id="dsq-author-user-682269">falconsaftey43</span> </cite></div><div id="dsq-comment-body-682269" class="dsq-comment-body"><div id="dsq-comment-message-682269" class="dsq-comment-message"><p>For me, it&#8217;d have to be Cortez Allen. Not even just from when he was drafted, but for the first several years of his career he looked very promising in his role. Then he got an extension, accumulated a lot of minor injuries, and just fell off a cliff.</p><p>Curtis Brown, Doran Grant, and Shamarko Thomas also got consideration from me.</p></div></div></li><li class="comment even thread-even depth-1" id="dsq-comment-682271"><div id="dsq-comment-header-682271" class="dsq-comment-header"> <cite id="dsq-cite-682271"> <span id="dsq-author-user-682271">falconsaftey43</span> </cite></div><div id="dsq-comment-body-682271" class="dsq-comment-body"><div id="dsq-comment-message-682271" class="dsq-comment-message"><p>How about Limas Sweed!? So many were pumped when we got him. Thought he was a steal in the 2nd. Then he turned out to be a complete bust, not even a rosterable player.</p></div></div></li><li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-682273"><div id="dsq-comment-header-682273" class="dsq-comment-header"> <cite id="dsq-cite-682273"> <span id="dsq-author-user-682273">dany</span> </cite></div><div id="dsq-comment-body-682273" class="dsq-comment-body"><div id="dsq-comment-message-682273" class="dsq-comment-message"><p>Same here. He practically killed my enthusiasm for all draft picks and I&#8217;m mostly a pessimist about them until they show something, and he was drafted almost ten years ago!</p></div></div></li><li class="comment even thread-even depth-1" id="dsq-comment-682276"><div id="dsq-comment-header-682276" class="dsq-comment-header"> <cite id="dsq-cite-682276"> <span id="dsq-author-user-682276">Ed Smith</span> </cite></div><div id="dsq-comment-body-682276" class="dsq-comment-body"><div id="dsq-comment-message-682276" class="dsq-comment-message"><p>2 letters: JJ &#8211; all day long&#8230; #1 pick, all kinds of &#8220;production&#8221; in college and absolutely NOTHING at the NFL level. My Daughter played soccer at UGA while he was there and got to watch him a lot. Quintessential bust&#8230;</p></div></div></li><li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-682281"><div id="dsq-comment-header-682281" class="dsq-comment-header"> <cite id="dsq-cite-682281"> <span id="dsq-author-user-682281">tcirish53@gmail.com</span> </cite></div><div id="dsq-comment-body-682281" class="dsq-comment-body"><div id="dsq-comment-message-682281" class="dsq-comment-message"><p>To me, recent is the last five years.<br /> Using this, I would say either Dri Archer or Golson.<br /> I know JJones name will come up in this discussion but (although a huge disappointment as a pass rusher) he actually PLAYED and was solid vs the run and in coverage.<br /> I have a sneaking feeling that Golson will pan out to a degree so that would leave Dri Archer.</p></div></div></li><li class="comment even thread-even depth-1" id="dsq-comment-682282"><div id="dsq-comment-header-682282" class="dsq-comment-header"> <cite id="dsq-cite-682282"> <span id="dsq-author-user-682282">tcirish53@gmail.com</span> </cite></div><div id="dsq-comment-body-682282" class="dsq-comment-body"><div id="dsq-comment-message-682282" class="dsq-comment-message"><p>Good one!!</p></div></div></li></ul></div></div> <script type="text/javascript">/*<![CDATA[*/var disqus_url='http://www.steelersdepot.com/2017/06/2017-offseason-questions-recent-draft-pick-biggest-letdown/';var disqus_identifier='464305 http://www.steelersdepot.com/?p=464305';var disqus_container_id='disqus_thread';var disqus_shortname='steelersdepot';var disqus_title="2017 Offseason Questions: What Recent Draft Pick Was Your Biggest Letdown?";var disqus_config_custom=window.disqus_config;var disqus_config=function(){this.language='';this.callbacks.onReady.push(function(){var script=document.createElement('script');script.async=true;script.src='?cf_action=sync_comments&post_id=464305';var firstScript=document.getElementsByTagName('script')[0];firstScript.parentNode.insertBefore(script,firstScript);});if(disqus_config_custom){disqus_config_custom.call(this);}};(function(){var dsq=document.createElement('script');dsq.type='text/javascript';dsq.async=true;dsq.src='//'+disqus_shortname+'.disqus.com/embed.js';(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(dsq);})();/*]]>*/</script> </div> <aside class="mh-sidebar"><div class="sb-widget clearfix"><div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-7138622909378284" data-ad-slot="6153397631" data-ad-format="auto"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div></div><div class="sb-widget clearfix"><div class="textwidget"><p><script id="mNCC" language="javascript">/*<![CDATA[*/medianet_width="300";medianet_height="250";medianet_crid="586365717";medianet_versionId="111299";(function(){var isSSL='https:'==document.location.protocol;var mnSrc=(isSSL?'https:':'http:')+'//contextual.media.net/nmedianet.js?cid=8CU2WB7LL'+(isSSL?'&https=1':'');document.write('<scr'+'ipt type="text/javascript" id="mNSC" src="'+mnSrc+'"></scr'+'ipt>');})();/*]]>*/</script></p></div></div><div class="sb-widget clearfix"><div id="inner-taboola-3"></div><script type="text/javascript">window._taboola=window._taboola||[];_taboola.push({mode:'thumbnails-rr',container:'inner-taboola-3',placement:'sidebar-3',target_type:'mix'});</script></div><div class="sb-widget clearfix"><ul class="mh-rp-widget widget-list"><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2017/06/2017-steelers-stock-watch-cb-artie-burns-stock/" title="2017 Steelers Stock Watch – CB Artie Burns – Stock Up" rel="bookmark">2017 Steelers Stock Watch – CB Artie Burns – Stock Up</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2017/06/paper-steelers-wr-stacked-top-bottom/" title="On Paper, Steelers WR Stacked From Top To Bottom" rel="bookmark">On Paper, Steelers WR Stacked From Top To Bottom</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2017/06/zachary-orrs-free-agency-visit-tour-may-not-include-trip-back-baltimore/" title="Zachary Orr&#8217;s Free Agency Visit Tour May Not Include Trip Back To Baltimore" rel="bookmark">Zachary Orr&#8217;s Free Agency Visit Tour May Not Include Trip Back To Baltimore</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2017/06/2017-offseason-questions-recent-draft-pick-biggest-letdown/" title="2017 Offseason Questions: What Recent Draft Pick Was Your Biggest Letdown?" rel="bookmark">2017 Offseason Questions: What Recent Draft Pick Was Your Biggest Letdown?</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2017/06/2017-steelers-dont-many-air-miles-go-sleep/" title="2017 Steelers Don&#8217;t Have Many Air Miles To Go Before They Sleep" rel="bookmark">2017 Steelers Don&#8217;t Have Many Air Miles To Go Before They Sleep</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2017/06/pff-roethlisberger-led-nfl-deep-passing-tds-2016/" title="PFF: Roethlisberger Led NFL In Deep Passing TDs In 2016" rel="bookmark">PFF: Roethlisberger Led NFL In Deep Passing TDs In 2016</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2017/06/one-nfl-analyst-believes-steelers-title-worthy-defense/" title="One NFL Analyst Believes Steelers Have Title-Worthy Defense" rel="bookmark">One NFL Analyst Believes Steelers Have Title-Worthy Defense</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2017/06/grass-aint-always-greener-post-steelers-career-terence-garvin/" title="Grass Ain&#8217;t Always Greener &#8211; Post-Steelers Career Of Terence Garvin" rel="bookmark">Grass Ain&#8217;t Always Greener &#8211; Post-Steelers Career Of Terence Garvin</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2017/06/steelers-contract-look-back-kent-graham-2000-signing/" title="Steelers Contract Look-Back: Kent Graham 2000 Signing" rel="bookmark">Steelers Contract Look-Back: Kent Graham 2000 Signing</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2017/06/ask-alex-steelers-mailbag-83/" title="Ask Alex: Steelers&#8217; Mailbag" rel="bookmark">Ask Alex: Steelers&#8217; Mailbag</a></li></ul></div><div class="sb-widget clearfix"><div class="textwidget"><center><a target="_blank" href="http://shareasale.com/r.cfm?b=537844&amp;u=275818&amp;m=7124&amp;urllink=&amp;afftrack="><img src="http://static.shareasale.com/image/7124/NFL_Pittsburg_Steelers_300x250.jpg" border="0" alt="Shop the newest Pittsburgh Steelers fan gear at Fanatics!" /></a></center></div></div></aside></div></div> <footer class="mh-footer"><div class="wrapper-inner clearfix"></div><div class="footer-bottom"><div class="wrapper-inner clearfix"><div class="copyright-wrap"><p class="copyright">Copyright 2017 | Theme by <a href="http://spencer.vegas/" title="Las Vegas WordPress">WordPress</a> | <a href="http://www.steelersdepot.com/privacy-policy/" title="Privacy Policy" rel="nofollow">Privacy Policy</a></p></div><div class="sv-footer">Optimized by <a href="http://spencer.vegas/" title="Las Vegas WordPress">Las Vegas WordPress</a></div></div></div> </footer> <script type="text/javascript">/*<![CDATA[*/var disqus_shortname='steelersdepot';(function(){var nodes=document.getElementsByTagName('span');for(var i=0,url;i<nodes.length;i++){if(nodes[i].className.indexOf('dsq-postid')!=-1&&nodes[i].parentNode.tagName=='A'){nodes[i].parentNode.setAttribute('data-disqus-identifier',nodes[i].getAttribute('data-dsqidentifier'));url=nodes[i].parentNode.href.split('#',1);if(url.length==1){url=url[0];}
else{url=url[1];}
nodes[i].parentNode.href=url+'#disqus_thread';}}
var s=document.createElement('script');s.async=true;s.type='text/javascript';s.src='//'+disqus_shortname+'.disqus.com/count.js';(document.getElementsByTagName('HEAD')[0]||document.getElementsByTagName('BODY')[0]).appendChild(s);}());/*]]>*/</script> <script type="text/javascript">var sectionCode=sectionCode||[];sectionCode.push("a70f4eaa-a346-43eb-98ae-f8e6526f5f12");(function(){var script=document.createElement("script");script.async=true;script.src="https://s.yimg.com/av/gemini/ga/gemini.js";document.body.appendChild(script);})();</script><script type='text/javascript'>window._taboola=window._taboola||[];_taboola.push({flush:true});</script> <script type="text/javascript">window.WPCOM_sharing_counts={"http:\/\/www.steelersdepot.com\/2017\/06\/2017-offseason-questions-recent-draft-pick-biggest-letdown\/":464305};</script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-content/plugins/wordpress-post-tabs/js/jquery.posttabs.js?ver=1.6.2'></script> <script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201726'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-content/themes/mh_newsdesk/js/scripts.js?ver=4.8'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-content/plugins/simple-social-icons/svgxuse.js?ver=1.1.21'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-includes/js/wp-embed.min.js?ver=4.8'></script> <script type='text/javascript'>var sharing_js_options={"lang":"en","counts":"1"};</script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=5.0'></script> <script type='text/javascript'>var windowOpen;jQuery(document.body).on('click','a.share-twitter',function(){if('undefined'!==typeof windowOpen){windowOpen.close();}
windowOpen=window.open(jQuery(this).attr('href'),'wpcomtwitter','menubar=1,resizable=1,width=600,height=350');return false;});var windowOpen;jQuery(document.body).on('click','a.share-facebook',function(){if('undefined'!==typeof windowOpen){windowOpen.close();}
windowOpen=window.open(jQuery(this).attr('href'),'wpcomfacebook','menubar=1,resizable=1,width=600,height=400');return false;});var windowOpen;jQuery(document.body).on('click','a.share-google-plus-1',function(){if('undefined'!==typeof windowOpen){windowOpen.close();}
windowOpen=window.open(jQuery(this).attr('href'),'wpcomgoogle-plus-1','menubar=1,resizable=1,width=480,height=550');return false;});</script> <script type="text/javascript" id="slb_context">if(!!window.jQuery){(function($){$(document).ready(function(){if(!!window.SLB){{$.extend(SLB,{"context":["public","user_guest"]});}}})})(jQuery);}</script> <script type='text/javascript' src='https://stats.wp.com/e-201726.js' async defer></script> <script type='text/javascript'>_stq=window._stq||[];_stq.push(['view',{v:'ext',j:'1:5.0',blog:'12286105',post:'464305',tz:'-5',srv:'www.steelersdepot.com'}]);_stq.push(['clickTrackerInit','12286105','464305']);</script> </body></html>