<!DOCTYPE html><html class="no-js" lang="en-US" prefix="og: http://ogp.me/ns#"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1.0"><link rel="profile" href="http://gmpg.org/xfn/11" /><link rel="pingback" href="http://www.steelersdepot.com/xmlrpc.php" /><title>Steelers Film Room: 2016 Joe Haden Vs Odell Beckham Jr. Matchup - Steelers Depot</title><meta name="description" content="“To be the man, you got to beat the man.” A phrase not only made famous by wrestling icon Ric Flair but also a very important quote relatable to new Pittsb"/><link rel="canonical" href="http://www.steelersdepot.com/2017/09/steelers-film-room-2016-joe-haden-vs-odell-beckham-jr-matchup/" /><link rel="publisher" href="https://plus.google.com/+DaveBryan"/><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Steelers Film Room: 2016 Joe Haden Vs Odell Beckham Jr. Matchup - Steelers Depot" /><meta property="og:description" content="“To be the man, you got to beat the man.” A phrase not only made famous by wrestling icon Ric Flair but also a very important quote relatable to new Pittsb" /><meta property="og:url" content="http://www.steelersdepot.com/2017/09/steelers-film-room-2016-joe-haden-vs-odell-beckham-jr-matchup/" /><meta property="og:site_name" content="Steelers Depot" /><meta property="article:tag" content="animated gifs" /><meta property="article:tag" content="Joe Haden" /><meta property="article:tag" content="Odell Beckham Jr." /><meta property="article:section" content="Article" /><meta property="article:published_time" content="2017-09-06T11:13:30+00:00" /><meta property="og:image" content="http://www.steelersdepot.com/wp-content/uploads/2017/09/haden-beckham-2016.jpg" /><meta property="og:image:width" content="777" /><meta property="og:image:height" content="491" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="“To be the man, you got to beat the man.” A phrase not only made famous by wrestling icon Ric Flair but also a very important quote relatable to new Pittsb" /><meta name="twitter:title" content="Steelers Film Room: 2016 Joe Haden Vs Odell Beckham Jr. Matchup - Steelers Depot" /><meta name="twitter:site" content="@Steelersdepot" /><meta name="twitter:image" content="http://www.steelersdepot.com/wp-content/uploads/2017/09/haden-beckham-2016.jpg" /><meta name="twitter:creator" content="@Steelersdepot" /> <script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"http:\/\/www.steelersdepot.com\/","name":"Steeles Depot","potentialAction":{"@type":"SearchAction","target":"http:\/\/www.steelersdepot.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script> <script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","url":"http:\/\/www.steelersdepot.com\/2017\/09\/steelers-film-room-2016-joe-haden-vs-odell-beckham-jr-matchup\/","sameAs":["https:\/\/plus.google.com\/+DaveBryan","https:\/\/twitter.com\/Steelersdepot"],"@id":"#organization","name":"Steelers Depot","logo":"http:\/\/www.steelersdepot.com\/wp-content\/uploads\/2015\/07\/SteelersDepot.jpg"}</script> <link rel='dns-prefetch' href='//www.steelersdepot.com' /><link rel='dns-prefetch' href='//s0.wp.com' /><link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Steelers Depot &raquo; Feed" href="http://www.steelersdepot.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Steelers Depot &raquo; Comments Feed" href="http://www.steelersdepot.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Steelers Depot &raquo; Steelers Film Room: 2016 Joe Haden Vs Odell Beckham Jr. Matchup Comments Feed" href="http://www.steelersdepot.com/2017/09/steelers-film-room-2016-joe-haden-vs-odell-beckham-jr-matchup/feed/" /> <script type="text/javascript">/*<![CDATA[*/window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.steelersdepot.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.1"}};!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);/*]]>*/</script> <style type="text/css">img.wp-smiley,img.emoji{display:inline !important;border:none !important;box-shadow:none !important;height:1em !important;width:1em !important;margin:0
.07em !important;vertical-align:-0.1em !important;background:none !important;padding:0
!important}</style><link rel='stylesheet' id='simple-payments-css'  href='http://www.steelersdepot.com/wp-content/plugins/jetpack/modules/simple-payments/simple-payments.css?ver=4.8.1' type='text/css' media='all' /><link rel='stylesheet' id='wpts_ui_css-css'  href='http://www.steelersdepot.com/wp-content/plugins/wordpress-post-tabs/css/styles/default/style.css?ver=1.6.2' type='text/css' media='all' /><link rel='stylesheet' id='wp-pagenavi-css'  href='http://www.steelersdepot.com/wp-content/plugins/wp-pagenavi/pagenavi-css.css?ver=2.70' type='text/css' media='all' /><link rel='stylesheet' id='parent-style-css'  href='http://www.steelersdepot.com/wp-content/themes/mh_newsdesk/style.css?ver=4.8.1' type='text/css' media='all' /><link rel='stylesheet' id='mh-style-css'  href='http://www.steelersdepot.com/wp-content/themes/mh_newsdesk-child/style.css?ver=1.1.0' type='text/css' media='all' /><link rel='stylesheet' id='mh-font-awesome-css'  href='//maxcdn.bootstrapcdn.com/font-awesome/4.3.0/css/font-awesome.min.css' type='text/css' media='all' /><link rel='stylesheet' id='mh-google-fonts-css'  href='//fonts.googleapis.com/css?family=PT+Serif:300,400,400italic,600,700|Oswald:300,400,400italic,600,700' type='text/css' media='all' /><link rel='stylesheet' id='simple-social-icons-font-css'  href='http://www.steelersdepot.com/wp-content/plugins/simple-social-icons/css/style.css?ver=2.0.1' type='text/css' media='all' /><link rel='stylesheet' id='slb_core-css'  href='http://www.steelersdepot.com/wp-content/plugins/simple-lightbox/client/css/app.css?ver=2.6.0' type='text/css' media='all' /><link rel='stylesheet' id='social-logos-css'  href='http://www.steelersdepot.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' /><link rel='stylesheet' id='open-sans-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C300%2C400%2C600&#038;subset=latin%2Clatin-ext&#038;ver=4.8.1' type='text/css' media='all' /><link rel='stylesheet' id='jetpack_css-css'  href='http://www.steelersdepot.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.2.1' type='text/css' media='all' /><link rel='https://api.w.org/' href='http://www.steelersdepot.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.steelersdepot.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.steelersdepot.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 4.8.1" /><link rel='shortlink' href='http://wp.me/pPyaZ-1Yes' /><link rel="alternate" type="application/json+oembed" href="http://www.steelersdepot.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.steelersdepot.com%2F2017%2F09%2Fsteelers-film-room-2016-joe-haden-vs-odell-beckham-jr-matchup%2F" /><link rel="alternate" type="text/xml+oembed" href="http://www.steelersdepot.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.steelersdepot.com%2F2017%2F09%2Fsteelers-film-room-2016-joe-haden-vs-odell-beckham-jr-matchup%2F&#038;format=xml" /> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>(adsbygoogle=window.adsbygoogle||[]).push({google_ad_client:"ca-pub-7138622909378284",enable_page_level_ads:true});</script> <script data-cfasync="false" type="text/javascript">(function(w,d){var s=d.createElement('script');s.src='//delivery.adrecover.com/15913/adRecover.js';s.type='text/javascript';s.async=true;(d.getElementsByTagName('head')[0]||d.getElementsByTagName('body')[0]).appendChild(s);})(window,document);</script><script type='text/javascript'>window._taboola=window._taboola||[];_taboola.push({article:'auto'});_taboola.push({listenTo:'render',handler:function(p){TRC.modDebug.logMessageToServer(2,"wordpress-integ");}});_taboola.push({additional_data:{sdkd:{"os":"Wordpress","osv":"4.8.1","sdkt":"Taboola Wordpress Plugin","sdkv":"1.0.9"}}});!function(e,f,u){e.async=1;e.src=u;f.parentNode.insertBefore(e,f);}(document.createElement('script'),document.getElementsByTagName('script')[0],'//cdn.taboola.com/libtrc/steelersdepot/loader.js');</script><style type='text/css'>img#wpstats{display:none}</style><style type="text/css">.social-nav a:hover, .logo-title, .entry-content a, a:hover, .entry-meta .entry-meta-author, .entry-meta a, .comment-info, blockquote, .pagination a:hover
.pagelink{color:#f1c000}.main-nav li:hover, .slicknav_menu, .ticker-title, .breadcrumb a, .breadcrumb .bc-text, .button span, .widget-title span, input[type=submit], table th, .comment-section-title .comment-count, #cancel-comment-reply-link:hover, .pagination .current, .pagination
.pagelink{background:#f1c000}blockquote,input[type=text]:hover,input[type=email]:hover,input[type=tel]:hover,input[type=url]:hover,textarea:hover{border-color:#f1c000}.widget-title, .pagination a.page-numbers:hover, .dots:hover, .pagination a:hover .pagelink,.comment-section-title{background:#000}.commentlist .depth-1, .commentlist .bypostauthor
.avatar{border-color:#000}.main-nav, .main-nav ul li:hover>ul,.mh-footer{background:#000}.header-top, .header-nav ul li:hover>ul,.footer-ad-wrap,.footer-1,.footer-2,.footer-3,.footer-bottom{background:#000}.social-nav
a{color:#000}.footer-widgets .widget-title{background:#000}</style><link rel="shortcut icon" href="http://www.steelersdepot.com/wp-content/uploads/2015/07/favicon.ico"> <!--[if lt IE 9]> <script src="http://www.steelersdepot.com/wp-content/themes/mh_newsdesk/js/css3-mediaqueries.js"></script> <![endif]--><style type="text/css" media="screen">.simple-social-icons ul li a, .simple-social-icons ul li a:hover, .simple-social-icons ul li a:focus{background-color:#999 !important;border-radius:3px;color:#fff !important;border:0px
#fff solid !important;font-size:18px;padding:9px}.simple-social-icons ul li a:hover, .simple-social-icons ul li a:focus{background-color:#666 !important;border-color:#fff !important;color:#fff !important}.simple-social-icons ul li a:focus{outline:1px
dotted #666 !important}</style></head><body class="post-template-default single single-post postid-469864 single-format-standard mh-right-sb"><div id="mh-wrapper"> <header class="mh-header"><div class="header-wrap clearfix"><div class="mh-col mh-1-3 header-logo"> <a href="http://www.steelersdepot.com/" title="Steelers Depot" rel="home"><div class="logo-wrap" role="banner"> <img src="http://www.steelersdepot.com/wp-content/uploads/2015/07/cropped-cropped-depot-logo1.png" height="100" width="384" alt="Steelers Depot" /></div> </a></div> <aside class="mh-col mh-2-3"><div class="header-ad"><div class="textwidget"><p><script id="mNCC" language="javascript">/*<![CDATA[*/medianet_width="728";medianet_height="90";medianet_crid="782279489";medianet_versionId="111299";(function(){var isSSL='https:'==document.location.protocol;var mnSrc=(isSSL?'https:':'http:')+'//contextual.media.net/nmedianet.js?cid=8CU2WB7LL'+(isSSL?'&https=1':'');document.write('<scr'+'ipt type="text/javascript" id="mNSC" src="'+mnSrc+'"></scr'+'ipt>');})();/*]]>*/</script></p></div></div></aside></div><div class="header-menu clearfix"> <nav class="main-nav clearfix"><div class="menu-header-container"><ul id="menu-header" class="menu"><li id="menu-item-37673" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-37673"><a href="http://www.steelersdepot.com">Home</a></li><li id="menu-item-154806" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154806"><a href="http://www.steelersdepot.com/category/news/">Steelers News</a></li><li id="menu-item-38055" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38055"><a href="http://www.steelersdepot.com/steelers-news/">Steelers Wire</a></li><li id="menu-item-163626" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-163626"><a href="http://www.steelersdepot.com/category/podcast/">Podcast</a></li><li id="menu-item-38056" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38056"><a href="http://www.shareasale.com/r.cfm?b=375840&#038;u=275818&#038;m=7124&#038;urllink=&#038;afftrack=">Steelers Merchandise</a></li><li id="menu-item-38057" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38057"><a href="http://www.jdoqocy.com/click-2334271-10858765?sid=&#038;url=http://www.ticketliquidator.com/tix/Pittsburgh-Steelers-tickets.aspx?utm_source=CJID&#038;utm_medium=2334271">Tickets</a></li><li id="menu-item-240752" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-240752"><a>NFL Draft Info</a><ul class="sub-menu"><li id="menu-item-456507" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-456507"><a href="http://www.steelersdepot.com/2017-nfl-scouting-combine-results-tracker/">2017 NFL Combine Results</a></li><li id="menu-item-240753" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-240753"><a href="http://www.steelersdepot.com/2016/03/steelers-2016-pre-draft-visit-tracker/">2016 Pre-Draft Visits</a></li><li id="menu-item-225936" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-225936"><a title="2016 NFL Combine Results" href="http://www.steelersdepot.com/2016-nfl-scouting-combine-results/">2016 NFL Combine Results</a></li></ul></li><li id="menu-item-38058" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38058"><a href="http://www.dpbolvw.net/click-2334271-10539967?url=http%3A%2F%2Fwww.zinio.com%2Fwww%2Fbrowse%2Fproduct.jsp%3FproductId%3D500215550%26affId%3Dcj%26rf%3Dcjaffcatalog&#038;cjsku=500073101">Steelers Digest</a></li><li id="menu-item-158274" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-158274"><a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&#038;hosted_button_id=XZ97MFHPQZYX4">Donate</a></li></ul></div>		</nav><div class="header-sub clearfix"> <section id="ticker" class="news-ticker mh-col mh-2-3 clearfix"> <span class="ticker-title">Hot Topics</span><ul class="ticker-content"></ul> </section>						<aside class="mh-col mh-1-3 header-search"><form role="search" method="get" class="search-form" action="http://www.steelersdepot.com/"> <label> <span class="screen-reader-text">Search for:</span> <input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" /> </label> <input type="submit" class="search-submit" value="Search" /></form>			</aside></div></div> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');ga('create','UA-11437002-3','auto');ga('send','pageview');</script> </header><div class="mh-section mh-group"><div id="main-content" class="mh-content"> <nav class="breadcrumb"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="http://www.steelersdepot.com" itemprop="url" class="bc-home"><span itemprop="title">Home</span></a></span> <span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="http://www.steelersdepot.com/category/article/" itemprop="url"><span itemprop="title">Article</span></a></span></nav> <article id="post-469864" class="post-469864 post type-post status-publish format-standard has-post-thumbnail hentry category-article tag-animated-gifs tag-joe-haden tag-odell-beckham-jr"> <header class="entry-header clearfix"><h1 class="entry-title">Steelers Film Room: 2016 Joe Haden Vs Odell Beckham Jr. Matchup</h1> </header><div class="entry-thumbnail"> <img width="777" height="437" src="http://www.steelersdepot.com/wp-content/uploads/2017/09/haden-beckham-2016-777x437.jpg" class="attachment-content-single size-content-single wp-post-image" alt="" srcset="http://www.steelersdepot.com/wp-content/uploads/2017/09/haden-beckham-2016-777x437.jpg 777w, http://www.steelersdepot.com/wp-content/uploads/2017/09/haden-beckham-2016-180x101.jpg 180w, http://www.steelersdepot.com/wp-content/uploads/2017/09/haden-beckham-2016-260x146.jpg 260w, http://www.steelersdepot.com/wp-content/uploads/2017/09/haden-beckham-2016-373x210.jpg 373w, http://www.steelersdepot.com/wp-content/uploads/2017/09/haden-beckham-2016-120x67.jpg 120w" sizes="(max-width: 777px) 100vw, 777px" /></div><p class="entry-meta"> <span class="entry-meta-author vcard author">By <a class="fn" href="http://www.steelersdepot.com/author/daniel-waterman/">Daniel Valente</a></span> <span class="entry-meta-date updated">September 6, 2017 at 11:13 am</span></p><div class="entry-content clearfix"> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-7138622909378284" data-ad-slot="9778711637" data-ad-format="auto"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script> <br><p>“To be the man, you got to beat the man.” A phrase not only made famous by wrestling icon <strong>Ric Flair</strong> but also a very important quote relatable to new <strong>Pittsburgh Steelers</strong>’ cornerback <strong>Joe Haden. </strong>Due to past accolades and being signed to a contract that could pay him a total of $27 million, many are counting on Haden to be the man in the Steelers’ young secondary.</p><p>While Haden’s first test to be the man in Pittsburgh will come next Sunday against his former team – the<strong> Cleveland Browns</strong>, he has had his fair share of main event matchups over his career. One in particular that stands out is last season’s matchup against the <strong>New York Giants</strong> and wide receiver <strong>Odell Beckham Jr</strong>.</p><p>One of the top receivers in the game today, Beckham was just the test Haden needed to see if the former Browns’ cornerback could still hang with the best of them. And while Beckham looked like the decisive winner on paper – finishing with six receptions for 96 yards and 2 touchdowns, the film shows that this was a much closer contest than it appeared.</p><p><img class="aligncenter size-full" src="http://giant.gfycat.com/ColorfulPitifulEquine.gif" width="575" height="327" /></p><p>The Giants go for the big blow early with a deep pass down the right sideline to Beckham but Haden is able to recover quickly and break it up. Great awareness and anticipation from the Pro Bowl corner to break up the pass from Giants quarterback <strong>Eli Manning</strong>.</p><div class="xkZlDp9i" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-7138622909378284" data-ad-slot="6153397631" data-ad-format="auto"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script> <br></div><p><img class="aligncenter size-full" src="http://giant.gfycat.com/FriendlySkeletalFerret.gif" width="575" height="327" /></p><p>Beckham is able to get one back on Haden by converting an early third down in the first quarter. Facing third and five, Beckham uses a nifty outside release and works his way back to the play to convert. Haden is unfortunately stranded in no man’s land as Manning puts the ball in a place where only Beckham can make a play.</p><p><img class="aligncenter size-full" src="http://giant.gfycat.com/DevotedOfficialAnophelesmosquito.gif" width="575" height="327" /></p><p>Beckham finally connects with the big blow here, turning a short pass into a 32-yard touchdown. Lined up on the left side of the offense, Beckham runs a drag route and uses his speed to outrace Haden towards the sideline. With a final chance to limit the damage, Haden falls flat on his attempt to bring down Beckham and is forced to watch the Giants receiver scamper towards the end zone.</p><p><img class="aligncenter size-full" src="http://giant.gfycat.com/FeminineSoulfulBandicoot.gif" width="575" height="327" /></p><p>Not ready to allow a second touchdown to Beckham, Haden sticks to the Giants receiver through traffic, forcing him into a very unlikely position to score. Beckham even gets away with a shove on Haden in the back corner of the end zone but is still unable to make the catch.</p><p><img class="aligncenter size-full" src="http://giant.gfycat.com/WillingPessimisticBlackfootedferret.gif" width="575" height="327" /></p><p>With the score tied, Beckham takes the last point in a winner takes all scenario. Lined up in the slot, Beckham uses a double move to work his way back to the middle of the field to make the catch. Though Haden is not a headless chicken in coverage, his speed and quickness is no match for Beckham.</p><p>While Beckham came out victorious, the performance between the two was not as separated as the box score would make it appear. A couple missed tackles is likely the difference between a breakout day by Beckham and a modest stat line.</p><p>Though the argument can be made that Haden’s 2016 season may be skewed due to two notable groin injuries, it will harder to give the new cornerback a hall pass again should he want to be the man in a young Steelers’ secondary. Fortunately, as the tape shows there are still glimpses of a dominant Haden waiting to be extracted.</p><div id='taboola-below-article'></div><script type='text/javascript'>window._taboola=window._taboola||[];_taboola.push({mode:'thumbnails-a',container:'taboola-below-article',placement:'below-article',target_type:'mix'});</script><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-469864" class="share-twitter sd-button share-icon" href="http://www.steelersdepot.com/2017/09/steelers-film-room-2016-joe-haden-vs-odell-beckham-jr-matchup/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-469864" class="share-facebook sd-button share-icon" href="http://www.steelersdepot.com/2017/09/steelers-film-room-2016-joe-haden-vs-odell-beckham-jr-matchup/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-469864" class="share-google-plus-1 sd-button share-icon" href="http://www.steelersdepot.com/2017/09/steelers-film-room-2016-joe-haden-vs-odell-beckham-jr-matchup/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span>Google</span></a></li><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon" href="http://www.steelersdepot.com/2017/09/steelers-film-room-2016-joe-haden-vs-odell-beckham-jr-matchup/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-pinterest"><a rel="nofollow" data-shared="sharing-pinterest-469864" class="share-pinterest sd-button share-icon" href="http://www.steelersdepot.com/2017/09/steelers-film-room-2016-joe-haden-vs-odell-beckham-jr-matchup/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span>Pinterest</span></a></li><li class="share-end"></li></ul></div></div></div><div class="entry-tags clearfix"><span>TOPICS:</span><a href="http://www.steelersdepot.com/tag/animated-gifs/" rel="tag">animated gifs</a><a href="http://www.steelersdepot.com/tag/joe-haden/" rel="tag">Joe Haden</a><a href="http://www.steelersdepot.com/tag/odell-beckham-jr/" rel="tag">Odell Beckham Jr.</a></div></div> </article><div class="mh-share-buttons mh-group"><div class="mh-col mh-1-4 mh-facebook"> <a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=http://www.steelersdepot.com/2017/09/steelers-film-room-2016-joe-haden-vs-odell-beckham-jr-matchup/&t=Steelers Film Room: 2016 Joe Haden Vs Odell Beckham Jr. Matchup', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><span class="mh-share-button"><i class="fa fa-facebook fa-2x"></i>SHARE</span></a></div><div class="mh-col mh-1-4 mh-twitter"> <a href="#" onclick="window.open('http://twitter.com/share?text=Steelers Film Room: 2016 Joe Haden Vs Odell Beckham Jr. Matchup -&url=http://www.steelersdepot.com/2017/09/steelers-film-room-2016-joe-haden-vs-odell-beckham-jr-matchup/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><span class="mh-share-button"><i class="fa fa-twitter fa-2x"></i>TWEET</span></a></div><div class="mh-col mh-1-4 mh-pinterest"> <a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=http://www.steelersdepot.com/2017/09/steelers-film-room-2016-joe-haden-vs-odell-beckham-jr-matchup/&media=http://www.steelersdepot.com/wp-content/uploads/2017/09/haden-beckham-2016.jpg&description=Steelers Film Room: 2016 Joe Haden Vs Odell Beckham Jr. Matchup', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><span class="mh-share-button"><i class="fa fa-pinterest fa-2x"></i>PIN</span></a></div><div class="mh-col mh-1-4 mh-googleplus"> <a href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=http://www.steelersdepot.com/2017/09/steelers-film-room-2016-joe-haden-vs-odell-beckham-jr-matchup/', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank"><span class="mh-share-button"><i class="fa fa-google-plus fa-2x"></i>SHARE</span></a></div></div>			<nav class="post-nav-wrap" role="navigation"><ul class="post-nav clearfix"><li class="post-nav-prev"> <a href="http://www.steelersdepot.com/2017/09/rough-year-steelers-free-agency-departures-bad-news-compensatory-formula/" rel="prev"><i class="fa fa-chevron-left"></i>Previous post</a></li><li class="post-nav-next"> <a href="http://www.steelersdepot.com/2017/09/dulac-steelers-close-reaching-deal-tuitt/" rel="next">Next post<i class="fa fa-chevron-right"></i></a></li></ul> </nav><h4 class="widget-title"><span>About the Author</span></h4> <section class="author-box clearfix"><div class="author-box-avatar"><a href="http://www.steelersdepot.com/author/daniel-waterman/"><img alt='' src='http://0.gravatar.com/avatar/672f722b7b803a56da972a7f16fecb90?s=100&#038;d=mm&#038;r=g' srcset='http://0.gravatar.com/avatar/672f722b7b803a56da972a7f16fecb90?s=200&amp;d=mm&amp;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' /></a></div><h5 class="author-box-name"><a href="http://www.steelersdepot.com/author/daniel-waterman/">Daniel Valente</a></h5><div class="author-box-desc">Steelers fan from birth, spending majority of my free time looking up statistics. Had the honor of meeting Mike Vanderjagt shortly after his infamous missed field goal in the 2005 Divisional Round. Currently pursuing a Journalism degree. Follow me on Twitter @StatsGuyDaniel</div> </section><div id="disqus_thread"><div id="dsq-content"><ul id="dsq-comments"><li class="comment even thread-even depth-1" id="dsq-comment-722758"><div id="dsq-comment-header-722758" class="dsq-comment-header"> <cite id="dsq-cite-722758"> <span id="dsq-author-user-722758">StrengthOfVictory</span> </cite></div><div id="dsq-comment-body-722758" class="dsq-comment-body"><div id="dsq-comment-message-722758" class="dsq-comment-message"><p>In two cases, it looks like fellow Browns defenders were more of an impediment to Haden than Beckham. Definitely encouraging signs&#8230;especially if Joe is healthier this year.</p></div></div></li><li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-722761"><div id="dsq-comment-header-722761" class="dsq-comment-header"> <cite id="dsq-cite-722761"> <span id="dsq-author-user-722761">falconsaftey43</span> </cite></div><div id="dsq-comment-body-722761" class="dsq-comment-body"><div id="dsq-comment-message-722761" class="dsq-comment-message"><p>Encouraging overall I think. Didn&#8217;t get blown past by one of the quickest, fastest, and best route running WRs in the game. Stayed pretty close to him and made some plays on the ball. The curl and drag are the only ones where he gave up decent separation. The last play stick-n-nod up the seam, he&#8217;s close in trail and forces a tight window throw, the safety just completely blows it and never even makes contact with OBJ. That&#8217;s on the safety all the way, it&#8217;s the only vertical route on his side and he is late and completely misses the tackle as well.</p></div></div></li><li class="comment even thread-even depth-1" id="dsq-comment-722763"><div id="dsq-comment-header-722763" class="dsq-comment-header"> <cite id="dsq-cite-722763"> <span id="dsq-author-user-722763">Boots</span> </cite></div><div id="dsq-comment-body-722763" class="dsq-comment-body"><div id="dsq-comment-message-722763" class="dsq-comment-message"><p>We&#8217;ve seen AB take an almost identical crossing route to house against Burns this preseason, so when you go up against one of the best in the game it can happen.  The safeties are as much to blame on the last one as Haden because they HAVE to make that tackle. Again Haden doesn&#8217;t have to be AllPro #1 CB here and try to do too much, he just needs to be a healthier version of last year to be an upgrade and solidify this secondary!</p></div></div></li><li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-722795"><div id="dsq-comment-header-722795" class="dsq-comment-header"> <cite id="dsq-cite-722795"> <span id="dsq-author-user-722795">nutty32</span> </cite></div><div id="dsq-comment-body-722795" class="dsq-comment-body"><div id="dsq-comment-message-722795" class="dsq-comment-message"><p>Does Belichick ever leave any of his corners manned up, single coverage against the other team&#8217;s all-world WR? Only the Browns and Raiders seem to be so stupid on a regular basis.</p></div></div></li><li class="comment even thread-even depth-1" id="dsq-comment-722802"><div id="dsq-comment-header-722802" class="dsq-comment-header"> <cite id="dsq-cite-722802"> <span id="dsq-author-user-722802">falconsaftey43</span> </cite></div><div id="dsq-comment-body-722802" class="dsq-comment-body"><div id="dsq-comment-message-722802" class="dsq-comment-message"><p>IDK. Cover zero is really infrequent. I don&#8217;t think any of these are cover zero (except maybe the one in the endzone). Most appear to be man defense with 1 or 2 safeties over the top, so there is help somewhere. Teams don&#8217;t often &#8220;double&#8221; a WR truly with two guys assigned to him and only him. It&#8217;s more that they have man coverage with zone help around him.</p></div></div></li></ul></div></div> <script type="text/javascript">/*<![CDATA[*/var disqus_url='http://www.steelersdepot.com/2017/09/steelers-film-room-2016-joe-haden-vs-odell-beckham-jr-matchup/';var disqus_identifier='469864 http://www.steelersdepot.com/?p=469864';var disqus_container_id='disqus_thread';var disqus_shortname='steelersdepot';var disqus_title="Steelers Film Room: 2016 Joe Haden Vs Odell Beckham Jr. Matchup";var disqus_config_custom=window.disqus_config;var disqus_config=function(){this.language='';this.callbacks.onReady.push(function(){var script=document.createElement('script');script.async=true;script.src='?cf_action=sync_comments&post_id=469864';var firstScript=document.getElementsByTagName('script')[0];firstScript.parentNode.insertBefore(script,firstScript);});if(disqus_config_custom){disqus_config_custom.call(this);}};(function(){var dsq=document.createElement('script');dsq.type='text/javascript';dsq.async=true;dsq.src='//'+disqus_shortname+'.disqus.com/embed.js';(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(dsq);})();/*]]>*/</script> </div> <aside class="mh-sidebar"><div class="widget_text sb-widget clearfix"><div class="textwidget custom-html-widget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-7138622909378284" data-ad-slot="6153397631" data-ad-format="auto"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div></div><div class="sb-widget clearfix"><div id="inner-taboola-3"></div><script type="text/javascript">window._taboola=window._taboola||[];_taboola.push({mode:'thumbnails-rr',container:'inner-taboola-3',placement:'sidebar-3',target_type:'mix'});</script></div><div class="sb-widget clearfix"><ul class="mh-rp-widget widget-list"><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2017/09/dulac-steelers-close-reaching-deal-tuitt/" title="Dulac: Steelers Close To Reaching Deal With Tuitt" rel="bookmark">Dulac: Steelers Close To Reaching Deal With Tuitt</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2017/09/steelers-film-room-2016-joe-haden-vs-odell-beckham-jr-matchup/" title="Steelers Film Room: 2016 Joe Haden Vs Odell Beckham Jr. Matchup" rel="bookmark">Steelers Film Room: 2016 Joe Haden Vs Odell Beckham Jr. Matchup</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2017/09/rough-year-steelers-free-agency-departures-bad-news-compensatory-formula/" title="Rough Year For Steelers Free Agency Departures Is Bad News For Compensatory Formula" rel="bookmark">Rough Year For Steelers Free Agency Departures Is Bad News For Compensatory Formula</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2017/09/terrible-podcast-talking-steelers-browns-preview-tomlin-tuesday-2017-expectations/" title="The Terrible Podcast – Talking Steelers Browns Preview, Tomlin Tuesday, 2017 Expectations &#038; More" rel="bookmark">The Terrible Podcast – Talking Steelers Browns Preview, Tomlin Tuesday, 2017 Expectations &#038; More</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2017/09/steelers-fans-hoping-wont-remember-kameron-canadays-name/" title="Steelers Fans Hoping They Won&#8217;t Have To Remember Kameron Canaday&#8217;s Name" rel="bookmark">Steelers Fans Hoping They Won&#8217;t Have To Remember Kameron Canaday&#8217;s Name</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2017/09/steelers-ask-pricey-reserves-take-pay-cut-get-cut/" title="Steelers Could Ask Pricey Reserves To Take Pay Cut Or Get Cut" rel="bookmark">Steelers Could Ask Pricey Reserves To Take Pay Cut Or Get Cut</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2017/09/tomlin-steelers-bungling-kick-return-situation/" title="Tomlin, Steelers Bungling Up Kick Return Situation" rel="bookmark">Tomlin, Steelers Bungling Up Kick Return Situation</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2017/09/film-room-juju-finds-jam-special-teams/" title="Film Room: JuJu Finds His &#8216;Jam&#8217; On Special Teams" rel="bookmark">Film Room: JuJu Finds His &#8216;Jam&#8217; On Special Teams</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2017/09/data-dump-justin-hunters-career-numbers-isolated-quarterback/" title="Data Dump: Justin Hunter&#8217;s Career Numbers Isolated By Quarterback" rel="bookmark">Data Dump: Justin Hunter&#8217;s Career Numbers Isolated By Quarterback</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2017/09/mike-tomlin-odd-interest-kick-returners-little-no-experience/" title="Mike Tomlin Has Odd Interest In Kick Returners With Little Or No Experience" rel="bookmark">Mike Tomlin Has Odd Interest In Kick Returners With Little Or No Experience</a></li></ul></div><div class="sb-widget clearfix"><div class="textwidget"><center><a target="_blank" href="http://shareasale.com/r.cfm?b=537844&amp;u=275818&amp;m=7124&amp;urllink=&amp;afftrack="><img src="http://static.shareasale.com/image/7124/NFL_Pittsburg_Steelers_300x250.jpg" border="0" alt="Shop the newest Pittsburgh Steelers fan gear at Fanatics!" /></a></center></div></div></aside></div></div> <footer class="mh-footer"><div class="wrapper-inner clearfix"></div><div class="footer-bottom"><div class="wrapper-inner clearfix"><div class="copyright-wrap"><p class="copyright">Copyright 2017 | Theme by <a href="http://spencer.vegas/" title="Las Vegas WordPress">WordPress</a> | <a href="http://www.steelersdepot.com/privacy-policy/" title="Privacy Policy" rel="nofollow">Privacy Policy</a></p></div><div class="sv-footer">Optimized by <a href="http://spencer.vegas/" title="Las Vegas WordPress">Las Vegas WordPress</a></div></div></div> </footer> <script type="text/javascript">/*<![CDATA[*/var disqus_shortname='steelersdepot';(function(){var nodes=document.getElementsByTagName('span');for(var i=0,url;i<nodes.length;i++){if(nodes[i].className.indexOf('dsq-postid')!=-1&&nodes[i].parentNode.tagName=='A'){nodes[i].parentNode.setAttribute('data-disqus-identifier',nodes[i].getAttribute('data-dsqidentifier'));url=nodes[i].parentNode.href.split('#',1);if(url.length==1){url=url[0];}
else{url=url[1];}
nodes[i].parentNode.href=url+'#disqus_thread';}}
var s=document.createElement('script');s.async=true;s.type='text/javascript';s.src='//'+disqus_shortname+'.disqus.com/count.js';(document.getElementsByTagName('HEAD')[0]||document.getElementsByTagName('BODY')[0]).appendChild(s);}());/*]]>*/</script> <script type="text/javascript">var sectionCode=sectionCode||[];sectionCode.push("a70f4eaa-a346-43eb-98ae-f8e6526f5f12");(function(){var script=document.createElement("script");script.async=true;script.src="https://s.yimg.com/av/gemini/ga/gemini.js";document.body.appendChild(script);})();</script><script type='text/javascript'>window._taboola=window._taboola||[];_taboola.push({flush:true});</script> <script type="text/javascript">window.WPCOM_sharing_counts={"http:\/\/www.steelersdepot.com\/2017\/09\/steelers-film-room-2016-joe-haden-vs-odell-beckham-jr-matchup\/":469864};</script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-content/plugins/wordpress-post-tabs/js/jquery.posttabs.js?ver=1.6.2'></script> <script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201736'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-content/themes/mh_newsdesk/js/scripts.js?ver=4.8.1'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-content/plugins/simple-social-icons/svgxuse.js?ver=1.1.21'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-includes/js/wp-embed.min.js?ver=4.8.1'></script> <script type='text/javascript'>var sharing_js_options={"lang":"en","counts":"1"};</script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=5.2.1'></script> <script type='text/javascript'>var windowOpen;jQuery(document.body).on('click','a.share-twitter',function(){if('undefined'!==typeof windowOpen){windowOpen.close();}
windowOpen=window.open(jQuery(this).attr('href'),'wpcomtwitter','menubar=1,resizable=1,width=600,height=350');return false;});var windowOpen;jQuery(document.body).on('click','a.share-facebook',function(){if('undefined'!==typeof windowOpen){windowOpen.close();}
windowOpen=window.open(jQuery(this).attr('href'),'wpcomfacebook','menubar=1,resizable=1,width=600,height=400');return false;});var windowOpen;jQuery(document.body).on('click','a.share-google-plus-1',function(){if('undefined'!==typeof windowOpen){windowOpen.close();}
windowOpen=window.open(jQuery(this).attr('href'),'wpcomgoogle-plus-1','menubar=1,resizable=1,width=480,height=550');return false;});</script> <script type="text/javascript" id="slb_context">if(!!window.jQuery){(function($){$(document).ready(function(){if(!!window.SLB){{$.extend(SLB,{"context":["public","user_guest"]});}}})})(jQuery);}</script> <script type='text/javascript' src='https://stats.wp.com/e-201736.js' async defer></script> <script type='text/javascript'>_stq=window._stq||[];_stq.push(['view',{v:'ext',j:'1:5.2.1',blog:'12286105',post:'469864',tz:'-5',srv:'www.steelersdepot.com'}]);_stq.push(['clickTrackerInit','12286105','469864']);</script> </body></html>