<!DOCTYPE html><html class="no-js" lang="en-US" prefix="og: http://ogp.me/ns#"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1.0"><link rel="profile" href="http://gmpg.org/xfn/11" /><link rel="pingback" href="http://www.steelersdepot.com/xmlrpc.php" /><title>Roethlisberger Believes Veteran Leadership Will Help Young Guys In Playoffs - Steelers Depot</title><meta name="description" content="The Pittsburgh Steelers&#039; 2017 rookie class has been marvelous. But the playoffs are a different beast. And a time for the veterans on the team to step up."/><link rel="canonical" href="http://www.steelersdepot.com/2018/01/roethlisberger-believes-veteran-leadership-will-help-young-guys-playoffs/" /><link rel="publisher" href="https://plus.google.com/+DaveBryan"/><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Roethlisberger Believes Veteran Leadership Will Help Young Guys In Playoffs - Steelers Depot" /><meta property="og:description" content="The Pittsburgh Steelers&#039; 2017 rookie class has been marvelous. But the playoffs are a different beast. And a time for the veterans on the team to step up." /><meta property="og:url" content="http://www.steelersdepot.com/2018/01/roethlisberger-believes-veteran-leadership-will-help-young-guys-playoffs/" /><meta property="og:site_name" content="Steelers Depot" /><meta property="article:tag" content="Ben Roethlisberger" /><meta property="article:tag" content="James Farrior" /><meta property="article:tag" content="Jerome Bettis" /><meta property="article:tag" content="JuJu Smith-Schuster" /><meta property="article:tag" content="Pittsburgh Steelers" /><meta property="article:tag" content="T.J. Watt" /><meta property="article:section" content="Article" /><meta property="article:published_time" content="2018-01-03T13:38:10+00:00" /><meta property="og:image" content="http://www.steelersdepot.com/wp-content/uploads/2018/01/StockRoethlisberger19.jpg" /><meta property="og:image:width" content="761" /><meta property="og:image:height" content="418" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="The Pittsburgh Steelers&#039; 2017 rookie class has been marvelous. But the playoffs are a different beast. And a time for the veterans on the team to step up." /><meta name="twitter:title" content="Roethlisberger Believes Veteran Leadership Will Help Young Guys In Playoffs - Steelers Depot" /><meta name="twitter:site" content="@Steelersdepot" /><meta name="twitter:image" content="http://www.steelersdepot.com/wp-content/uploads/2018/01/StockRoethlisberger19.jpg" /><meta name="twitter:creator" content="@Alex_Kozora" /> <script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"http:\/\/www.steelersdepot.com\/","name":"Steeles Depot","potentialAction":{"@type":"SearchAction","target":"http:\/\/www.steelersdepot.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script> <script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","url":"http:\/\/www.steelersdepot.com\/2018\/01\/roethlisberger-believes-veteran-leadership-will-help-young-guys-playoffs\/","sameAs":["https:\/\/plus.google.com\/+DaveBryan","https:\/\/twitter.com\/Steelersdepot"],"@id":"#organization","name":"Steelers Depot","logo":"http:\/\/www.steelersdepot.com\/wp-content\/uploads\/2015\/07\/SteelersDepot.jpg"}</script> <link rel='dns-prefetch' href='//www.steelersdepot.com' /><link rel='dns-prefetch' href='//s0.wp.com' /><link rel='dns-prefetch' href='//vjs.zencdn.net' /><link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Steelers Depot &raquo; Feed" href="http://www.steelersdepot.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Steelers Depot &raquo; Comments Feed" href="http://www.steelersdepot.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Steelers Depot &raquo; Roethlisberger Believes Veteran Leadership Will Help Young Guys In Playoffs Comments Feed" href="http://www.steelersdepot.com/2018/01/roethlisberger-believes-veteran-leadership-will-help-young-guys-playoffs/feed/" /> <script type="text/javascript">/*<![CDATA[*/window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.steelersdepot.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.1"}};!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56794,8205,9794,65039],[55358,56794,8203,9794,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);/*]]>*/</script> <style type="text/css">img.wp-smiley,img.emoji{display:inline !important;border:none !important;box-shadow:none !important;height:1em !important;width:1em !important;margin:0
.07em !important;vertical-align:-0.1em !important;background:none !important;padding:0
!important}</style><link rel='stylesheet' id='wpts_ui_css-css'  href='http://www.steelersdepot.com/wp-content/plugins/wordpress-post-tabs/css/styles/default/style.css?ver=1.6.2' type='text/css' media='all' /><link rel='stylesheet' id='videojs-css'  href='//vjs.zencdn.net/5.9.2/video-js.css?ver=4.9.1' type='text/css' media='all' /><link rel='stylesheet' id='videojs-style-css'  href='http://www.steelersdepot.com/wp-content/plugins/videojs-hls-player/videojs-hls-player.css?ver=4.9.1' type='text/css' media='all' /><link rel='stylesheet' id='videojs-airplay-css'  href='http://www.steelersdepot.com/wp-content/plugins/videojs-hls-player/videojs-airplay/videojs.airplay.css?ver=4.9.1' type='text/css' media='all' /><link rel='stylesheet' id='wp-pagenavi-css'  href='http://www.steelersdepot.com/wp-content/plugins/wp-pagenavi/pagenavi-css.css?ver=2.70' type='text/css' media='all' /><link rel='stylesheet' id='parent-style-css'  href='http://www.steelersdepot.com/wp-content/themes/mh_newsdesk/style.css?ver=4.9.1' type='text/css' media='all' /><link rel='stylesheet' id='mh-style-css'  href='http://www.steelersdepot.com/wp-content/themes/mh_newsdesk-child/style.css?ver=1.1.0' type='text/css' media='all' /><link rel='stylesheet' id='mh-font-awesome-css'  href='//maxcdn.bootstrapcdn.com/font-awesome/4.3.0/css/font-awesome.min.css' type='text/css' media='all' /><link rel='stylesheet' id='mh-google-fonts-css'  href='//fonts.googleapis.com/css?family=PT+Serif:300,400,400italic,600,700|Oswald:300,400,400italic,600,700' type='text/css' media='all' /><link rel='stylesheet' id='simple-social-icons-font-css'  href='http://www.steelersdepot.com/wp-content/plugins/simple-social-icons/css/style.css?ver=2.0.1' type='text/css' media='all' /><link rel='stylesheet' id='slb_core-css'  href='http://www.steelersdepot.com/wp-content/plugins/simple-lightbox/client/css/app.css?ver=2.6.0' type='text/css' media='all' /><link rel='stylesheet' id='social-logos-css'  href='http://www.steelersdepot.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' /><link rel='stylesheet' id='jetpack_css-css'  href='http://www.steelersdepot.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.6.1' type='text/css' media='all' /><link rel='https://api.w.org/' href='http://www.steelersdepot.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.steelersdepot.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.steelersdepot.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 4.9.1" /><link rel='shortlink' href='https://wp.me/pPyaZ-218a' /><link rel="alternate" type="application/json+oembed" href="http://www.steelersdepot.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.steelersdepot.com%2F2018%2F01%2Froethlisberger-believes-veteran-leadership-will-help-young-guys-playoffs%2F" /><link rel="alternate" type="text/xml+oembed" href="http://www.steelersdepot.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.steelersdepot.com%2F2018%2F01%2Froethlisberger-believes-veteran-leadership-will-help-young-guys-playoffs%2F&#038;format=xml" /> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>(adsbygoogle=window.adsbygoogle||[]).push({google_ad_client:"ca-pub-7138622909378284",enable_page_level_ads:true});</script> <script data-cfasync="false" type="text/javascript">(function(w,d){var s=d.createElement('script');s.src='//delivery.adrecover.com/15913/adRecover.js';s.type='text/javascript';s.async=true;(d.getElementsByTagName('head')[0]||d.getElementsByTagName('body')[0]).appendChild(s);})(window,document);</script><script type='text/javascript'>window._taboola=window._taboola||[];_taboola.push({article:'auto'});_taboola.push({listenTo:'render',handler:function(p){TRC.modDebug.logMessageToServer(2,"wordpress-integ");}});_taboola.push({additional_data:{sdkd:{"os":"Wordpress","osv":"4.9.1","sdkt":"Taboola Wordpress Plugin","sdkv":"1.0.9"}}});!function(e,f,u){e.async=1;e.src=u;f.parentNode.insertBefore(e,f);}(document.createElement('script'),document.getElementsByTagName('script')[0],'//cdn.taboola.com/libtrc/steelersdepot/loader.js');</script> <script type="text/javascript">var _tmip=_tmip||[];_tmip.push({"tags":{"author":"Alex Kozora"}});</script> <style type='text/css'>img#wpstats{display:none}</style><style type="text/css">.social-nav a:hover, .logo-title, .entry-content a, a:hover, .entry-meta .entry-meta-author, .entry-meta a, .comment-info, blockquote, .pagination a:hover
.pagelink{color:#f1c000}.main-nav li:hover, .slicknav_menu, .ticker-title, .breadcrumb a, .breadcrumb .bc-text, .button span, .widget-title span, input[type=submit], table th, .comment-section-title .comment-count, #cancel-comment-reply-link:hover, .pagination .current, .pagination
.pagelink{background:#f1c000}blockquote,input[type=text]:hover,input[type=email]:hover,input[type=tel]:hover,input[type=url]:hover,textarea:hover{border-color:#f1c000}.widget-title, .pagination a.page-numbers:hover, .dots:hover, .pagination a:hover .pagelink,.comment-section-title{background:#000}.commentlist .depth-1, .commentlist .bypostauthor
.avatar{border-color:#000}.main-nav, .main-nav ul li:hover>ul,.mh-footer{background:#000}.header-top, .header-nav ul li:hover>ul,.footer-ad-wrap,.footer-1,.footer-2,.footer-3,.footer-bottom{background:#000}.social-nav
a{color:#000}.footer-widgets .widget-title{background:#000}</style><link rel="shortcut icon" href="http://www.steelersdepot.com/wp-content/uploads/2015/07/favicon.ico"> <!--[if lt IE 9]> <script src="http://www.steelersdepot.com/wp-content/themes/mh_newsdesk/js/css3-mediaqueries.js"></script> <![endif]--><style type="text/css" media="screen">.simple-social-icons ul li a, .simple-social-icons ul li a:hover, .simple-social-icons ul li a:focus{background-color:#999 !important;border-radius:3px;color:#fff !important;border:0px
#fff solid !important;font-size:18px;padding:9px}.simple-social-icons ul li a:hover, .simple-social-icons ul li a:focus{background-color:#666 !important;border-color:#fff !important;color:#fff !important}.simple-social-icons ul li a:focus{outline:1px
dotted #666 !important}</style></head><body class="post-template-default single single-post postid-481006 single-format-standard mh-right-sb"><div id="mh-wrapper"> <header class="mh-header"><div class="header-wrap clearfix"><div class="mh-col mh-1-3 header-logo"> <a href="http://www.steelersdepot.com/" title="Steelers Depot" rel="home"><div class="logo-wrap" role="banner"> <img src="http://www.steelersdepot.com/wp-content/uploads/2015/07/cropped-cropped-depot-logo1.png" height="100" width="384" alt="Steelers Depot" /></div> </a></div> <aside class="widget_text mh-col mh-2-3"><div class="widget_text header-ad"><div class="textwidget custom-html-widget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-7138622909378284" data-ad-slot="3074123274" data-ad-format="auto"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div></div></aside></div><div class="header-menu clearfix"> <nav class="main-nav clearfix"><div class="menu-header-container"><ul id="menu-header" class="menu"><li id="menu-item-37673" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-37673"><a href="http://www.steelersdepot.com">Home</a></li><li id="menu-item-154806" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154806"><a href="http://www.steelersdepot.com/category/news/">Steelers News</a></li><li id="menu-item-38055" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38055"><a href="http://www.steelersdepot.com/steelers-news/">Steelers Wire</a></li><li id="menu-item-163626" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-163626"><a href="http://www.steelersdepot.com/category/podcast/">Podcast</a></li><li id="menu-item-38056" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38056"><a href="http://www.shareasale.com/r.cfm?b=375840&#038;u=275818&#038;m=7124&#038;urllink=&#038;afftrack=">Steelers Merchandise</a></li><li id="menu-item-38057" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38057"><a href="http://www.jdoqocy.com/click-2334271-10858765?sid=&#038;url=http://www.ticketliquidator.com/tix/Pittsburgh-Steelers-tickets.aspx?utm_source=CJID&#038;utm_medium=2334271">Tickets</a></li><li id="menu-item-240752" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-240752"><a>NFL Draft Info</a><ul class="sub-menu"><li id="menu-item-456507" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-456507"><a href="http://www.steelersdepot.com/2017-nfl-scouting-combine-results-tracker/">2017 NFL Combine Results</a></li><li id="menu-item-240753" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-240753"><a href="http://www.steelersdepot.com/2016/03/steelers-2016-pre-draft-visit-tracker/">2016 Pre-Draft Visits</a></li><li id="menu-item-225936" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-225936"><a title="2016 NFL Combine Results" href="http://www.steelersdepot.com/2016-nfl-scouting-combine-results/">2016 NFL Combine Results</a></li></ul></li><li id="menu-item-38058" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38058"><a href="http://www.dpbolvw.net/click-2334271-10539967?url=http%3A%2F%2Fwww.zinio.com%2Fwww%2Fbrowse%2Fproduct.jsp%3FproductId%3D500215550%26affId%3Dcj%26rf%3Dcjaffcatalog&#038;cjsku=500073101">Steelers Digest</a></li><li id="menu-item-158274" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-158274"><a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&#038;hosted_button_id=XZ97MFHPQZYX4">Donate</a></li></ul></div>		</nav><div class="header-sub clearfix"> <section id="ticker" class="news-ticker mh-col mh-2-3 clearfix"> <span class="ticker-title">Hot Topics</span><ul class="ticker-content"></ul> </section>						<aside class="mh-col mh-1-3 header-search"><form role="search" method="get" class="search-form" action="http://www.steelersdepot.com/"> <label> <span class="screen-reader-text">Search for:</span> <input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" /> </label> <input type="submit" class="search-submit" value="Search" /></form>			</aside></div></div> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');ga('create','UA-11437002-3','auto');ga('send','pageview');</script> </header><div class="mh-section mh-group"><div id="main-content" class="mh-content"> <nav class="breadcrumb"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="http://www.steelersdepot.com" itemprop="url" class="bc-home"><span itemprop="title">Home</span></a></span> <span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="http://www.steelersdepot.com/category/article/" itemprop="url"><span itemprop="title">Article</span></a></span></nav> <article id="post-481006" class="post-481006 post type-post status-publish format-standard has-post-thumbnail hentry category-article tag-ben-roethlisberger tag-james-farrior tag-jerome-bettis tag-juju-smith-schuster tag-pittsburgh-steelers tag-t-j-watt"> <header class="entry-header clearfix"><h1 class="entry-title">Roethlisberger Believes Veteran Leadership Will Help Young Guys In Playoffs</h1> </header><div class="entry-thumbnail"> <img width="761" height="418" src="http://www.steelersdepot.com/wp-content/uploads/2018/01/StockRoethlisberger19.jpg" class="attachment-content-single size-content-single wp-post-image" alt="" srcset="http://www.steelersdepot.com/wp-content/uploads/2018/01/StockRoethlisberger19.jpg 761w, http://www.steelersdepot.com/wp-content/uploads/2018/01/StockRoethlisberger19-300x165.jpg 300w, http://www.steelersdepot.com/wp-content/uploads/2018/01/StockRoethlisberger19-120x67.jpg 120w" sizes="(max-width: 761px) 100vw, 761px" /></div><div class="advertisement"><div class="widget_text sb-widget post-ad"><div class="textwidget custom-html-widget"></div></div></div><p class="entry-meta"> <span class="entry-meta-author vcard author">By <a class="fn" href="http://www.steelersdepot.com/author/alex-kozora/">Alex Kozora</a></span> <span class="entry-meta-date updated">January 3, 2018 at 01:38 pm</span></p><div class="entry-content clearfix"><p>The <strong>Pittsburgh Steelers&#8217;</strong> 2017 rookie class has been marvelous. But the playoffs are a different beast. And a time for the veterans on the team to step up. That&#8217;s what<strong> Ben Roethlisberger</strong> hoped for in his weekly Wednesday media session.</p><p>&#8220;I hope some of the young guys will be benefited by being on a veteran team,&#8221; he said <a href="http://www.steelers.com/videos/videos/Ben-You-should-never-take-these-moments-for-granted/7f855be7-4472-42fa-b953-ed92af239f8c"><strong>via the team site.</strong> </a>&#8220;Because I consider us a veteran team now. Having guys who have been there before to talk, to lead the way by example definitely helped me.&#8221;</p><p>Because there was a point, well more than a decade ago, where Roethlisberger was that rookie. Players like <strong>Jerome Bettis, Jeff Hartings, James Farrior</strong>, and <strong>Hines Ward</strong> were the old guys in the room. They taught Roethlisberger valuable lessons, including to cherish the moment.</p><p>&#8220;You should never take these moments for granted. I remember hearing that my first year here from some of the veteran guys who hadn&#8217;t been there in awhile saying, &#8216;don&#8217;t take this for granted. Embrace it,&#8217; and all this stuff.&#8221;</p><p>He reflected on his time as a rookie, calling it a &#8220;whirlwind&#8221; during the back half of the regular season and playoff run. Roethlisberger said the rookie wall was a very real thing and though it might not affect other positions as harshly, it&#8217;s an obvious hurdle to clear. College players are down with football by now, on a shorter schedule overall, and now have to gut out as much as three more games in as high-pressured an environment as they&#8217;ve ever been in.</p><div class="MJUUa7US" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"></div><p>Luckily for the Steelers, there are key vets in most places where there are rookies. <strong>Arthur Moats</strong> at OLB for <strong>T.J. Watt</strong>. <strong>Antonio Brown</strong> and <strong>Darrius Heyward-Bey</strong> at WR for <strong>JuJu Smith-Schuster</strong>. <strong>William Gay</strong> at CB for <strong>Cam Sutton</strong>.</p><p>For Roethlisberger, he said the fact he hasn&#8217;t won a Super Bowl in a long time is motivation for him. And for those who don&#8217;t have a ring, like Brown, <strong>Le&#8217;Veon Bell</strong>, even <strong>Joe Haden</strong>, the chance to chase it should be equally as motivating.</p><div id='taboola-below-article'></div><script type='text/javascript'>window._taboola=window._taboola||[];_taboola.push({mode:'thumbnails-a',container:'taboola-below-article',placement:'below-article',target_type:'mix'});</script><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-481006" class="share-twitter sd-button share-icon" href="http://www.steelersdepot.com/2018/01/roethlisberger-believes-veteran-leadership-will-help-young-guys-playoffs/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-481006" class="share-facebook sd-button share-icon" href="http://www.steelersdepot.com/2018/01/roethlisberger-believes-veteran-leadership-will-help-young-guys-playoffs/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-481006" class="share-google-plus-1 sd-button share-icon" href="http://www.steelersdepot.com/2018/01/roethlisberger-believes-veteran-leadership-will-help-young-guys-playoffs/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span>Google</span></a></li><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon" href="http://www.steelersdepot.com/2018/01/roethlisberger-believes-veteran-leadership-will-help-young-guys-playoffs/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-pinterest"><a rel="nofollow" data-shared="sharing-pinterest-481006" class="share-pinterest sd-button share-icon" href="http://www.steelersdepot.com/2018/01/roethlisberger-believes-veteran-leadership-will-help-young-guys-playoffs/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span>Pinterest</span></a></li><li class="share-end"></li></ul></div></div></div><div class="entry-tags clearfix"><span>TOPICS:</span><a href="http://www.steelersdepot.com/tag/ben-roethlisberger/" rel="tag">Ben Roethlisberger</a><a href="http://www.steelersdepot.com/tag/james-farrior/" rel="tag">James Farrior</a><a href="http://www.steelersdepot.com/tag/jerome-bettis/" rel="tag">Jerome Bettis</a><a href="http://www.steelersdepot.com/tag/juju-smith-schuster/" rel="tag">JuJu Smith-Schuster</a><a href="http://www.steelersdepot.com/tag/pittsburgh-steelers/" rel="tag">Pittsburgh Steelers</a><a href="http://www.steelersdepot.com/tag/t-j-watt/" rel="tag">T.J. Watt</a></div></div> </article><div class="mh-share-buttons mh-group"><div class="mh-col mh-1-4 mh-facebook"> <a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=http://www.steelersdepot.com/2018/01/roethlisberger-believes-veteran-leadership-will-help-young-guys-playoffs/&t=Roethlisberger Believes Veteran Leadership Will Help Young Guys In Playoffs', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><span class="mh-share-button"><i class="fa fa-facebook fa-2x"></i>SHARE</span></a></div><div class="mh-col mh-1-4 mh-twitter"> <a href="#" onclick="window.open('http://twitter.com/share?text=Roethlisberger Believes Veteran Leadership Will Help Young Guys In Playoffs -&url=http://www.steelersdepot.com/2018/01/roethlisberger-believes-veteran-leadership-will-help-young-guys-playoffs/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><span class="mh-share-button"><i class="fa fa-twitter fa-2x"></i>TWEET</span></a></div><div class="mh-col mh-1-4 mh-pinterest"> <a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=http://www.steelersdepot.com/2018/01/roethlisberger-believes-veteran-leadership-will-help-young-guys-playoffs/&media=http://www.steelersdepot.com/wp-content/uploads/2018/01/StockRoethlisberger19.jpg&description=Roethlisberger Believes Veteran Leadership Will Help Young Guys In Playoffs', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><span class="mh-share-button"><i class="fa fa-pinterest fa-2x"></i>PIN</span></a></div><div class="mh-col mh-1-4 mh-googleplus"> <a href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=http://www.steelersdepot.com/2018/01/roethlisberger-believes-veteran-leadership-will-help-young-guys-playoffs/', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank"><span class="mh-share-button"><i class="fa fa-google-plus fa-2x"></i>SHARE</span></a></div></div>			<nav class="post-nav-wrap" role="navigation"><ul class="post-nav clearfix"><li class="post-nav-prev"> <a href="http://www.steelersdepot.com/2018/01/important-steelers-team-stats-2017-regular-season/" rel="prev"><i class="fa fa-chevron-left"></i>Previous post</a></li><li class="post-nav-next"> <a href="http://www.steelersdepot.com/2018/01/steelers-got-bang-buck-run-stops-alualu/" rel="next">Next post<i class="fa fa-chevron-right"></i></a></li></ul> </nav><h4 class="widget-title"><span>About the Author</span></h4> <section class="author-box clearfix"><div class="author-box-avatar"><a href="http://www.steelersdepot.com/author/alex-kozora/"><img alt='' src='http://1.gravatar.com/avatar/dd199f8d970e1b3dbb6a44b8a92b4ef4?s=100&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/dd199f8d970e1b3dbb6a44b8a92b4ef4?s=200&#038;d=mm&#038;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' /></a></div><h5 class="author-box-name"><a href="http://www.steelersdepot.com/author/alex-kozora/">Alex Kozora</a></h5><div class="author-box-desc"><p>Full-time blogger from mom&#8217;s basement. Marrying tape and statistics. Chidi Iwuoma is my favorite Steeler of all-time.</p></div> </section><div id="disqus_thread"><div id="dsq-content"><ul id="dsq-comments"><li class="comment even thread-even depth-1" id="dsq-comment-831050"><div id="dsq-comment-header-831050" class="dsq-comment-header"> <cite id="dsq-cite-831050"> <span id="dsq-author-user-831050">GravityWon</span> </cite></div><div id="dsq-comment-body-831050" class="dsq-comment-body"><div id="dsq-comment-message-831050" class="dsq-comment-message"><p>It&#8217;s good to have a mix of vets &amp; young guys.  The vets can help with preparation.  Come game day the young guys will be revved up and not over- thinking things.</p></div></div></li><li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-831057"><div id="dsq-comment-header-831057" class="dsq-comment-header"> <cite id="dsq-cite-831057"> <span id="dsq-author-user-831057">BurghBoy412</span> </cite></div><div id="dsq-comment-body-831057" class="dsq-comment-body"><div id="dsq-comment-message-831057" class="dsq-comment-message"><p>This playoff run is going to be FUN!!</p></div></div></li><li class="comment even thread-even depth-1" id="dsq-comment-831063"><div id="dsq-comment-header-831063" class="dsq-comment-header"> <cite id="dsq-cite-831063"> <span id="dsq-author-user-831063">nutty32</span> </cite></div><div id="dsq-comment-body-831063" class="dsq-comment-body"><div id="dsq-comment-message-831063" class="dsq-comment-message"><p>&#8220;Arthur Moats at OLB for TJ Watt.&#8221;  Nice work, not going say anything.</p></div></div></li><li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-831079"><div id="dsq-comment-header-831079" class="dsq-comment-header"> <cite id="dsq-cite-831079"> <span id="dsq-author-user-831079">Rob</span> </cite></div><div id="dsq-comment-body-831079" class="dsq-comment-body"><div id="dsq-comment-message-831079" class="dsq-comment-message"><p>Missed the part where he wasn&#8217;t really a mentor eh?</p></div></div></li><li class="comment even thread-even depth-1" id="dsq-comment-831081"><div id="dsq-comment-header-831081" class="dsq-comment-header"> <cite id="dsq-cite-831081"> <span id="dsq-author-user-831081">nutty32</span> </cite></div><div id="dsq-comment-body-831081" class="dsq-comment-body"><div id="dsq-comment-message-831081" class="dsq-comment-message"><p>can&#8217;t link vids here, but look up &#8220;James Harrison coaches up T.J. Watt, Pittsburgh Steelers OLBs&#8221; on youtube on the pennlive channel.</p></div></div></li><li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-831082"><div id="dsq-comment-header-831082" class="dsq-comment-header"> <cite id="dsq-cite-831082"> <span id="dsq-author-user-831082">Rob</span> </cite></div><div id="dsq-comment-body-831082" class="dsq-comment-body"><div id="dsq-comment-message-831082" class="dsq-comment-message"><p>I can&#8217;t imagine a guy who wanted to be released week 1 spent much time after that helping out the people in front of him get better. Is that what you think happened?</p></div></div></li><li class="comment even thread-even depth-1" id="dsq-comment-831084"><div id="dsq-comment-header-831084" class="dsq-comment-header"> <cite id="dsq-cite-831084"> <span id="dsq-author-user-831084">Alex Kozora</span> </cite></div><div id="dsq-comment-body-831084" class="dsq-comment-body"><div id="dsq-comment-message-831084" class="dsq-comment-message"><p>Didn&#8217;t really do anything but thank you?</p></div></div></li><li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-831094"><div id="dsq-comment-header-831094" class="dsq-comment-header"> <cite id="dsq-cite-831094"> <span id="dsq-author-user-831094">Steeler4life</span> </cite></div><div id="dsq-comment-body-831094" class="dsq-comment-body"><div id="dsq-comment-message-831094" class="dsq-comment-message"><p>I really like your chances this year. It&#8217;s great to have home field in our first game. If we start off slow, our 6th man will be there to help us. I&#8217;d love to play Jacksonville again. Getting revenge on them will kick start our playoff journey!</p></div></div></li><li class="comment even thread-even depth-1" id="dsq-comment-831098"><div id="dsq-comment-header-831098" class="dsq-comment-header"> <cite id="dsq-cite-831098"> <span id="dsq-author-user-831098">nutty32</span> </cite></div><div id="dsq-comment-body-831098" class="dsq-comment-body"><div id="dsq-comment-message-831098" class="dsq-comment-message"><p>what came first? the chicken or the egg.</p></div></div></li></ul></div></div> <script type="text/javascript">/*<![CDATA[*/var disqus_url='http://www.steelersdepot.com/2018/01/roethlisberger-believes-veteran-leadership-will-help-young-guys-playoffs/';var disqus_identifier='481006 http://www.steelersdepot.com/?p=481006';var disqus_container_id='disqus_thread';var disqus_shortname='steelersdepot';var disqus_title="Roethlisberger Believes Veteran Leadership Will Help Young Guys In Playoffs";var disqus_config_custom=window.disqus_config;var disqus_config=function(){this.language='';this.callbacks.onReady.push(function(){var script=document.createElement('script');script.async=true;script.src='?cf_action=sync_comments&post_id=481006';var firstScript=document.getElementsByTagName('script')[0];firstScript.parentNode.insertBefore(script,firstScript);});if(disqus_config_custom){disqus_config_custom.call(this);}};(function(){var dsq=document.createElement('script');dsq.type='text/javascript';dsq.async=true;dsq.src='//'+disqus_shortname+'.disqus.com/embed.js';(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(dsq);})();/*]]>*/</script> </div> <aside class="mh-sidebar"><div class="widget_text sb-widget clearfix"><div class="textwidget custom-html-widget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-7138622909378284" data-ad-slot="2275390383" data-ad-format="auto"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div></div><div class="sb-widget clearfix"><div id="inner-taboola-3"></div><script type="text/javascript">window._taboola=window._taboola||[];_taboola.push({mode:'thumbnails-rr',container:'inner-taboola-3',placement:'sidebar-3',target_type:'mix'});</script></div><div class="sb-widget clearfix"><ul class="mh-rp-widget widget-list"><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2018/01/steelers-got-bang-buck-run-stops-alualu/" title="Steelers Got Bang For Their Buck And Run Stops Too With Alualu" rel="bookmark">Steelers Got Bang For Their Buck And Run Stops Too With Alualu</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2018/01/roethlisberger-believes-veteran-leadership-will-help-young-guys-playoffs/" title="Roethlisberger Believes Veteran Leadership Will Help Young Guys In Playoffs" rel="bookmark">Roethlisberger Believes Veteran Leadership Will Help Young Guys In Playoffs</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2018/01/important-steelers-team-stats-2017-regular-season/" title="Important Steelers Team Stats In The 2017 Regular Season" rel="bookmark">Important Steelers Team Stats In The 2017 Regular Season</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2018/01/report-steelers-oc-todd-haley-back-work-wednesday/" title="Report: Steelers OC Todd Haley Back At Work On Wednesday" rel="bookmark">Report: Steelers OC Todd Haley Back At Work On Wednesday</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2018/01/terrible-podcast-talking-steelers-week-haley-incident-munchak-tomlin-tuesday/" title="The Terrible Podcast – Talking Steelers Bye Week, Haley Incident, Munchak, Tomlin Tuesday &#038; More" rel="bookmark">The Terrible Podcast – Talking Steelers Bye Week, Haley Incident, Munchak, Tomlin Tuesday &#038; More</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2018/01/arrow-pointed-return-units-heading-postseason-play/" title="Arrow Pointed Up For Return Units Heading Into Postseason Play" rel="bookmark">Arrow Pointed Up For Return Units Heading Into Postseason Play</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2018/01/juju-smith-schuster-credited-youngest-player-1000-purpose-yards/" title="JuJu Smith-Schuster Credited As Youngest Player With 1000 All-Purpose Yards, But Was He?" rel="bookmark">JuJu Smith-Schuster Credited As Youngest Player With 1000 All-Purpose Yards, But Was He?</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2018/01/steelers-wr-juju-smith-schuster-named-afc-special-teams-player-week-week-17/" title="Steelers WR JuJu Smith-Schuster Named AFC Special Teams Player Of The Week For Week 17" rel="bookmark">Steelers WR JuJu Smith-Schuster Named AFC Special Teams Player Of The Week For Week 17</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2018/01/losing-mike-munchak-not-doom-steelers/" title="Losing Mike Munchak Would Not Doom Steelers" rel="bookmark">Losing Mike Munchak Would Not Doom Steelers</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2018/01/steelers-fans-get-used-idea-hines-wards-exclusion-canton/" title="Steelers Fans Should Get Used To Idea Of Hines Ward&#8217;s Exclusion From Canton" rel="bookmark">Steelers Fans Should Get Used To Idea Of Hines Ward&#8217;s Exclusion From Canton</a></li></ul></div><div class="widget_text sb-widget clearfix"><div class="textwidget custom-html-widget"><center><a target="_blank" href="http://shareasale.com/r.cfm?b=537844&amp;u=275818&amp;m=7124&amp;urllink=&amp;afftrack="><img src="http://static.shareasale.com/image/7124/NFL_Pittsburg_Steelers_300x250.jpg" border="0" alt="Shop the newest Pittsburgh Steelers fan gear at Fanatics!" /></a></center></div></div></aside></div></div> <footer class="mh-footer"><div class="wrapper-inner clearfix"></div><div class="footer-bottom"><div class="wrapper-inner clearfix"><div class="copyright-wrap"><p class="copyright">Copyright 2018 | Theme by <a href="http://spencer.vegas/" title="Las Vegas WordPress">WordPress</a> | <a href="http://www.steelersdepot.com/privacy-policy/" title="Privacy Policy" rel="nofollow">Privacy Policy</a></p></div><div class="sv-footer">Optimized by <a href="http://spencer.vegas/" title="Las Vegas WordPress">Las Vegas WordPress</a></div></div></div> </footer> <script type="text/javascript">/*<![CDATA[*/var disqus_shortname='steelersdepot';(function(){var nodes=document.getElementsByTagName('span');for(var i=0,url;i<nodes.length;i++){if(nodes[i].className.indexOf('dsq-postid')!=-1&&nodes[i].parentNode.tagName=='A'){nodes[i].parentNode.setAttribute('data-disqus-identifier',nodes[i].getAttribute('data-dsqidentifier'));url=nodes[i].parentNode.href.split('#',1);if(url.length==1){url=url[0];}
else{url=url[1];}
nodes[i].parentNode.href=url+'#disqus_thread';}}
var s=document.createElement('script');s.async=true;s.type='text/javascript';s.src='//'+disqus_shortname+'.disqus.com/count.js';(document.getElementsByTagName('HEAD')[0]||document.getElementsByTagName('BODY')[0]).appendChild(s);}());/*]]>*/</script> <script type="text/javascript">var sectionCode=sectionCode||[];sectionCode.push("a70f4eaa-a346-43eb-98ae-f8e6526f5f12");(function(){var script=document.createElement("script");script.async=true;script.src="https://s.yimg.com/av/gemini/ga/gemini.js";document.body.appendChild(script);})();</script><script type='text/javascript'>window._taboola=window._taboola||[];_taboola.push({flush:true});</script><div style="line-height:16px;text-align:center;"><script type="text/javascript" src="//s3.tracemyip.org/tracker/lgUrl.php?stlVar2=1217&amp;rgtype=4684NR-IPIB&amp;pidnVar2=45152&amp;prtVar2=4&amp;scvVar2=12"></script><noscript><a href="https://www.tracemyip.org/"><img src="//s3.tracemyip.org/tracker/1217/4684NR-IPIB/45152/4/12/ans/" alt="tracemyip" style="border:0px;"></a></noscript></div>  <script type="text/javascript">window.WPCOM_sharing_counts={"http:\/\/www.steelersdepot.com\/2018\/01\/roethlisberger-believes-veteran-leadership-will-help-young-guys-playoffs\/":481006};</script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-content/plugins/wordpress-post-tabs/js/jquery.posttabs.js?ver=1.6.2'></script> <script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201801'></script> <script type='text/javascript' src='//vjs.zencdn.net/5.9.2/video.js?ver=1.0.2'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-content/plugins/videojs-hls-player/videojs-contrib-hls/videojs-contrib-hls.min.js?ver=1.0.2'></script> <script type='text/javascript' src='//vjs.zencdn.net/ie8/1.1.2/videojs-ie8.min.js?ver=1.0.2'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-content/plugins/videojs-hls-player/videojs-airplay/videojs.airplay.js?ver=1.0.2'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-content/plugins/videojs-hls-player/videojs-hls-player.js?ver=1.0.2'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-content/themes/mh_newsdesk/js/scripts.js?ver=4.9.1'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-content/plugins/simple-social-icons/svgxuse.js?ver=1.1.21'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-includes/js/wp-embed.min.js?ver=4.9.1'></script> <script type='text/javascript'>var sharing_js_options={"lang":"en","counts":"1"};</script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=5.6.1'></script> <script type='text/javascript'>var windowOpen;jQuery(document.body).on('click','a.share-twitter',function(){if('undefined'!==typeof windowOpen){windowOpen.close();}
windowOpen=window.open(jQuery(this).attr('href'),'wpcomtwitter','menubar=1,resizable=1,width=600,height=350');return false;});var windowOpen;jQuery(document.body).on('click','a.share-facebook',function(){if('undefined'!==typeof windowOpen){windowOpen.close();}
windowOpen=window.open(jQuery(this).attr('href'),'wpcomfacebook','menubar=1,resizable=1,width=600,height=400');return false;});var windowOpen;jQuery(document.body).on('click','a.share-google-plus-1',function(){if('undefined'!==typeof windowOpen){windowOpen.close();}
windowOpen=window.open(jQuery(this).attr('href'),'wpcomgoogle-plus-1','menubar=1,resizable=1,width=480,height=550');return false;});</script> <script type="text/javascript" id="slb_context">if(!!window.jQuery){(function($){$(document).ready(function(){if(!!window.SLB){{$.extend(SLB,{"context":["public","user_guest"]});}}})})(jQuery);}</script> <script type='text/javascript' src='https://stats.wp.com/e-201801.js' async defer></script> <script type='text/javascript'>_stq=window._stq||[];_stq.push(['view',{v:'ext',j:'1:5.6.1',blog:'12286105',post:'481006',tz:'-5',srv:'www.steelersdepot.com'}]);_stq.push(['clickTrackerInit','12286105','481006']);</script> </body></html>