<!DOCTYPE html><html class="no-js" lang="en-US" prefix="og: http://ogp.me/ns#"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1.0"><link rel="profile" href="http://gmpg.org/xfn/11" /><link rel="pingback" href="http://www.steelersdepot.com/xmlrpc.php" /><title>Steelers Have Long History Of Showing No Interest In Spring Cap Casualties - Steelers Depot</title><meta name="description" content="If you’re like me, you pay close attention to the salary cap casualties that happen just prior to the start of each new league year as there’s always a few interesting players that become unemployed every offseason at around this time. In fact, just today we saw the Carolina Panthers cut safety Kurt Coleman and"/><link rel="canonical" href="http://www.steelersdepot.com/2018/02/steelers-long-history-showing-no-interest-spring-cap-casualties/" /><link rel="publisher" href="https://plus.google.com/+DaveBryan"/><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Steelers Have Long History Of Showing No Interest In Spring Cap Casualties - Steelers Depot" /><meta property="og:description" content="If you’re like me, you pay close attention to the salary cap casualties that happen just prior to the start of each new league year as there’s always a few interesting players that become unemployed every offseason at around this time. In fact, just today we saw the Carolina Panthers cut safety Kurt Coleman and" /><meta property="og:url" content="http://www.steelersdepot.com/2018/02/steelers-long-history-showing-no-interest-spring-cap-casualties/" /><meta property="og:site_name" content="Steelers Depot" /><meta property="article:tag" content="Antwaan Randle El" /><meta property="article:tag" content="DeAngelo Williams" /><meta property="article:tag" content="Kevin Colbert" /><meta property="article:section" content="Article" /><meta property="article:published_time" content="2018-02-26T19:16:08+00:00" /><meta property="og:image" content="http://www.steelersdepot.com/wp-content/uploads/2014/12/steelers-log0-large-e1437639472553.png" /><meta property="og:image:width" content="750" /><meta property="og:image:height" content="750" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="If you’re like me, you pay close attention to the salary cap casualties that happen just prior to the start of each new league year as there’s always a few interesting players that become unemployed every offseason at around this time. In fact, just today we saw the Carolina Panthers cut safety Kurt Coleman and" /><meta name="twitter:title" content="Steelers Have Long History Of Showing No Interest In Spring Cap Casualties - Steelers Depot" /><meta name="twitter:site" content="@Steelersdepot" /><meta name="twitter:image" content="http://www.steelersdepot.com/wp-content/uploads/2014/12/steelers-log0-large-e1437639472553.png" /><meta name="twitter:creator" content="@Steelersdepot" /> <script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"http:\/\/www.steelersdepot.com\/","name":"Steeles Depot","potentialAction":{"@type":"SearchAction","target":"http:\/\/www.steelersdepot.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script> <script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","url":"http:\/\/www.steelersdepot.com\/2018\/02\/steelers-long-history-showing-no-interest-spring-cap-casualties\/","sameAs":["https:\/\/plus.google.com\/+DaveBryan","https:\/\/twitter.com\/Steelersdepot"],"@id":"#organization","name":"Steelers Depot","logo":"http:\/\/www.steelersdepot.com\/wp-content\/uploads\/2015\/07\/SteelersDepot.jpg"}</script> <link rel='dns-prefetch' href='//www.steelersdepot.com' /><link rel='dns-prefetch' href='//s0.wp.com' /><link rel='dns-prefetch' href='//vjs.zencdn.net' /><link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Steelers Depot &raquo; Feed" href="http://www.steelersdepot.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Steelers Depot &raquo; Comments Feed" href="http://www.steelersdepot.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Steelers Depot &raquo; Steelers Have Long History Of Showing No Interest In Spring Cap Casualties Comments Feed" href="http://www.steelersdepot.com/2018/02/steelers-long-history-showing-no-interest-spring-cap-casualties/feed/" /> <script type="text/javascript">/*<![CDATA[*/window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.steelersdepot.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.4"}};!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);/*]]>*/</script> <style type="text/css">img.wp-smiley,img.emoji{display:inline !important;border:none !important;box-shadow:none !important;height:1em !important;width:1em !important;margin:0
.07em !important;vertical-align:-0.1em !important;background:none !important;padding:0
!important}</style><link rel='stylesheet' id='wpts_ui_css-css'  href='http://www.steelersdepot.com/wp-content/plugins/wordpress-post-tabs/css/styles/default/style.css?ver=1.6.2' type='text/css' media='all' /><link rel='stylesheet' id='feedzy-rss-feeds-css'  href='http://www.steelersdepot.com/wp-content/plugins/feedzy-rss-feeds/css/feedzy-rss-feeds.css?ver=3.2.8' type='text/css' media='all' /><link rel='stylesheet' id='videojs-css'  href='//vjs.zencdn.net/5.9.2/video-js.css?ver=4.9.4' type='text/css' media='all' /><link rel='stylesheet' id='videojs-style-css'  href='http://www.steelersdepot.com/wp-content/plugins/videojs-hls-player/videojs-hls-player.css?ver=4.9.4' type='text/css' media='all' /><link rel='stylesheet' id='videojs-airplay-css'  href='http://www.steelersdepot.com/wp-content/plugins/videojs-hls-player/videojs-airplay/videojs.airplay.css?ver=4.9.4' type='text/css' media='all' /><link rel='stylesheet' id='wp-pagenavi-css'  href='http://www.steelersdepot.com/wp-content/plugins/wp-pagenavi/pagenavi-css.css?ver=2.70' type='text/css' media='all' /><link rel='stylesheet' id='parent-style-css'  href='http://www.steelersdepot.com/wp-content/themes/mh_newsdesk/style.css?ver=4.9.4' type='text/css' media='all' /><link rel='stylesheet' id='mh-style-css'  href='http://www.steelersdepot.com/wp-content/themes/mh_newsdesk-child/style.css?ver=1.1.0' type='text/css' media='all' /><link rel='stylesheet' id='mh-font-awesome-css'  href='//maxcdn.bootstrapcdn.com/font-awesome/4.3.0/css/font-awesome.min.css' type='text/css' media='all' /><link rel='stylesheet' id='mh-google-fonts-css'  href='//fonts.googleapis.com/css?family=PT+Serif:300,400,400italic,600,700|Oswald:300,400,400italic,600,700' type='text/css' media='all' /><link rel='stylesheet' id='simple-social-icons-font-css'  href='http://www.steelersdepot.com/wp-content/plugins/simple-social-icons/css/style.css?ver=2.0.1' type='text/css' media='all' /><link rel='stylesheet' id='slb_core-css'  href='http://www.steelersdepot.com/wp-content/plugins/simple-lightbox/client/css/app.css?ver=2.6.0' type='text/css' media='all' /><link rel='stylesheet' id='social-logos-css'  href='http://www.steelersdepot.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' /><link rel='stylesheet' id='jetpack_css-css'  href='http://www.steelersdepot.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.8' type='text/css' media='all' /><link rel='https://api.w.org/' href='http://www.steelersdepot.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.steelersdepot.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.steelersdepot.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 4.9.4" /><link rel='shortlink' href='https://wp.me/pPyaZ-22bI' /><link rel="alternate" type="application/json+oembed" href="http://www.steelersdepot.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.steelersdepot.com%2F2018%2F02%2Fsteelers-long-history-showing-no-interest-spring-cap-casualties%2F" /><link rel="alternate" type="text/xml+oembed" href="http://www.steelersdepot.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.steelersdepot.com%2F2018%2F02%2Fsteelers-long-history-showing-no-interest-spring-cap-casualties%2F&#038;format=xml" /> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>(adsbygoogle=window.adsbygoogle||[]).push({google_ad_client:"ca-pub-7138622909378284",enable_page_level_ads:true});</script> <script data-cfasync="false" type="text/javascript">(function(w,d){var s=d.createElement('script');s.src='//delivery.adrecover.com/15913/adRecover.js';s.type='text/javascript';s.async=true;(d.getElementsByTagName('head')[0]||d.getElementsByTagName('body')[0]).appendChild(s);})(window,document);</script><script type='text/javascript'>window._taboola=window._taboola||[];_taboola.push({article:'auto'});_taboola.push({listenTo:'render',handler:function(p){TRC.modDebug.logMessageToServer(2,"wordpress-integ");}});_taboola.push({additional_data:{sdkd:{"os":"Wordpress","osv":"4.9.4","sdkt":"Taboola Wordpress Plugin","sdkv":"1.0.9"}}});!function(e,f,u){e.async=1;e.src=u;f.parentNode.insertBefore(e,f);}(document.createElement('script'),document.getElementsByTagName('script')[0],'//cdn.taboola.com/libtrc/steelersdepot/loader.js');</script> <script type="text/javascript">var _tmip=_tmip||[];_tmip.push({"tags":{"author":"davebryan"}});</script> <style type='text/css'>img#wpstats{display:none}</style><style type="text/css">.social-nav a:hover, .logo-title, .entry-content a, a:hover, .entry-meta .entry-meta-author, .entry-meta a, .comment-info, blockquote, .pagination a:hover
.pagelink{color:#f1c000}.main-nav li:hover, .slicknav_menu, .ticker-title, .breadcrumb a, .breadcrumb .bc-text, .button span, .widget-title span, input[type=submit], table th, .comment-section-title .comment-count, #cancel-comment-reply-link:hover, .pagination .current, .pagination
.pagelink{background:#f1c000}blockquote,input[type=text]:hover,input[type=email]:hover,input[type=tel]:hover,input[type=url]:hover,textarea:hover{border-color:#f1c000}.widget-title, .pagination a.page-numbers:hover, .dots:hover, .pagination a:hover .pagelink,.comment-section-title{background:#000}.commentlist .depth-1, .commentlist .bypostauthor
.avatar{border-color:#000}.main-nav, .main-nav ul li:hover>ul,.mh-footer{background:#000}.header-top, .header-nav ul li:hover>ul,.footer-ad-wrap,.footer-1,.footer-2,.footer-3,.footer-bottom{background:#000}.social-nav
a{color:#000}.footer-widgets .widget-title{background:#000}</style><link rel="shortcut icon" href="http://www.steelersdepot.com/wp-content/uploads/2015/07/favicon.ico"> <!--[if lt IE 9]> <script src="http://www.steelersdepot.com/wp-content/themes/mh_newsdesk/js/css3-mediaqueries.js"></script> <![endif]--><style type="text/css" media="screen">.simple-social-icons ul li a, .simple-social-icons ul li a:hover, .simple-social-icons ul li a:focus{background-color:#999 !important;border-radius:3px;color:#fff !important;border:0px
#fff solid !important;font-size:18px;padding:9px}.simple-social-icons ul li a:hover, .simple-social-icons ul li a:focus{background-color:#666 !important;border-color:#fff !important;color:#fff !important}.simple-social-icons ul li a:focus{outline:1px
dotted #666 !important}</style></head><body class="post-template-default single single-post postid-485070 single-format-standard mh-right-sb"><div id="mh-wrapper"> <header class="mh-header"><div class="header-wrap clearfix"><div class="mh-col mh-1-3 header-logo"> <a href="http://www.steelersdepot.com/" title="Steelers Depot" rel="home"><div class="logo-wrap" role="banner"> <img src="http://www.steelersdepot.com/wp-content/uploads/2015/07/cropped-cropped-depot-logo1.png" height="100" width="384" alt="Steelers Depot" /></div> </a></div> <aside class="widget_text mh-col mh-2-3"><div class="widget_text header-ad"><div class="textwidget custom-html-widget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-7138622909378284" data-ad-slot="3074123274" data-ad-format="auto"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div></div></aside></div><div class="header-menu clearfix"> <nav class="main-nav clearfix"><div class="menu-header-container"><ul id="menu-header" class="menu"><li id="menu-item-37673" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-37673"><a href="http://www.steelersdepot.com">Home</a></li><li id="menu-item-154806" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154806"><a href="http://www.steelersdepot.com/category/news/">Steelers News</a></li><li id="menu-item-38055" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38055"><a href="http://www.steelersdepot.com/steelers-news/">Steelers Wire</a></li><li id="menu-item-163626" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-163626"><a href="http://www.steelersdepot.com/category/podcast/">Podcast</a></li><li id="menu-item-38056" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38056"><a href="http://www.shareasale.com/r.cfm?b=375840&#038;u=275818&#038;m=7124&#038;urllink=&#038;afftrack=">Steelers Merchandise</a></li><li id="menu-item-38057" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38057"><a href="http://www.jdoqocy.com/click-2334271-10858765?sid=&#038;url=http://www.ticketliquidator.com/tix/Pittsburgh-Steelers-tickets.aspx?utm_source=CJID&#038;utm_medium=2334271">Tickets</a></li><li id="menu-item-240752" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-240752"><a>NFL Draft Info</a><ul class="sub-menu"><li id="menu-item-456507" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-456507"><a href="http://www.steelersdepot.com/2017-nfl-scouting-combine-results-tracker/">2017 NFL Combine Results</a></li><li id="menu-item-240753" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-240753"><a href="http://www.steelersdepot.com/2016/03/steelers-2016-pre-draft-visit-tracker/">2016 Pre-Draft Visits</a></li><li id="menu-item-225936" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-225936"><a title="2016 NFL Combine Results" href="http://www.steelersdepot.com/2016-nfl-scouting-combine-results/">2016 NFL Combine Results</a></li></ul></li><li id="menu-item-38058" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38058"><a href="http://www.dpbolvw.net/click-2334271-10539967?url=http%3A%2F%2Fwww.zinio.com%2Fwww%2Fbrowse%2Fproduct.jsp%3FproductId%3D500215550%26affId%3Dcj%26rf%3Dcjaffcatalog&#038;cjsku=500073101">Steelers Digest</a></li><li id="menu-item-158274" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-158274"><a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&#038;hosted_button_id=XZ97MFHPQZYX4">Donate</a></li></ul></div>		</nav><div class="header-sub clearfix"> <section id="ticker" class="news-ticker mh-col mh-2-3 clearfix"> <span class="ticker-title">Hot Topics</span><ul class="ticker-content"></ul> </section>						<aside class="mh-col mh-1-3 header-search"><form role="search" method="get" class="search-form" action="http://www.steelersdepot.com/"> <label> <span class="screen-reader-text">Search for:</span> <input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" /> </label> <input type="submit" class="search-submit" value="Search" /></form>			</aside></div></div> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');ga('create','UA-11437002-3','auto');ga('send','pageview');</script> </header><div class="mh-section mh-group"><div id="main-content" class="mh-content"> <nav class="breadcrumb"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="http://www.steelersdepot.com" itemprop="url" class="bc-home"><span itemprop="title">Home</span></a></span> <span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="http://www.steelersdepot.com/category/article/" itemprop="url"><span itemprop="title">Article</span></a></span></nav> <article id="post-485070" class="post-485070 post type-post status-publish format-standard has-post-thumbnail hentry category-article tag-antwaan-randle-el tag-deangelo-williams tag-kevin-colbert"> <header class="entry-header clearfix"><h1 class="entry-title">Steelers Have Long History Of Showing No Interest In Spring Cap Casualties</h1> </header><div class="entry-thumbnail"> <img width="750" height="437" src="http://www.steelersdepot.com/wp-content/uploads/2014/12/steelers-log0-large-e1437639472553-750x437.png" class="attachment-content-single size-content-single wp-post-image" alt="" /></div><div class="advertisement"><div class="widget_text sb-widget post-ad"><div class="textwidget custom-html-widget"></div></div></div><p class="entry-meta"> <span class="entry-meta-author vcard author">By <a class="fn" href="http://www.steelersdepot.com/author/davebryan/">Dave Bryan</a></span> <span class="entry-meta-date updated">February 26, 2018 at 07:16 pm</span></p><div class="entry-content clearfix"><p>If you’re like me, you pay close attention to the salary cap casualties that happen just prior to the start of each new league year as there’s always a few interesting players that become unemployed every offseason at around this time. In fact, just today we saw the <strong>Carolina Panthers</strong> cut safety <strong>Kurt Coleman</strong> and defensive end <strong>Charles Johnson</strong> and the <strong>Chicago Bears</strong> part ways with outside linebacker <strong>Pernell McPhee</strong> and safety <strong>Quintin Demps</strong>. Inevitability, I’m usually asked immediately about every high-profile cut on Twitter and if X player would be someone the <strong>Pittsburgh Steelers</strong> might be interested in signing. My normal response to those questions is that it&#8217;s unlikely to happen.</p><p>It’s easy for me to say that the Steelers won&#8217;t have any interest in offseason salary cap causalities of other teams because of their history related to such. Dating back to 2000, which was the first year <strong>Kevin Colbert</strong> was with the organization, the Steelers have shown virtually no interest in signing pre-new league year salary cap casualties by the start of the annual free agent signing period.</p><p>I went back through all the Steelers transactions that took place every year from 2000 and on and between February 1 and the middle of March (prior to start of that league year) and I failed to find any signings of players who had become offseason salary cap casualties who had never played in Pittsburgh previously. With that clarification out of the way, the Steelers did sign wide receiver <strong>Antwaan Randle El</strong> to a multi-year contract just a few days after the <strong>Washington Redskins</strong> made him a salary cap casualty in March of 2010. If you think I have overlooked one, let me know.</p><p>The closest thing the Steelers have really ever had when it comes to them signing another team&#8217;s early offseason castoff was just a few years ago when they signed running back <strong>DeAngelo Williams</strong>. While it was common knowledge in late February of 2015 that the Panthers were going to part ways with Williams, they didn’t officially cut him until just after the start of the 2015 NFL league year in March because they wanted to designate him post-June 1 cut for salary cap relief purposes. Williams was quickly signed by the Steelers just a few days after he was officially let go by the Panthers. In fact, <a href="http://www.steelersdepot.com/2015/02/deangelo-williams-could-be-on-steelers-radar-after-release-from-panthers/">I even suggested the team should sign Williams</a> a few weeks before the Panthers cut him.</p><p>In short, if you are hoping the Steelers will soon be signing any of the recent higher-profile players who have been released over the course of the last few weeks, or any of those that will be on the street by the time the new league year rolls around, you&#8217;re bound to be disappointed. The Steelers have never been big players in regular unrestricted free agency and not really players at all when it comes to signing a castoff from another team early in the spring.</p><div class="WlKYQ0d0" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"></div><div id='taboola-below-article'></div><script type='text/javascript'>window._taboola=window._taboola||[];_taboola.push({mode:'thumbnails-a',container:'taboola-below-article',placement:'below-article',target_type:'mix'});</script><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-485070" class="share-twitter sd-button share-icon" href="http://www.steelersdepot.com/2018/02/steelers-long-history-showing-no-interest-spring-cap-casualties/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-485070" class="share-facebook sd-button share-icon" href="http://www.steelersdepot.com/2018/02/steelers-long-history-showing-no-interest-spring-cap-casualties/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-485070" class="share-google-plus-1 sd-button share-icon" href="http://www.steelersdepot.com/2018/02/steelers-long-history-showing-no-interest-spring-cap-casualties/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span>Google</span></a></li><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon" href="http://www.steelersdepot.com/2018/02/steelers-long-history-showing-no-interest-spring-cap-casualties/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-pinterest"><a rel="nofollow" data-shared="sharing-pinterest-485070" class="share-pinterest sd-button share-icon" href="http://www.steelersdepot.com/2018/02/steelers-long-history-showing-no-interest-spring-cap-casualties/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span>Pinterest</span></a></li><li class="share-end"></li></ul></div></div></div><div class="entry-tags clearfix"><span>TOPICS:</span><a href="http://www.steelersdepot.com/tag/antwaan-randle-el/" rel="tag">Antwaan Randle El</a><a href="http://www.steelersdepot.com/tag/deangelo-williams/" rel="tag">DeAngelo Williams</a><a href="http://www.steelersdepot.com/tag/kevin-colbert/" rel="tag">Kevin Colbert</a></div></div> </article><div class="mh-share-buttons mh-group"><div class="mh-col mh-1-4 mh-facebook"> <a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=http://www.steelersdepot.com/2018/02/steelers-long-history-showing-no-interest-spring-cap-casualties/&t=Steelers Have Long History Of Showing No Interest In Spring Cap Casualties', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><span class="mh-share-button"><i class="fa fa-facebook fa-2x"></i>SHARE</span></a></div><div class="mh-col mh-1-4 mh-twitter"> <a href="#" onclick="window.open('http://twitter.com/share?text=Steelers Have Long History Of Showing No Interest In Spring Cap Casualties -&url=http://www.steelersdepot.com/2018/02/steelers-long-history-showing-no-interest-spring-cap-casualties/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><span class="mh-share-button"><i class="fa fa-twitter fa-2x"></i>TWEET</span></a></div><div class="mh-col mh-1-4 mh-pinterest"> <a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=http://www.steelersdepot.com/2018/02/steelers-long-history-showing-no-interest-spring-cap-casualties/&media=http://www.steelersdepot.com/wp-content/uploads/2014/12/steelers-log0-large-e1437639472553.png&description=Steelers Have Long History Of Showing No Interest In Spring Cap Casualties', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><span class="mh-share-button"><i class="fa fa-pinterest fa-2x"></i>PIN</span></a></div><div class="mh-col mh-1-4 mh-googleplus"> <a href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=http://www.steelersdepot.com/2018/02/steelers-long-history-showing-no-interest-spring-cap-casualties/', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank"><span class="mh-share-button"><i class="fa fa-google-plus fa-2x"></i>SHARE</span></a></div></div>			<nav class="post-nav-wrap" role="navigation"><ul class="post-nav clearfix"><li class="post-nav-prev"> <a href="http://www.steelersdepot.com/2018/02/2018-nfl-draft-player-profiles-alabama-ilb-shaun-dion-hamilton/" rel="prev"><i class="fa fa-chevron-left"></i>Previous post</a></li></ul> </nav><div id="disqus_thread"></div></div> <aside class="mh-sidebar"><div class="widget_text sb-widget clearfix"><div class="textwidget custom-html-widget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-7138622909378284" data-ad-slot="2275390383" data-ad-format="auto"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div></div><div class="sb-widget clearfix"><div id="inner-taboola-3"></div><script type="text/javascript">window._taboola=window._taboola||[];_taboola.push({mode:'thumbnails-rr',container:'inner-taboola-3',placement:'sidebar-3',target_type:'mix'});</script></div><div class="sb-widget clearfix"><ul class="mh-rp-widget widget-list"><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2018/02/steelers-long-history-showing-no-interest-spring-cap-casualties/" title="Steelers Have Long History Of Showing No Interest In Spring Cap Casualties" rel="bookmark">Steelers Have Long History Of Showing No Interest In Spring Cap Casualties</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2018/02/2018-nfl-draft-player-profiles-alabama-ilb-shaun-dion-hamilton/" title="2018 NFL Draft Player Profiles: Alabama ILB Shaun Dion Hamilton" rel="bookmark">2018 NFL Draft Player Profiles: Alabama ILB Shaun Dion Hamilton</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2018/02/report-steelers-spent-98-85-2017-nfl-salary-cap-number-cash-last-season/" title="Report: Steelers Spent 98.85% Of 2017 NFL Salary Cap Number In Cash Last Season" rel="bookmark">Report: Steelers Spent 98.85% Of 2017 NFL Salary Cap Number In Cash Last Season</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2018/02/mayock-boise-state-ilb-leighton-vander-esch-great-fit-steelers/" title="Mayock: Boise State ILB Leighton Vander Esch Would Be &#8216;Great Fit&#8217; For Steelers" rel="bookmark">Mayock: Boise State ILB Leighton Vander Esch Would Be &#8216;Great Fit&#8217; For Steelers</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2018/02/audio-mike-mayock-2018-pre-nfl-scouting-combine-media-conference-call/" title="Audio: Mike Mayock 2018 Pre-NFL Scouting Combine Media Conference Call" rel="bookmark">Audio: Mike Mayock 2018 Pre-NFL Scouting Combine Media Conference Call</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2018/02/best-play-worst-play-mike-mitchell/" title="Best Play/Worst Play: Mike Mitchell" rel="bookmark">Best Play/Worst Play: Mike Mitchell</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2018/02/2018-nfl-mock-draft-steelers-take-olb-lorenzo-carter-first-round/" title="2018 NFL Mock Draft: Steelers Take OLB Lorenzo Carter In First Round" rel="bookmark">2018 NFL Mock Draft: Steelers Take OLB Lorenzo Carter In First Round</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2018/02/2018-nfl-draft-player-profiles-oklahoma-state-qb-mason-rudolph/" title="2018 NFL Draft Player Profiles: Oklahoma State QB Mason Rudolph" rel="bookmark">2018 NFL Draft Player Profiles: Oklahoma State QB Mason Rudolph</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2018/02/2018-nfl-draft-player-profiles-lsu-rb-darrel-williams/" title="2018 NFL Draft Player Profiles: LSU RB Darrel Williams" rel="bookmark">2018 NFL Draft Player Profiles: LSU RB Darrel Williams</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2018/02/steelers-2018-free-agents-analysis-ls-kameron-canaday-erfa-re-signed/" title="Steelers 2018 Free Agents Analysis: LS Kameron Canaday &#8211;  ERFA (Re-Signed)" rel="bookmark">Steelers 2018 Free Agents Analysis: LS Kameron Canaday &#8211;  ERFA (Re-Signed)</a></li></ul></div><div class="widget_text sb-widget clearfix"><div class="textwidget custom-html-widget"><center><a target="_blank" href="http://shareasale.com/r.cfm?b=537844&amp;u=275818&amp;m=7124&amp;urllink=&amp;afftrack="><img src="http://static.shareasale.com/image/7124/NFL_Pittsburg_Steelers_300x250.jpg" border="0" alt="Shop the newest Pittsburgh Steelers fan gear at Fanatics!" /></a></center></div></div></aside></div></div> <footer class="mh-footer"><div class="wrapper-inner clearfix"></div><div class="footer-bottom"><div class="wrapper-inner clearfix"><div class="copyright-wrap"><p class="copyright">Copyright 2018 | Theme by <a href="http://spencer.vegas/" title="Las Vegas WordPress">WordPress</a> | <a href="http://www.steelersdepot.com/privacy-policy/" title="Privacy Policy" rel="nofollow">Privacy Policy</a></p></div><div class="sv-footer">Optimized by <a href="http://spencer.vegas/" title="Las Vegas WordPress">Las Vegas WordPress</a></div></div></div> </footer> <script type="text/javascript">var sectionCode=sectionCode||[];sectionCode.push("a70f4eaa-a346-43eb-98ae-f8e6526f5f12");(function(){var script=document.createElement("script");script.async=true;script.src="https://s.yimg.com/av/gemini/ga/gemini.js";document.body.appendChild(script);})();</script><script type='text/javascript'>window._taboola=window._taboola||[];_taboola.push({flush:true});</script><div style="line-height:16px;text-align:center;"><script type="text/javascript" src="//s3.tracemyip.org/tracker/lgUrl.php?stlVar2=1217&amp;rgtype=4684NR-IPIB&amp;pidnVar2=45152&amp;prtVar2=4&amp;scvVar2=12"></script><noscript><a href="https://www.tracemyip.org/"><img src="//s3.tracemyip.org/tracker/1217/4684NR-IPIB/45152/4/12/ans/" alt="tracemyip" style="border:0px;"></a></noscript></div>  <script type="text/javascript">window.WPCOM_sharing_counts={"http:\/\/www.steelersdepot.com\/2018\/02\/steelers-long-history-showing-no-interest-spring-cap-casualties\/":485070};</script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-content/plugins/wordpress-post-tabs/js/jquery.posttabs.js?ver=1.6.2'></script> <script type='text/javascript'>var countVars={"disqusShortname":"steelersdepot"};</script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.13'></script> <script type='text/javascript'>var embedVars={"disqusConfig":{"integration":"wordpress 3.0.13"},"disqusIdentifier":"485070 http:\/\/www.steelersdepot.com\/?p=485070","disqusShortname":"steelersdepot","disqusTitle":"Steelers Have Long History Of Showing No Interest In Spring Cap Casualties","disqusUrl":"http:\/\/www.steelersdepot.com\/2018\/02\/steelers-long-history-showing-no-interest-spring-cap-casualties\/","postId":"485070"};</script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.13'></script> <script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201809'></script> <script type='text/javascript' src='//vjs.zencdn.net/5.9.2/video.js?ver=1.0.2'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-content/plugins/videojs-hls-player/videojs-contrib-hls/videojs-contrib-hls.min.js?ver=1.0.2'></script> <script type='text/javascript' src='//vjs.zencdn.net/ie8/1.1.2/videojs-ie8.min.js?ver=1.0.2'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-content/plugins/videojs-hls-player/videojs-airplay/videojs.airplay.js?ver=1.0.2'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-content/plugins/videojs-hls-player/videojs-hls-player.js?ver=1.0.2'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-content/themes/mh_newsdesk/js/scripts.js?ver=4.9.4'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-content/plugins/simple-social-icons/svgxuse.js?ver=1.1.21'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-includes/js/wp-embed.min.js?ver=4.9.4'></script> <script type='text/javascript'>var sharing_js_options={"lang":"en","counts":"1"};</script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=5.8'></script> <script type='text/javascript'>var windowOpen;jQuery(document.body).on('click','a.share-twitter',function(){if('undefined'!==typeof windowOpen){windowOpen.close();}
windowOpen=window.open(jQuery(this).attr('href'),'wpcomtwitter','menubar=1,resizable=1,width=600,height=350');return false;});var windowOpen;jQuery(document.body).on('click','a.share-facebook',function(){if('undefined'!==typeof windowOpen){windowOpen.close();}
windowOpen=window.open(jQuery(this).attr('href'),'wpcomfacebook','menubar=1,resizable=1,width=600,height=400');return false;});var windowOpen;jQuery(document.body).on('click','a.share-google-plus-1',function(){if('undefined'!==typeof windowOpen){windowOpen.close();}
windowOpen=window.open(jQuery(this).attr('href'),'wpcomgoogle-plus-1','menubar=1,resizable=1,width=480,height=550');return false;});</script> <script type="text/javascript" id="slb_context">if(!!window.jQuery){(function($){$(document).ready(function(){if(!!window.SLB){{$.extend(SLB,{"context":["public","user_guest"]});}}})})(jQuery);}</script> <script type='text/javascript' src='https://stats.wp.com/e-201809.js' async='async' defer='defer'></script> <script type='text/javascript'>_stq=window._stq||[];_stq.push(['view',{v:'ext',j:'1:5.8',blog:'12286105',post:'485070',tz:'-5',srv:'www.steelersdepot.com'}]);_stq.push(['clickTrackerInit','12286105','485070']);</script> </body></html>