<!DOCTYPE html><html lang="en-US" prefix="og: http://ogp.me/ns#"><head><meta charset="UTF-8" ><meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" /><link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="http://www.steelersdepot.com/feed/" /><link rel="alternate" type="text/xml" title="RSS .92" href="http://www.steelersdepot.com/feed/rss/" /><link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="http://www.steelersdepot.com/feed/atom/" /><link rel="pingback" href="http://www.steelersdepot.com/xmlrpc.php" /><meta property="og:image" content="http://www.steelersdepot.com/wp-content/uploads/2017/06/ryan-leaf-steelers-chargers-2000.jpg" /><meta name="twitter:image" content="http://www.steelersdepot.com/wp-content/uploads/2017/06/ryan-leaf-steelers-chargers-2000.jpg" /><meta property="og:type" content="article" /><meta property="og:description" content="The NFL Draft and free agency are vastly different experiences for players. As incoming college prospects, they have little authority or autonomy over their immediate futures beyond having given permission to teams to claim their rights. Whoever drafts them, that is the only team that they can play for until that team elects to part [&hellip;]" /><meta name="twitter:card" content="summary"><meta name="twitter:url" content="http://www.steelersdepot.com/2018/04/ryan-leafs-advice-to-qb-selected-by-browns-eli-manning-your-way-out/"><meta name="twitter:title" content="Ryan Leaf&#8217;s Advice To QB Selected By Browns: Eli Manning Your Way Out"><meta name="twitter:description" content="The NFL Draft and free agency are vastly different experiences for players. As incoming college prospects, they have little authority or autonomy over their immediate futures beyond having given permission to teams to claim their rights. Whoever drafts them, that is the only team that they can play for until that team elects to part [&hellip;]"><title>Ryan Leaf&#039;s Advice To QB Selected By Browns: Eli Manning Your Way Out - Steelers Depot</title><meta name="description" content="The NFL Draft and free agency are vastly different experiences for players. As incoming college prospects, they have little authority or autonomy over their immediate futures beyond having given permission to teams to claim their rights. Whoever drafts them, that is the only team that they can play for until that"/><link rel="canonical" href="http://www.steelersdepot.com/2018/04/ryan-leafs-advice-to-qb-selected-by-browns-eli-manning-your-way-out/" /><link rel="publisher" href="https://plus.google.com/+DaveBryan"/><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Ryan Leaf&#039;s Advice To QB Selected By Browns: Eli Manning Your Way Out - Steelers Depot" /><meta property="og:description" content="The NFL Draft and free agency are vastly different experiences for players. As incoming college prospects, they have little authority or autonomy over their immediate futures beyond having given permission to teams to claim their rights. Whoever drafts them, that is the only team that they can play for until that" /><meta property="og:url" content="http://www.steelersdepot.com/2018/04/ryan-leafs-advice-to-qb-selected-by-browns-eli-manning-your-way-out/" /><meta property="og:site_name" content="Steelers Depot" /><meta property="article:tag" content="Ryan Leaf" /><meta property="article:section" content="Article" /><meta property="article:published_time" content="2018-04-02T11:00:50-04:00" /><meta property="article:modified_time" content="2018-04-02T04:13:49-04:00" /><meta property="og:updated_time" content="2018-04-02T04:13:49-04:00" /><meta property="og:image" content="http://www.steelersdepot.com/wp-content/uploads/2017/06/ryan-leaf-steelers-chargers-2000.jpg" /><meta property="og:image:width" content="777" /><meta property="og:image:height" content="484" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="The NFL Draft and free agency are vastly different experiences for players. As incoming college prospects, they have little authority or autonomy over their immediate futures beyond having given permission to teams to claim their rights. Whoever drafts them, that is the only team that they can play for until that" /><meta name="twitter:title" content="Ryan Leaf&#039;s Advice To QB Selected By Browns: Eli Manning Your Way Out - Steelers Depot" /><meta name="twitter:site" content="@Steelersdepot" /><meta name="twitter:image" content="http://www.steelersdepot.com/wp-content/uploads/2017/06/ryan-leaf-steelers-chargers-2000.jpg" /><meta name="twitter:creator" content="@mmarczi" /> <script type='application/ld+json'>{"@context":"https:\/\/schema.org","@type":"Organization","url":"http:\/\/www.steelersdepot.com\/","sameAs":["https:\/\/plus.google.com\/+DaveBryan","https:\/\/twitter.com\/Steelersdepot"],"@id":"#organization","name":"Steelers Depot","logo":""}</script> <link rel='dns-prefetch' href='//www.steelersdepot.com' /><link rel='dns-prefetch' href='//s0.wp.com' /><link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' /><link rel='dns-prefetch' href='//netdna.bootstrapcdn.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Steelers Depot &raquo; Feed" href="http://www.steelersdepot.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Steelers Depot &raquo; Comments Feed" href="http://www.steelersdepot.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Steelers Depot &raquo; Ryan Leaf&#8217;s Advice To QB Selected By Browns: Eli Manning Your Way Out Comments Feed" href="http://www.steelersdepot.com/2018/04/ryan-leafs-advice-to-qb-selected-by-browns-eli-manning-your-way-out/feed/" /> <script type="text/javascript">/*<![CDATA[*/window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.steelersdepot.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.4"}};!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);/*]]>*/</script> <style type="text/css">img.wp-smiley,img.emoji{display:inline !important;border:none !important;box-shadow:none !important;height:1em !important;width:1em !important;margin:0
.07em !important;vertical-align:-0.1em !important;background:none !important;padding:0
!important}</style><link rel='stylesheet' id='feedzy-rss-feeds-css'  href='http://www.steelersdepot.com/wp-content/plugins/feedzy-rss-feeds/css/feedzy-rss-feeds.css?ver=3.2.9' type='text/css' media='all' /><link rel='stylesheet' id='wp-pagenavi-css'  href='http://www.steelersdepot.com/wp-content/plugins/wp-pagenavi/pagenavi-css.css?ver=2.70' type='text/css' media='all' /><link rel='stylesheet' id='mvp-reset-css'  href='http://www.steelersdepot.com/wp-content/themes/flex-mag/css/reset.css?ver=4.9.4' type='text/css' media='all' /><link rel='stylesheet' id='mvp-fontawesome-css'  href='//netdna.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.css?ver=4.9.4' type='text/css' media='all' /><link rel='stylesheet' id='mvp-style-css'  href='http://www.steelersdepot.com/wp-content/themes/flex-mag-child/style.css?ver=4.9.4' type='text/css' media='all' /> <!--[if lt IE 10]><link rel='stylesheet' id='mvp-iecss-css'  href='http://www.steelersdepot.com/wp-content/themes/flex-mag-child/css/iecss.css?ver=4.9.4' type='text/css' media='all' /> <![endif]--><link rel='stylesheet' id='mvp-style-entertainment-css'  href='http://www.steelersdepot.com/wp-content/themes/flex-mag/css/style-entertainment.css?ver=4.9.4' type='text/css' media='all' /><link rel='stylesheet' id='mvp-media-queries-css'  href='http://www.steelersdepot.com/wp-content/themes/flex-mag/css/media-queries.css?ver=4.9.4' type='text/css' media='all' /><link rel='stylesheet' id='slb_core-css'  href='http://www.steelersdepot.com/wp-content/plugins/simple-lightbox/client/css/app.css?ver=2.6.0' type='text/css' media='all' /><link rel='stylesheet' id='child-ad-free-css'  href='http://www.steelersdepot.com/wp-content/themes/flex-mag-child/assets/css/ad-free.css?ver=4.9.4' type='text/css' media='all' /><link rel='stylesheet' id='child-archive-css'  href='http://www.steelersdepot.com/wp-content/themes/flex-mag-child/assets/css/archive.css?ver=4.9.4' type='text/css' media='all' /><link rel='stylesheet' id='child-colors-css'  href='http://www.steelersdepot.com/wp-content/themes/flex-mag-child/assets/css/colors.css?ver=4.9.4' type='text/css' media='all' /><link rel='stylesheet' id='child-fonts-css'  href='http://www.steelersdepot.com/wp-content/themes/flex-mag-child/assets/css/fonts.css?ver=4.9.4' type='text/css' media='all' /><link rel='stylesheet' id='child-footer-css'  href='http://www.steelersdepot.com/wp-content/themes/flex-mag-child/assets/css/footer.css?ver=4.9.4' type='text/css' media='all' /><link rel='stylesheet' id='child-layout-css'  href='http://www.steelersdepot.com/wp-content/themes/flex-mag-child/assets/css/layout.css?ver=4.9.4' type='text/css' media='all' /><link rel='stylesheet' id='child-login-css'  href='http://www.steelersdepot.com/wp-content/themes/flex-mag-child/assets/css/login.css?ver=4.9.4' type='text/css' media='all' /><link rel='stylesheet' id='child-nav-css'  href='http://www.steelersdepot.com/wp-content/themes/flex-mag-child/assets/css/nav.css?ver=4.9.4' type='text/css' media='all' /><link rel='stylesheet' id='child-posts-css'  href='http://www.steelersdepot.com/wp-content/themes/flex-mag-child/assets/css/posts.css?ver=4.9.4' type='text/css' media='all' /><link rel='stylesheet' id='child-pre-css'  href='http://www.steelersdepot.com/wp-content/themes/flex-mag-child/assets/css/pre.css?ver=4.9.4' type='text/css' media='all' /><link rel='stylesheet' id='child-sidebar-css'  href='http://www.steelersdepot.com/wp-content/themes/flex-mag-child/assets/css/sidebar.css?ver=4.9.4' type='text/css' media='all' /><link rel='stylesheet' id='child-tables-css'  href='http://www.steelersdepot.com/wp-content/themes/flex-mag-child/assets/css/tables.css?ver=4.9.4' type='text/css' media='all' /><link rel='stylesheet' id='child-widgets-css'  href='http://www.steelersdepot.com/wp-content/themes/flex-mag-child/assets/css/widgets.css?ver=4.9.4' type='text/css' media='all' /><link rel='stylesheet' id='bootstrap-css-css'  href='https://maxcdn.bootstrapcdn.com/bootstrap/4.0.0/css/bootstrap.min.css?ver=4.9.4' type='text/css' media='all' /><link rel='stylesheet' id='jetpack_css-css'  href='http://www.steelersdepot.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.9' type='text/css' media='all' /><link rel='https://api.w.org/' href='http://www.steelersdepot.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.steelersdepot.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.steelersdepot.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 4.9.4" /><link rel='shortlink' href='https://wp.me/pPyaZ-22RY' /><link rel="alternate" type="application/json+oembed" href="http://www.steelersdepot.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.steelersdepot.com%2F2018%2F04%2Fryan-leafs-advice-to-qb-selected-by-browns-eli-manning-your-way-out%2F" /><link rel="alternate" type="text/xml+oembed" href="http://www.steelersdepot.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.steelersdepot.com%2F2018%2F04%2Fryan-leafs-advice-to-qb-selected-by-browns-eli-manning-your-way-out%2F&#038;format=xml" /> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>(adsbygoogle=window.adsbygoogle||[]).push({google_ad_client:"ca-pub-7138622909378284",enable_page_level_ads:true});</script> <script data-cfasync="false" type="text/javascript">(function(w,d){var s=d.createElement('script');s.src='//delivery.adrecover.com/15913/adRecover.js';s.type='text/javascript';s.async=true;(d.getElementsByTagName('head')[0]||d.getElementsByTagName('body')[0]).appendChild(s);})(window,document);</script><script type='text/javascript'>window._taboola=window._taboola||[];_taboola.push({article:'auto'});_taboola.push({listenTo:'render',handler:function(p){TRC.modDebug.logMessageToServer(2,"wordpress-integ");}});_taboola.push({additional_data:{sdkd:{"os":"Wordpress","osv":"4.9.4","sdkt":"Taboola Wordpress Plugin","sdkv":"1.0.9"}}});!function(e,f,u){e.async=1;e.src=u;f.parentNode.insertBefore(e,f);}(document.createElement('script'),document.getElementsByTagName('script')[0],'//cdn.taboola.com/libtrc/steelersdepot/loader.js');</script><style type='text/css'>img#wpstats{display:none}</style><style type='text/css'>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</style><style type="text/css">.post-cont-out,.post-cont-in{margin-right:0}.home-wrap-out2{float:left;margin-left:0;margin-right:-315px}.home-wrap-in2{margin-left:0;margin-right:315px}.home-left-col{float:left}.home-mid-col{float:right;margin-left:15px;margin-right:0}@media screen and (max-width: 1399px) and (min-width: 1250px){.home-wrap-out2{float:left;margin-left:0;margin-right:-265px}.home-wrap-in2{margin-left:0;margin-right:265px}}@media screen and (max-width: 1249px) and (min-width: 1100px){.home-wrap-out2{float:left;margin-left:0;margin-right:-265px}.home-wrap-in2{margin-left:0;margin-right:265px}}@media screen and (max-width: 1099px){.home-wrap-out2,.home-wrap-in2{float:left;margin-left:0;margin-right:0}.home-mid-col{float:left}}@media screen and (max-width: 479px){.home-mid-col{margin-left:0}}</style><style type="text/css" id="custom-background-css">body.custom-background{background-color:#eee}</style></head><body class="post-template-default single single-post postid-487690 single-format-standard custom-background logged-out"> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');ga('create','UA-11437002-3','auto');ga('send','pageview');</script> <div id="site" class="left relative"><div id="site-wrap" class="left relative"><div id="fly-wrap"><div class="fly-wrap-out"><div class="fly-side-wrap"><ul class="fly-bottom-soc left relative"><li class="twit-soc"> <a href="https://twitter.com/Steelersdepot" target="_blank"> <i class="fa fa-twitter fa-2"></i> </a></li><li class="rss-soc"> <a href="http://www.steelersdepot.com/feed/rss/" target="_blank"> <i class="fa fa-rss fa-2"></i> </a></li></ul></div><div class="fly-wrap-in"><div id="fly-menu-wrap"> <nav class="fly-nav-menu left relative"><div class="menu-header-container"><ul id="menu-header" class="menu"><li id="menu-item-37673" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-37673"><a href="http://www.steelersdepot.com">Home</a></li><li id="menu-item-154806" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154806"><a href="http://www.steelersdepot.com/category/news/">Steelers News</a></li><li id="menu-item-38055" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38055"><a href="http://www.steelersdepot.com/steelers-news/">Steelers Wire</a></li><li id="menu-item-163626" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-163626"><a href="http://www.steelersdepot.com/category/podcast/">Podcast</a></li><li id="menu-item-240752" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-240752"><a>NFL Draft Info</a><ul class="sub-menu"><li id="menu-item-456507" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-456507"><a href="http://www.steelersdepot.com/2017-nfl-scouting-combine-results-tracker/">2017 NFL Combine Results</a></li><li id="menu-item-240753" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-240753"><a href="http://www.steelersdepot.com/2016/03/steelers-2016-pre-draft-visit-tracker/">2016 Pre-Draft Visits</a></li><li id="menu-item-225936" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-225936"><a title="2016 NFL Combine Results" href="http://www.steelersdepot.com/2016-nfl-scouting-combine-results/">2016 NFL Combine Results</a></li></ul></li><li id="menu-item-38058" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38058"><a href="http://www.dpbolvw.net/click-2334271-10539967?url=http%3A%2F%2Fwww.zinio.com%2Fwww%2Fbrowse%2Fproduct.jsp%3FproductId%3D500215550%26affId%3Dcj%26rf%3Dcjaffcatalog&#038;cjsku=500073101">Steelers Digest</a></li><li id="menu-item-158274" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-158274"><a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&#038;hosted_button_id=XZ97MFHPQZYX4">Donate</a></li></ul></div>				</nav></div></div></div></div><div id="head-main-wrap" class="left relative"><div id="head-main-top" class="left relative"></div><div id="main-nav-wrap"><div class="nav-out"><div class="nav-in"><div id="main-nav-cont" class="left" itemscope itemtype="http://schema.org/Organization"><div class="nav-logo-out"><div class="nav-left-wrap left relative"><div class="fly-but-wrap left relative"> <span></span> <span></span> <span></span> <span></span></div><div class="nav-logo left"> <a itemprop="url" href="http://www.steelersdepot.com/"><img itemprop="logo" src="http://www.steelersdepot.com/wp-content/uploads/2015/07/cropped-cropped-depot-logo1.png" alt="Steelers Depot" data-rjs="2" /></a><h2 class="mvp-logo-title">Steelers Depot</h2></div></div><div class="nav-logo-in"><div class="nav-menu-out"><div class="nav-menu-in"> <nav class="main-menu-wrap left"><div class="menu-header-container"><ul id="menu-header-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-37673"><a href="http://www.steelersdepot.com">Home</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154806"><a href="http://www.steelersdepot.com/category/news/">Steelers News</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38055"><a href="http://www.steelersdepot.com/steelers-news/">Steelers Wire</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-163626"><a href="http://www.steelersdepot.com/category/podcast/">Podcast</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-240752"><a>NFL Draft Info</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-456507"><a href="http://www.steelersdepot.com/2017-nfl-scouting-combine-results-tracker/">2017 NFL Combine Results</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-240753"><a href="http://www.steelersdepot.com/2016/03/steelers-2016-pre-draft-visit-tracker/">2016 Pre-Draft Visits</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-225936"><a title="2016 NFL Combine Results" href="http://www.steelersdepot.com/2016-nfl-scouting-combine-results/">2016 NFL Combine Results</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38058"><a href="http://www.dpbolvw.net/click-2334271-10539967?url=http%3A%2F%2Fwww.zinio.com%2Fwww%2Fbrowse%2Fproduct.jsp%3FproductId%3D500215550%26affId%3Dcj%26rf%3Dcjaffcatalog&#038;cjsku=500073101">Steelers Digest</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-158274"><a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&#038;hosted_button_id=XZ97MFHPQZYX4">Donate</a></li></ul></div>												</nav></div><div class="nav-right-wrap relative"><div class="nav-search-wrap left relative"> <span class="nav-search-but left"><i class="fa fa-search fa-2"></i></span><div class="search-fly-wrap"><form method="get" id="searchform" action="http://www.steelersdepot.com/"> <input type="text" name="s" id="s" value="Type search term and press enter" onfocus='if (this.value == "Type search term and press enter") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Type search term and press enter"; }' /> <input type="hidden" id="searchsubmit" value="Search" /></form></div></div> <a href="https://twitter.com/Steelersdepot" target="_blank"> <span class="nav-soc-but"><i class="fa fa-twitter fa-2"></i></span> </a></div></div></div></div></div></div></div></div></div><div id="body-main-wrap" class="left relative" itemscope itemtype="http://schema.org/NewsArticle"><meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="http://www.steelersdepot.com/2018/04/ryan-leafs-advice-to-qb-selected-by-browns-eli-manning-your-way-out/"/><div class="body-main-out relative"><div class="body-main-in"><div id="body-main-cont" class="left relative"><div id="leader-wrap" class="left relative"> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-7138622909378284" data-ad-slot="9571372570" data-ad-format="auto"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script> </div><div id="post-main-wrap" class="left relative"><div class="post-wrap-out1"><div class="post-wrap-in1"><div id="post-left-col" class="relative"> <article id="post-area" class="post-487690 post type-post status-publish format-standard has-post-thumbnail hentry category-article tag-ryan-leaf"> <header id="post-header"> <a class="post-cat-link" href="http://www.steelersdepot.com/category/article/"><span class="post-head-cat">Article</span></a><h1 class="post-title entry-title left" itemprop="headline">Ryan Leaf&#8217;s Advice To QB Selected By Browns: Eli Manning Your Way Out</h1><div id="post-info-wrap" class="left relative"><div class="post-info-out"><div class="post-info-img left relative"> <img alt='' src='http://1.gravatar.com/avatar/7fa7ee85674b58205a210a9bb2891f7d?s=50&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/7fa7ee85674b58205a210a9bb2891f7d?s=100&#038;d=mm&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' /></div><div class="post-info-in"><div class="post-info-right left relative"><div class="post-info-name left relative" itemprop="author" itemscope itemtype="https://schema.org/Person"> <span class="post-info-text">By</span> <span class="author-name vcard fn author" itemprop="name"><a href="http://www.steelersdepot.com/author/matthew-marczi/" title="Posts by Matthew Marczi" rel="author">Matthew Marczi</a></span> <span class="author-twitter"><a href="https://twitter.com/mmarczi" class="twitter-but" target="_blank"><i class="fa fa-twitter fa-2"></i></a></span></div><div class="post-info-date left relative"> <span class="post-info-text">Posted on</span> <span class="post-date updated"><time class="post-date updated" itemprop="datePublished" datetime="2018-04-02">April 2, 2018 at 11:00 am</time></span><meta itemprop="dateModified" content="2018-04-02"/></div></div></div></div></div> </header><section class="social-sharing-top"> <a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=http://www.steelersdepot.com/2018/04/ryan-leafs-advice-to-qb-selected-by-browns-eli-manning-your-way-out/&amp;t=Ryan Leaf&#8217;s Advice To QB Selected By Browns: Eli Manning Your Way Out', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><div class="facebook-share"><span class="fb-but1"><i class="fa fa-facebook fa-2"></i></span><span class="social-text">Share</span></div></a> <a href="#" onclick="window.open('http://twitter.com/share?text=Ryan Leaf&#8217;s Advice To QB Selected By Browns: Eli Manning Your Way Out -&amp;url=http://www.steelersdepot.com/2018/04/ryan-leafs-advice-to-qb-selected-by-browns-eli-manning-your-way-out/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><div class="twitter-share"><span class="twitter-but1"><i class="fa fa-twitter fa-2"></i></span><span class="social-text">Tweet</span></div></a> <a href="whatsapp://send?text=Ryan Leaf&#8217;s Advice To QB Selected By Browns: Eli Manning Your Way Out http://www.steelersdepot.com/2018/04/ryan-leafs-advice-to-qb-selected-by-browns-eli-manning-your-way-out/"><div class="whatsapp-share"><span class="whatsapp-but1"><i class="fa fa-whatsapp fa-2"></i></span><span class="social-text">Share</span></div></a> <a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=http://www.steelersdepot.com/2018/04/ryan-leafs-advice-to-qb-selected-by-browns-eli-manning-your-way-out/&amp;media=http://www.steelersdepot.com/wp-content/uploads/2017/06/ryan-leaf-steelers-chargers-2000.jpg&amp;description=Ryan Leaf&#8217;s Advice To QB Selected By Browns: Eli Manning Your Way Out', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><div class="pinterest-share"><span class="pinterest-but1"><i class="fa fa-pinterest-p fa-2"></i></span><span class="social-text">Share</span></div></a> <a href="mailto:?subject=Ryan Leaf&#8217;s Advice To QB Selected By Browns: Eli Manning Your Way Out&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: http://www.steelersdepot.com/2018/04/ryan-leafs-advice-to-qb-selected-by-browns-eli-manning-your-way-out/"><div class="email-share"><span class="email-but"><i class="fa fa-envelope fa-2"></i></span><span class="social-text">Email</span></div></a> <a href="#disqus_thread"><div class="social-comments comment-click-487690"><i class="fa fa-commenting fa-2"></i></div></a> </section><div class="left" id="post-feat-img-wrapper"><div id="post-feat-img" class="relative" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"> <img width="777" height="484" src="http://www.steelersdepot.com/wp-content/uploads/2017/06/ryan-leaf-steelers-chargers-2000.jpg" class="attachment- size- wp-post-image" alt="" srcset="http://www.steelersdepot.com/wp-content/uploads/2017/06/ryan-leaf-steelers-chargers-2000.jpg 777w, http://www.steelersdepot.com/wp-content/uploads/2017/06/ryan-leaf-steelers-chargers-2000-300x187.jpg 300w, http://www.steelersdepot.com/wp-content/uploads/2017/06/ryan-leaf-steelers-chargers-2000-768x478.jpg 768w" sizes="(max-width: 777px) 100vw, 777px" /><meta itemprop="url" content="http://www.steelersdepot.com/wp-content/uploads/2017/06/ryan-leaf-steelers-chargers-2000.jpg"><meta itemprop="width" content="777"><meta itemprop="height" content="484"><div class="post-feat-text"></div></div></div><div id="content-area" itemprop="articleBody" class="post-487690 post type-post status-publish format-standard has-post-thumbnail hentry category-article tag-ryan-leaf"><div class="post-cont-out"><div class="post-cont-in"><div id="content-main" class="left relative"><div class="post-specific-content"><p>The NFL Draft and free agency are vastly different experiences for players. As incoming college prospects, they have little authority or autonomy over their immediate futures beyond having given permission to teams to claim their rights. Whoever drafts them, that is the only team that they can play for until that team elects to part with him.</p><p>The instances are few and far between of any rookies exhibiting any kind of force over such situations, the obvious known examples being <strong>John Elway</strong> and <strong>Eli Manning</strong>, both of whom forced trades to other teams, the <strong>Denver Broncos</strong> in the case of the former and the <strong>New York Giants</strong> in the case of the latter. Each went on to win two Super Bowls for their teams.</p><p>One of the biggest draft busts in NFL history, <strong>Ryan Leaf</strong>, believes that whichever quarterback the <strong>Cleveland Browns</strong> select ought to advise his agent to “<a href="http://profootballtalk.nbcsports.com/2018/03/31/ryan-leaf-top-qb-should-pull-an-eli-manning-to-avoid-the-browns/">Eli Manning this for me</a>”, he recently said on <em>FS1</em>, as transcribed by <em>Pro Football Talk</em>.</p><p>As the second-overall pick in the 1998 NFL Draft behind Manning’s brother <strong>Peyton Manning</strong>, Leaf had a pretty awful career before running into legal problems that included an arrest stemming from addiction issues. <a href="https://www.theplayerstribune.com/en-us/articles/ryan-leaf-nfl-letter-to-my-younger-self">He penned an article last year around this time for the <em>Players’ Tribune</em> as an advice column to his younger self</a>.</p><p>Now he hopes to advise other young players, evidently, or at least one in particular, which is yet to be determined. He did single out <strong>Sam Darnold</strong>, though it is unclear if the Browns have circled around him as the quarterback prospect they have rated the highest, and that could naturally change between now and the draft.</p><p>Leaf said that he doesn’t want any player to be a bust, but wishes them success, and that is why he believes the top pick should refuse to play for the Browns, who have given him nor anybody else any indication that they can be successful. He called it “a place where quarterbacks go to die”.</p><p>“If I were Sam Darnold and I have this leverage right now and I know I’m going to be the first pick in the NFL Draft, I’m going to my agent and saying, ‘figure out a way for me to not to go Cleveland’”, he told the network.</p><p>“What if he plays five years there and is mediocre because they never win?”, he asked, which is a conversation that occasionally arises when discussing <strong>David Carr</strong>, the first-ever draft pick of the <strong>Houston Texans</strong>, who were awful. Carr’s younger brother, <strong>Derek Carr</strong>, has proven that his genes can have success in the NFL.</p><p>The tactic that Leaf is proposing is one that is incredibly rare, or at least works incredibly infrequently. But it’s also unprecedented for a team to go 1-31 over the course of two seasons. None of the top quarterbacks of the class have given any indication whatsoever that they would try to get out of Cleveland, however, and in fact they have all held private workouts with the team.</p> <span id='tbmarker'></span><script type='text/javascript'>/*<![CDATA[*/function insertAfter(e,t){t.parentNode.insertBefore(e,t.nextSibling)}function getElementByXPath(e,t){if(!t)t=document;if(t.evaluate)return t.evaluate(e,document,null,9,null).singleNodeValue;while(e.charAt(0)=="/")e=e.substr(1);var n=t;var r=e.split("/");for(var i=0;i<r.length;i++){var a=r[i].split(/(\w*)\[(\d*)\]/gi).filter(function(e){return!(e==""||e.match(/\s/gi))},this);var l=a[0];var o=a[1]?a[1]-1:0;if(i<r.length-1)n=n.getElementsByTagName(l)[o];else return n.getElementsByTagName(l)[o]}}if(!Array.prototype.filter){Array.prototype.filter=function(e){var t=this.length>>>0;if(typeof e!="function"){throw new TypeError}var n=[];var r=arguments[1];for(var i=0;i<t;i++){if(i in this){var a=this[i];if(e.call(r,a,i,this)){n.push(a)}}}return n}}function injectWidgetByXpath(e){var t=getElementByXPath(e);if(t==null){t=document.getElementById("tbdefault")}innerInject(t)}function injectWidgetByMarker(e){var t=document.getElementById(e);innerInject(t.parentNode)}function innerInject(e){var t=document.createElement("span");var n=document.createElement("script");var r="if JS crashes here, the first innerHTML value should be enclosed with single quotes instead of double, go to the minified version and change it";t.innerHTML="<div id='taboola-below-article'></div>";n.innerHTML="window._taboola = window._taboola || [];_taboola.push({mode:'thumbnails-a', container:'taboola-below-article', placement:'below-article', target_type: 'mix'});";insertAfter(t,e);insertAfter(n,t)}injectWidgetByMarker('tbmarker');/*]]>*/</script></div><div class="mvp-org-wrap" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><div class="mvp-org-logo" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"> <img src="http://www.steelersdepot.com/wp-content/uploads/2015/07/cropped-cropped-depot-logo1.png"/><meta itemprop="url" content="http://www.steelersdepot.com/wp-content/uploads/2015/07/cropped-cropped-depot-logo1.png"></div><meta itemprop="name" content="Steelers Depot"></div><div class="posts-nav-link"></div><div class="post-tags"> <span class="post-tags-header">Related Items:</span><span itemprop="keywords"><a href="http://www.steelersdepot.com/tag/ryan-leaf/" rel="tag">Ryan Leaf</a></span></div><div class="social-sharing-bot"> <a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=http://www.steelersdepot.com/2018/04/ryan-leafs-advice-to-qb-selected-by-browns-eli-manning-your-way-out/&amp;t=Ryan Leaf&#8217;s Advice To QB Selected By Browns: Eli Manning Your Way Out', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><div class="facebook-share"><span class="fb-but1"><i class="fa fa-facebook fa-2"></i></span><span class="social-text">Share</span></div></a> <a href="#" onclick="window.open('http://twitter.com/share?text=Ryan Leaf&#8217;s Advice To QB Selected By Browns: Eli Manning Your Way Out -&amp;url=http://www.steelersdepot.com/2018/04/ryan-leafs-advice-to-qb-selected-by-browns-eli-manning-your-way-out/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><div class="twitter-share"><span class="twitter-but1"><i class="fa fa-twitter fa-2"></i></span><span class="social-text">Tweet</span></div></a> <a href="whatsapp://send?text=Ryan Leaf&#8217;s Advice To QB Selected By Browns: Eli Manning Your Way Out http://www.steelersdepot.com/2018/04/ryan-leafs-advice-to-qb-selected-by-browns-eli-manning-your-way-out/"><div class="whatsapp-share"><span class="whatsapp-but1"><i class="fa fa-whatsapp fa-2"></i></span><span class="social-text">Share</span></div></a> <a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=http://www.steelersdepot.com/2018/04/ryan-leafs-advice-to-qb-selected-by-browns-eli-manning-your-way-out/&amp;media=http://www.steelersdepot.com/wp-content/uploads/2017/06/ryan-leaf-steelers-chargers-2000.jpg&amp;description=Ryan Leaf&#8217;s Advice To QB Selected By Browns: Eli Manning Your Way Out', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><div class="pinterest-share"><span class="pinterest-but1"><i class="fa fa-pinterest-p fa-2"></i></span><span class="social-text">Share</span></div></a> <a href="mailto:?subject=Ryan Leaf&#8217;s Advice To QB Selected By Browns: Eli Manning Your Way Out&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: http://www.steelersdepot.com/2018/04/ryan-leafs-advice-to-qb-selected-by-browns-eli-manning-your-way-out/"><div class="email-share"><span class="email-but"><i class="fa fa-envelope fa-2"></i></span><span class="social-text">Email</span></div></a> <a href="#disqus_thread"><div class="social-comments comment-click-487690"><i class="fa fa-commenting fa-2"></i></div></a></div><div class="mvp-related-posts left relative"><h4 class="post-header"><span class="post-header">Recommended for you</span></h4><ul><li><div class="mvp-related-img left relative"> <a href="http://www.steelersdepot.com/2017/06/former-nfl-qb-ryan-leaf-wishes-steelers-drafted/" rel="bookmark" title="Former NFL QB Ryan Leaf Wishes Steelers Would Have Drafted Him"> <img width="289" height="180" src="http://www.steelersdepot.com/wp-content/uploads/2017/06/ryan-leaf-steelers-chargers-2000.jpg" class="reg-img wp-post-image" alt="" srcset="http://www.steelersdepot.com/wp-content/uploads/2017/06/ryan-leaf-steelers-chargers-2000.jpg 777w, http://www.steelersdepot.com/wp-content/uploads/2017/06/ryan-leaf-steelers-chargers-2000-300x187.jpg 300w, http://www.steelersdepot.com/wp-content/uploads/2017/06/ryan-leaf-steelers-chargers-2000-768x478.jpg 768w" sizes="(max-width: 289px) 100vw, 289px" />						<img width="80" height="50" src="http://www.steelersdepot.com/wp-content/uploads/2017/06/ryan-leaf-steelers-chargers-2000.jpg" class="mob-img wp-post-image" alt="" srcset="http://www.steelersdepot.com/wp-content/uploads/2017/06/ryan-leaf-steelers-chargers-2000.jpg 777w, http://www.steelersdepot.com/wp-content/uploads/2017/06/ryan-leaf-steelers-chargers-2000-300x187.jpg 300w, http://www.steelersdepot.com/wp-content/uploads/2017/06/ryan-leaf-steelers-chargers-2000-768x478.jpg 768w" sizes="(max-width: 80px) 100vw, 80px" />					</a></div><div class="mvp-related-text left relative"> <a href="http://www.steelersdepot.com/2017/06/former-nfl-qb-ryan-leaf-wishes-steelers-drafted/">Former NFL QB Ryan Leaf Wishes Steelers Would Have Drafted Him</a></div></li><li><div class="mvp-related-img left relative"> <a href="http://www.steelersdepot.com/2015/05/2008-10-nfl-drafts-continue-to-haunt-steelers/" rel="bookmark" title="2008-10 NFL Drafts Continue To Haunt Steelers"> <img width="300" height="169" src="http://www.steelersdepot.com/wp-content/uploads/2015/02/2015_Steelers_Mock_Draft.jpg" class="reg-img wp-post-image" alt="" srcset="http://www.steelersdepot.com/wp-content/uploads/2015/02/2015_Steelers_Mock_Draft.jpg 650w, http://www.steelersdepot.com/wp-content/uploads/2015/02/2015_Steelers_Mock_Draft-300x169.jpg 300w, http://www.steelersdepot.com/wp-content/uploads/2015/02/2015_Steelers_Mock_Draft-180x101.jpg 180w, http://www.steelersdepot.com/wp-content/uploads/2015/02/2015_Steelers_Mock_Draft-260x146.jpg 260w, http://www.steelersdepot.com/wp-content/uploads/2015/02/2015_Steelers_Mock_Draft-373x210.jpg 373w, http://www.steelersdepot.com/wp-content/uploads/2015/02/2015_Steelers_Mock_Draft-120x67.jpg 120w" sizes="(max-width: 300px) 100vw, 300px" />						<img width="80" height="45" src="http://www.steelersdepot.com/wp-content/uploads/2015/02/2015_Steelers_Mock_Draft.jpg" class="mob-img wp-post-image" alt="" srcset="http://www.steelersdepot.com/wp-content/uploads/2015/02/2015_Steelers_Mock_Draft.jpg 650w, http://www.steelersdepot.com/wp-content/uploads/2015/02/2015_Steelers_Mock_Draft-300x169.jpg 300w, http://www.steelersdepot.com/wp-content/uploads/2015/02/2015_Steelers_Mock_Draft-180x101.jpg 180w, http://www.steelersdepot.com/wp-content/uploads/2015/02/2015_Steelers_Mock_Draft-260x146.jpg 260w, http://www.steelersdepot.com/wp-content/uploads/2015/02/2015_Steelers_Mock_Draft-373x210.jpg 373w, http://www.steelersdepot.com/wp-content/uploads/2015/02/2015_Steelers_Mock_Draft-120x67.jpg 120w" sizes="(max-width: 80px) 100vw, 80px" />					</a></div><div class="mvp-related-text left relative"> <a href="http://www.steelersdepot.com/2015/05/2008-10-nfl-drafts-continue-to-haunt-steelers/">2008-10 NFL Drafts Continue To Haunt Steelers</a></div></li><li><div class="mvp-related-img left relative"> <a href="http://www.steelersdepot.com/2015/01/steelers-signed-elvis-dumervil-instead-ravens/" rel="bookmark" title="What If The Steelers Had Signed Elvis Dumervil Instead Of The Ravens? "> <img width="248" height="180" src="http://www.steelersdepot.com/wp-content/uploads/2015/01/Elvis-Dumervil-Headshot.png" class="reg-img wp-post-image" alt="" srcset="http://www.steelersdepot.com/wp-content/uploads/2015/01/Elvis-Dumervil-Headshot.png 600w, http://www.steelersdepot.com/wp-content/uploads/2015/01/Elvis-Dumervil-Headshot-300x218.png 300w" sizes="(max-width: 248px) 100vw, 248px" />						<img width="80" height="58" src="http://www.steelersdepot.com/wp-content/uploads/2015/01/Elvis-Dumervil-Headshot.png" class="mob-img wp-post-image" alt="" srcset="http://www.steelersdepot.com/wp-content/uploads/2015/01/Elvis-Dumervil-Headshot.png 600w, http://www.steelersdepot.com/wp-content/uploads/2015/01/Elvis-Dumervil-Headshot-300x218.png 300w" sizes="(max-width: 80px) 100vw, 80px" />					</a></div><div class="mvp-related-text left relative"> <a href="http://www.steelersdepot.com/2015/01/steelers-signed-elvis-dumervil-instead-ravens/">What If The Steelers Had Signed Elvis Dumervil Instead Of The Ravens? </a></div></li></ul></div><div id="comments-button" class="left relative comment-click-487690 com-but-487690"> <span class="comment-but-text"><span class="dsq-postid" data-dsqidentifier="487690 http://www.steelersdepot.com/?p=487690">Comments</span></span></div><div id="disqus_thread" class="disqus-thread-487690"></div> <script type="text/javascript">var disqus_shortname="steelersdepot";var disqus_title="Ryan Leaf's Advice To QB Selected By Browns: Eli Manning Your Way Out";var disqus_url="http://www.steelersdepot.com/2018/04/ryan-leafs-advice-to-qb-selected-by-browns-eli-manning-your-way-out/";var disqus_identifier="steelersdepot-487690";</script> </div></div></div></div> </article></div></div><div id="post-right-col" class="relative"><div id="sidebar-wrap" class="left relative theiaStickySidebar"><div id="custom_html-19" class="widget_text side-widget widget_custom_html"><div class="textwidget custom-html-widget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-7138622909378284" data-ad-slot="2275390383" data-ad-format="auto"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div></div><div id="taboola-3" class="side-widget widget_taboola"><script type="text/javascript">window._taboola=window._taboola||[];_taboola.push({mode:'thumbnails-rr',container:'taboola-3',placement:'sidebar-widget-post-3',target_type:'mix'});</script></div><div id="custom_html-20" class="widget_text side-widget widget_custom_html"><div class="textwidget custom-html-widget"><center><a target="_blank" href="http://shareasale.com/r.cfm?b=537844&amp;u=275818&amp;m=7124&amp;urllink=&amp;afftrack="><img src="http://static.shareasale.com/image/7124/NFL_Pittsburg_Steelers_300x250.jpg" border="0" alt="Shop the newest Pittsburgh Steelers fan gear at Fanatics!" /></a></center></div></div></div></div></div></div></div></div></div></div><footer id="foot-wrap" class="left relative"><div id="foot-top-wrap" class="left relative"><div class="body-main-out relative"><div class="body-main-in"><div id="foot-widget-wrap" class="left relative"><div class="foot-widget left relative"><div class="foot-logo left realtive"> <img src="http://www.steelersdepot.com/wp-content/themes/flex-mag/images/logos/logo-foot.png" alt="Steelers Depot" data-rjs="2" /></div><div class="foot-info-text left relative"><p>Quis autem vel eum iure reprehenderit qui in ea voluptate velit esse quam nihil molestiae consequatur, vel illum qui dolorem?</p><p>Temporibus autem quibusdam et aut officiis debitis aut rerum necessitatibus saepe eveniet.</p></div><div class="foot-soc left relative"><ul class="foot-soc-list relative"><li class="foot-soc-twit"> <a href="https://twitter.com/Steelersdepot" target="_blank"><i class="fa fa-twitter-square fa-2"></i></a></li><li class="foot-soc-rss"> <a href="http://www.steelersdepot.com/feed/rss/" target="_blank"><i class="fa fa-rss-square fa-2"></i></a></li></ul></div></div></div></div></div></div><div id="foot-bot-wrap" class="left relative"><div class="body-main-out relative"><div class="body-main-in"><div id="foot-bot" class="left relative"><div class="foot-menu relative"><div class="menu-header-container"><ul id="menu-header-2" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-37673"><a href="http://www.steelersdepot.com">Home</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154806"><a href="http://www.steelersdepot.com/category/news/">Steelers News</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38055"><a href="http://www.steelersdepot.com/steelers-news/">Steelers Wire</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-163626"><a href="http://www.steelersdepot.com/category/podcast/">Podcast</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-240752"><a>NFL Draft Info</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-456507"><a href="http://www.steelersdepot.com/2017-nfl-scouting-combine-results-tracker/">2017 NFL Combine Results</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-240753"><a href="http://www.steelersdepot.com/2016/03/steelers-2016-pre-draft-visit-tracker/">2016 Pre-Draft Visits</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-225936"><a title="2016 NFL Combine Results" href="http://www.steelersdepot.com/2016-nfl-scouting-combine-results/">2016 NFL Combine Results</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38058"><a href="http://www.dpbolvw.net/click-2334271-10539967?url=http%3A%2F%2Fwww.zinio.com%2Fwww%2Fbrowse%2Fproduct.jsp%3FproductId%3D500215550%26affId%3Dcj%26rf%3Dcjaffcatalog&#038;cjsku=500073101">Steelers Digest</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-158274"><a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&#038;hosted_button_id=XZ97MFHPQZYX4">Donate</a></li></ul></div></div><div class="foot-copy relative"><p>&copy; 2018 Steelers Depot</p></div></div></div></div></div> </footer></div></div><div class="fly-to-top back-to-top"> <i class="fa fa-angle-up fa-3"></i> <span class="to-top-text">To Top</span></div><div class="fly-fade"></div> <script type="text/javascript">var sectionCode=sectionCode||[];sectionCode.push("a70f4eaa-a346-43eb-98ae-f8e6526f5f12");(function(){var script=document.createElement("script");script.async=true;script.src="https://s.yimg.com/av/gemini/ga/gemini.js";document.body.appendChild(script);})();</script><script type='text/javascript'>window._taboola=window._taboola||[];_taboola.push({flush:true});</script> <div data-theiaStickySidebar-sidebarSelector='"#tab-col2"' data-theiaStickySidebar-options='{"containerSelector":"#home-main-wrap","additionalMarginTop":0,"additionalMarginBottom":0,"updateSidebarHeight":false,"minWidth":0,"sidebarBehavior":"modern","disableOnResponsiveLayouts":true}'></div><div data-theiaStickySidebar-sidebarSelector='"#tab-col3"' data-theiaStickySidebar-options='{"containerSelector":"#home-main-wrap","additionalMarginTop":90,"additionalMarginBottom":0,"updateSidebarHeight":false,"minWidth":0,"sidebarBehavior":"modern","disableOnResponsiveLayouts":true}'></div><div data-theiaStickySidebar-sidebarSelector='"#post-right-col"' data-theiaStickySidebar-options='{"containerSelector":"#home-main-wrap","additionalMarginTop":90,"additionalMarginBottom":0,"updateSidebarHeight":false,"minWidth":0,"sidebarBehavior":"modern","disableOnResponsiveLayouts":true}'></div> <script type="text/javascript">/*<![CDATA[*/jQuery(document).ready(function($){var duration=500;$('.back-to-top').click(function(event){event.preventDefault();$('html, body').animate({scrollTop:0},duration);return false;});$('.menu-item-has-children a').click(function(event){event.stopPropagation();location.href=this.href;});$('.menu-item-has-children').click(function(){$(this).addClass('toggled');if($('.menu-item-has-children').hasClass('toggled'))
{$(this).children('ul').toggle();$('.fly-nav-menu').getNiceScroll().resize();}
$(this).toggleClass('tog-minus');return false;});$(window).load(function(){$('.fly-nav-menu').niceScroll({cursorcolor:"#888",cursorwidth:7,cursorborder:0,zindex:999999});});$(".comment-click-487690").on("click",function(){$(".com-click-id-487690").show();$(".disqus-thread-487690").show();$(".com-but-487690").hide();});$(window).load(function(){$('.post-gallery-bot').flexslider({animation:"slide",controlNav:false,animationLoop:true,slideshow:false,itemWidth:80,itemMargin:10,asNavFor:'.post-gallery-top'});$('.post-gallery-top').flexslider({animation:"fade",controlNav:false,animationLoop:true,slideshow:false,prevText:"&lt;",nextText:"&gt;",sync:".post-gallery-bot"});});});/*]]>*/</script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-includes/js/comment-reply.min.js?ver=4.9.4'></script> <script type='text/javascript'>var countVars={"disqusShortname":"steelersdepot"};</script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.15'></script> <script type='text/javascript'>var embedVars={"disqusConfig":{"integration":"wordpress 3.0.15"},"disqusIdentifier":"487690 http:\/\/www.steelersdepot.com\/?p=487690","disqusShortname":"steelersdepot","disqusTitle":"Ryan Leaf\u2019s Advice To QB Selected By Browns: Eli Manning Your Way Out","disqusUrl":"http:\/\/www.steelersdepot.com\/2018\/04\/ryan-leafs-advice-to-qb-selected-by-browns-eli-manning-your-way-out\/","postId":"487690"};</script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.15'></script> <script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201814'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-content/plugins/theia-sticky-sidebar/js/theia-sticky-sidebar.js?ver=1.6.3'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-content/plugins/theia-sticky-sidebar/js/main.js?ver=1.6.3'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-content/themes/flex-mag/js/scripts.js?ver=4.9.4'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-content/themes/flex-mag/js/autoloadpost.js?ver=4.9.4'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-content/themes/flex-mag/js/retina.js?ver=4.9.4'></script> <script type='text/javascript' src='https://maxcdn.bootstrapcdn.com/bootstrap/3.3.7/js/bootstrap.min.js?ver=4.9.4'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-content/themes/flex-mag-child/assets/js/main.js?ver=4.9.4'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-includes/js/wp-embed.min.js?ver=4.9.4'></script> <script type="text/javascript" id="slb_context">if(!!window.jQuery){(function($){$(document).ready(function(){if(!!window.SLB){{$.extend(SLB,{"context":["public","user_guest"]});}}})})(jQuery);}</script> <script type='text/javascript' src='https://stats.wp.com/e-201814.js' async='async' defer='defer'></script> <script type='text/javascript'>_stq=window._stq||[];_stq.push(['view',{v:'ext',j:'1:5.9',blog:'12286105',post:'487690',tz:'-4',srv:'www.steelersdepot.com'}]);_stq.push(['clickTrackerInit','12286105','487690']);</script> <script id="dsq-count-scr" src="//steelersdepot.disqus.com/count.js" async></script> </body></html>