
<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8" >
<meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" />

<meta name="robots" content="noarchive">


<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="https://www.steelersdepot.com/feed/" />
<link rel="alternate" type="text/xml" title="RSS .92" href="https://www.steelersdepot.com/feed/rss/" />
<link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="https://www.steelersdepot.com/feed/atom/" />
<link rel="pingback" href="https://www.steelersdepot.com/xmlrpc.php" />

<meta property="og:image" content="https://www.steelersdepot.com/wp-content/uploads/2018/06/Landry-Jones-OTAs.jpg" />
<meta name="twitter:image" content="https://www.steelersdepot.com/wp-content/uploads/2018/06/Landry-Jones-OTAs.jpg" />

<meta property="og:type" content="article" />
<meta property="og:description" content="In case you&#8217;re wondering how the competition is going at the backup quarterback positions so far during the Pittsburgh Steelers 2018 training camp, it&#8217;s going just like you should have thought it would way before the team even reported to Saint Vincent College in Latrobe over a week ago. In short, Landry Jones is still [&hellip;]" />
<meta name="twitter:card" content="summary">
<meta name="twitter:url" content="https://www.steelersdepot.com/2018/08/colbert-on-backup-qb-competition-obviously-landrys-our-number-two/">
<meta name="twitter:title" content="Colbert On Backup QB Competition: &#8216;Obviously, Landry&#8217;s Our Number Two&#8217;">
<meta name="twitter:description" content="In case you&#8217;re wondering how the competition is going at the backup quarterback positions so far during the Pittsburgh Steelers 2018 training camp, it&#8217;s going just like you should have thought it would way before the team even reported to Saint Vincent College in Latrobe over a week ago. In short, Landry Jones is still [&hellip;]">


<title>Colbert On Backup QB Competition: &#039;Obviously, Landry&#039;s Our Number Two&#039; - Steelers Depot</title>

<!-- This site is optimized with the Yoast SEO plugin v7.9 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="In case you&#039;re wondering how the competition is going at the backup quarterback positions so far during the Pittsburgh Steelers 2018 training camp, it&#039;s"/>
<link rel="canonical" href="https://www.steelersdepot.com/2018/08/colbert-on-backup-qb-competition-obviously-landrys-our-number-two/" />
<link rel="publisher" href="https://plus.google.com/+DaveBryan"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Colbert On Backup QB Competition: &#039;Obviously, Landry&#039;s Our Number Two&#039; - Steelers Depot" />
<meta property="og:description" content="In case you&#039;re wondering how the competition is going at the backup quarterback positions so far during the Pittsburgh Steelers 2018 training camp, it&#039;s" />
<meta property="og:url" content="https://www.steelersdepot.com/2018/08/colbert-on-backup-qb-competition-obviously-landrys-our-number-two/" />
<meta property="og:site_name" content="Steelers Depot" />
<meta property="article:tag" content="Joshua Dobbs" />
<meta property="article:tag" content="Kevin Colbert" />
<meta property="article:tag" content="Landry Jones" />
<meta property="article:tag" content="Mason Rudolph" />
<meta property="article:section" content="Steelers News" />
<meta property="article:published_time" content="2018-08-02T12:24:26-04:00" />
<meta property="og:image" content="https://www.steelersdepot.com/wp-content/uploads/2018/06/Landry-Jones-OTAs.jpg" />
<meta property="og:image:secure_url" content="https://www.steelersdepot.com/wp-content/uploads/2018/06/Landry-Jones-OTAs.jpg" />
<meta property="og:image:width" content="777" />
<meta property="og:image:height" content="437" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="In case you&#039;re wondering how the competition is going at the backup quarterback positions so far during the Pittsburgh Steelers 2018 training camp, it&#039;s" />
<meta name="twitter:title" content="Colbert On Backup QB Competition: &#039;Obviously, Landry&#039;s Our Number Two&#039; - Steelers Depot" />
<meta name="twitter:site" content="@Steelersdepot" />
<meta name="twitter:image" content="https://www.steelersdepot.com/wp-content/uploads/2018/06/Landry-Jones-OTAs.jpg" />
<meta name="twitter:creator" content="@Steelersdepot" />
<script type='application/ld+json'>{"@context":"https:\/\/schema.org","@type":"Organization","url":"https:\/\/www.steelersdepot.com\/","sameAs":["https:\/\/plus.google.com\/+DaveBryan","https:\/\/twitter.com\/Steelersdepot"],"@id":"https:\/\/www.steelersdepot.com\/#organization","name":"Steelers Depot","logo":""}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//www.steelersdepot.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//netdna.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Steelers Depot &raquo; Feed" href="https://www.steelersdepot.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Steelers Depot &raquo; Comments Feed" href="https://www.steelersdepot.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Steelers Depot &raquo; Colbert On Backup QB Competition: &#8216;Obviously, Landry&#8217;s Our Number Two&#8217; Comments Feed" href="https://www.steelersdepot.com/2018/08/colbert-on-backup-qb-competition-obviously-landrys-our-number-two/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.steelersdepot.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.7"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='feedzy-rss-feeds-css'  href='https://www.steelersdepot.com/wp-content/plugins/feedzy-rss-feeds/css/feedzy-rss-feeds.css?ver=3.2.11' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://www.steelersdepot.com/wp-includes/css/dashicons.min.css?ver=4.9.7' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-reset-css'  href='https://www.steelersdepot.com/wp-content/themes/flex-mag/css/reset.css?ver=4.9.7' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-fontawesome-css'  href='//netdna.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.css?ver=4.9.7' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-style-css'  href='https://www.steelersdepot.com/wp-content/themes/flex-mag-child/style.css?ver=4.9.7' type='text/css' media='all' />
<!--[if lt IE 10]>
<link rel='stylesheet' id='mvp-iecss-css'  href='https://www.steelersdepot.com/wp-content/themes/flex-mag-child/css/iecss.css?ver=4.9.7' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='mvp-style-entertainment-css'  href='https://www.steelersdepot.com/wp-content/themes/flex-mag/css/style-entertainment.css?ver=4.9.7' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-media-queries-css'  href='https://www.steelersdepot.com/wp-content/themes/flex-mag/css/media-queries.css?ver=4.9.7' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack-widget-social-icons-styles-css'  href='https://www.steelersdepot.com/wp-content/plugins/jetpack/modules/widgets/social-icons/social-icons.css?ver=20170506' type='text/css' media='all' />
<link rel='stylesheet' id='slb_core-css'  href='https://www.steelersdepot.com/wp-content/plugins/simple-lightbox/client/css/app.css?ver=2.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='child-main-css'  href='https://www.steelersdepot.com/wp-content/themes/flex-mag-child/assets/css/_main.min.css?ver=4.9.7' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css-css'  href='https://maxcdn.bootstrapcdn.com/bootstrap/4.0.0/css/bootstrap.min.css?ver=4.9.7' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.steelersdepot.com/wp-content/plugins/jetpack/css/jetpack.css?ver=6.3.3' type='text/css' media='all' />
<script type='text/javascript' src='https://www.steelersdepot.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.steelersdepot.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.steelersdepot.com/wp-content/themes/flex-mag-child/assets/js/googlesyndication.js?ver=4.9.7'></script>
<link rel='https://api.w.org/' href='https://www.steelersdepot.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.steelersdepot.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.steelersdepot.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.9.7" />
<link rel='shortlink' href='https://wp.me/pPyaZ-250v' />
<link rel="alternate" type="application/json+oembed" href="https://www.steelersdepot.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.steelersdepot.com%2F2018%2F08%2Fcolbert-on-backup-qb-competition-obviously-landrys-our-number-two%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.steelersdepot.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.steelersdepot.com%2F2018%2F08%2Fcolbert-on-backup-qb-competition-obviously-landrys-our-number-two%2F&#038;format=xml" />
<script type="text/javascript" data-cfasync="false">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</script><style type='text/css'>img#wpstats{display:none}</style>
<style type='text/css'>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</style>
	
<style type="text/css">


.post-cont-out,
.post-cont-in {
	margin-right: 0;
	}




.home-wrap-out2 {
	float: left;
	margin-left: 0;
	margin-right: -315px;
	}
.home-wrap-in2 {
	margin-left: 0;
	margin-right: 315px;
	}
.home-left-col {
	float: left;
	}
.home-mid-col {
	float: right;
	margin-left: 15px;
	margin-right: 0;
	}

@media screen and (max-width: 1399px) and (min-width: 1250px) {
.home-wrap-out2 {
	float: left;
	margin-left: 0;
	margin-right: -265px;
	}
.home-wrap-in2 {
	margin-left: 0;
	margin-right: 265px;
	}
}
@media screen and (max-width: 1249px) and (min-width: 1100px) {
.home-wrap-out2 {
	float: left;
	margin-left: 0;
	margin-right: -265px;
	}
.home-wrap-in2 {
	margin-left: 0;
	margin-right: 265px;
	}
}
@media screen and (max-width: 1099px) {
.home-wrap-out2,
.home-wrap-in2 {
	float: left;
	margin-left: 0;
	margin-right: 0;
	}
.home-mid-col {
	float: left;
	}
}
@media screen and (max-width: 479px) {
.home-mid-col {
	margin-left: 0;
	}
}





</style>

<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #eeeeee; }
</style>

		<script type="text/javascript">
		window._taboola = window._taboola || [];
		_taboola.push({article:'auto'});
		!function (e, f, u, i) {
			if (!document.getElementById(i)){
				e.async = 1;
				e.src = u;
				e.id = i;
				f.parentNode.insertBefore(e, f);
			}
		}(document.createElement('script'),
		document.getElementsByTagName('script')[0],
		'//cdn.taboola.com/libtrc/steelersdepot/loader.js',
		'tb_loader_script');
		if(window.performance && typeof window.performance.mark == 'function')
		{window.performance.mark('tbl_ic');}
	</script>
	</head>


<body class="post-template-default single single-post postid-495907 single-format-standard custom-background logged-out">
	<script>
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','/wp-content/themes/flex-mag-child/assets/js/google-analytics.js','ga');

	ga('create', 'UA-11437002-3', 'auto');
	ga('send', 'pageview');
	</script>
	<div id="site" class="left relative">
		<div id="site-wrap" class="left relative">
						<div id="fly-wrap">
	<div class="fly-wrap-out">
		<div class="fly-side-wrap">
			<ul class="fly-bottom-soc left relative">
													<li class="twit-soc">
						<a href="https://twitter.com/Steelersdepot" target="_blank">
						<i class="fa fa-twitter fa-2"></i>
						</a>
					</li>
																																					<li class="rss-soc">
						<a href="https://www.steelersdepot.com/feed/rss/" target="_blank">
						<i class="fa fa-rss fa-2"></i>
						</a>
					</li>
							</ul>
		</div><!--fly-side-wrap-->
		<div class="fly-wrap-in">
			<div id="fly-menu-wrap">
				<nav class="fly-nav-menu left relative">
					<div class="menu-header-container"><ul id="menu-header" class="menu"><li id="menu-item-37673" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37673"><a href="/">Home</a></li>
<li id="menu-item-154806" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154806"><a href="/category/news/">Steelers News</a></li>
<li id="menu-item-38055" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38055"><a href="/steelers-news/">Steelers Wire</a></li>
<li id="menu-item-163626" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-163626"><a href="/category/podcast/">Podcast</a></li>
<li id="menu-item-240752" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-240752"><a>NFL Draft Info</a>
<ul class="sub-menu">
	<li id="menu-item-456507" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-456507"><a href="/2017-nfl-scouting-combine-results-tracker/">2017 NFL Combine Results</a></li>
	<li id="menu-item-240753" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-240753"><a href="/2016/03/steelers-2016-pre-draft-visit-tracker/">2016 Pre-Draft Visits</a></li>
	<li id="menu-item-225936" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-225936"><a title="2016 NFL Combine Results" href="/2016-nfl-scouting-combine-results/">2016 NFL Combine Results</a></li>
</ul>
</li>
<li id="menu-item-38058" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38058"><a href="http://www.dpbolvw.net/click-2334271-10539967?url=http%3A%2F%2Fwww.zinio.com%2Fwww%2Fbrowse%2Fproduct.jsp%3FproductId%3D500215550%26affId%3Dcj%26rf%3Dcjaffcatalog&#038;cjsku=500073101">Steelers Digest</a></li>
<li id="menu-item-158274" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-158274"><a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&#038;hosted_button_id=XZ97MFHPQZYX4">Donate</a></li>
<li id="menu-item-493253" class="logged-out menu-item menu-item-type-post_type menu-item-object-page menu-item-493253"><a href="https://www.steelersdepot.com/go-ad-free/">Go Ad-Free</a></li>
<li id="menu-item-493254" class="logged-out menu-item menu-item-type-custom menu-item-object-custom menu-item-493254"><a href="/wp-login.php">Login</a></li>
<li id="menu-item-493255" class="logged-in menu-item menu-item-type-custom menu-item-object-custom menu-item-493255"><a href="/wp-login.php?action=logout">Logout</a></li>
</ul></div>				</nav>
			</div><!--fly-menu-wrap-->
		</div><!--fly-wrap-in-->
	</div><!--fly-wrap-out-->
</div><!--fly-wrap-->			<div id="head-main-wrap" class="left relative">
				<div id="head-main-top" class="left relative">
																														</div><!--head-main-top-->
				<div id="main-nav-wrap">
					<div class="nav-out">
						<div class="nav-in">
							<div id="main-nav-cont" class="left" itemscope itemtype="http://schema.org/Organization">
								<div class="nav-logo-out">
									<div class="nav-left-wrap left relative">
										<div class="fly-but-wrap left relative">
											<span></span>
											<span></span>
											<span></span>
											<span></span>
										</div><!--fly-but-wrap-->
																					<div class="nav-logo left">
																									<a itemprop="url" href="https://www.steelersdepot.com/"><img itemprop="logo" src="https://www.steelersdepot.com/wp-content/uploads/2015/07/cropped-cropped-depot-logo1.png" alt="Steelers Depot" data-rjs="2" /></a>
																																					<h2 class="mvp-logo-title">Steelers Depot</h2>
																							</div><!--nav-logo-->
																			</div><!--nav-left-wrap-->
									<div class="nav-logo-in">
										<div class="nav-menu-out">
											<div class="nav-menu-in">
												<nav class="main-menu-wrap left">
													<div class="menu-header-container"><ul id="menu-header-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37673"><a href="/">Home</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154806"><a href="/category/news/">Steelers News</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38055"><a href="/steelers-news/">Steelers Wire</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-163626"><a href="/category/podcast/">Podcast</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-240752"><a>NFL Draft Info</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-456507"><a href="/2017-nfl-scouting-combine-results-tracker/">2017 NFL Combine Results</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-240753"><a href="/2016/03/steelers-2016-pre-draft-visit-tracker/">2016 Pre-Draft Visits</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-225936"><a title="2016 NFL Combine Results" href="/2016-nfl-scouting-combine-results/">2016 NFL Combine Results</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38058"><a href="http://www.dpbolvw.net/click-2334271-10539967?url=http%3A%2F%2Fwww.zinio.com%2Fwww%2Fbrowse%2Fproduct.jsp%3FproductId%3D500215550%26affId%3Dcj%26rf%3Dcjaffcatalog&#038;cjsku=500073101">Steelers Digest</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-158274"><a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&#038;hosted_button_id=XZ97MFHPQZYX4">Donate</a></li>
<li class="logged-out menu-item menu-item-type-post_type menu-item-object-page menu-item-493253"><a href="https://www.steelersdepot.com/go-ad-free/">Go Ad-Free</a></li>
<li class="logged-out menu-item menu-item-type-custom menu-item-object-custom menu-item-493254"><a href="/wp-login.php">Login</a></li>
<li class="logged-in menu-item menu-item-type-custom menu-item-object-custom menu-item-493255"><a href="/wp-login.php?action=logout">Logout</a></li>
</ul></div>												</nav>
											</div><!--nav-menu-in-->
											<div class="nav-right-wrap relative">
												<div class="nav-search-wrap left relative">
													<span class="nav-search-but left"><i class="fa fa-search fa-2"></i></span>
													<div class="search-fly-wrap">
														<form method="get" id="searchform" action="https://www.steelersdepot.com/">
	<input type="text" name="s" id="s" value="Type search term and press enter" onfocus='if (this.value == "Type search term and press enter") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Type search term and press enter"; }' />
	<input type="hidden" id="searchsubmit" value="Search" />
</form>													</div><!--search-fly-wrap-->
												</div><!--nav-search-wrap-->
																																					<a href="https://twitter.com/Steelersdepot" target="_blank">
													<span class="nav-soc-but"><i class="fa fa-twitter fa-2"></i></span>
													</a>
																							</div><!--nav-right-wrap-->
										</div><!--nav-menu-out-->
									</div><!--nav-logo-in-->
								</div><!--nav-logo-out-->
							</div><!--main-nav-cont-->
						</div><!--nav-in-->
					</div><!--nav-out-->
				</div><!--main-nav-wrap-->
			</div><!--head-main-wrap-->
										<div id="body-main-wrap" class="left relative" itemscope itemtype="http://schema.org/NewsArticle">
					<meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="https://www.steelersdepot.com/2018/08/colbert-on-backup-qb-competition-obviously-landrys-our-number-two/"/>
																																			<div class="body-main-out relative">
					<div class="body-main-in">
						<div id="body-main-cont" class="left relative">
																			<div id="leader-wrap" class="left relative">
								<!-- large column top -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-7138622909378284"
     data-ad-slot="9571372570"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>							</div><!--leader-wrap-->
												<div id="post-main-wrap" class="left relative">
	<div class="post-wrap-out1">
		<div class="post-wrap-in1">
			<div id="post-left-col" class="relative">
	<article id="post-area" class="post-495907 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-joshua-dobbs tag-kevin-colbert tag-landry-jones tag-mason-rudolph">
			<header id="post-header">
							<a class="post-cat-link" href="https://www.steelersdepot.com/category/news/"><span class="post-head-cat">Steelers News</span></a>
						<h1 class="post-title entry-title left" itemprop="headline">Colbert On Backup QB Competition: &#8216;Obviously, Landry&#8217;s Our Number Two&#8217;</h1>
							<div id="post-info-wrap" class="left relative">
					<div class="post-info-out">
						<div class="post-info-img left relative">
							<img alt='' src='https://secure.gravatar.com/avatar/108b00b5dd3364a8638248aea7b2da43?s=50&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/108b00b5dd3364a8638248aea7b2da43?s=100&#038;d=mm&#038;r=g 2x' class='avatar arm_grid_avatar arm-avatar avatar-50 photo' height='50' width='50' />						</div><!--post-info-img-->
						<div class="post-info-in">
							<div class="post-info-right left relative">
								<div class="post-info-name left relative" itemprop="author" itemscope itemtype="https://schema.org/Person">
									<span class="post-info-text">By</span> <span class="author-name vcard fn author" itemprop="name"><a href="https://www.steelersdepot.com/author/davebryan/" title="Posts by Dave Bryan" rel="author">Dave Bryan</a></span> 																	</div><!--post-info-name-->
								<div class="post-info-date left relative">
									<span class="post-info-text">Posted on</span> <span class="post-date updated"><time class="post-date updated" itemprop="datePublished" datetime="2018-08-02">August 2, 2018 at 12:24 pm</time></span>
									<meta itemprop="dateModified" content="2018-08-02"/>
								</div><!--post-info-date-->
							</div><!--post-info-right-->
						</div><!--post-info-in-->
					</div><!--post-info-out-->
				</div><!--post-info-wrap-->
					</header><!--post-header-->
	

			<section class="social-sharing-top">
			<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://www.steelersdepot.com/2018/08/colbert-on-backup-qb-competition-obviously-landrys-our-number-two/&amp;t=Colbert On Backup QB Competition: &#8216;Obviously, Landry&#8217;s Our Number Two&#8217;', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><div class="facebook-share"><span class="fb-but1"><i class="fa fa-facebook fa-2"></i></span><span class="social-text">Share</span></div></a>
			<a href="#" onclick="window.open('http://twitter.com/share?text=Colbert On Backup QB Competition: &#8216;Obviously, Landry&#8217;s Our Number Two&#8217; -&amp;url=https://www.steelersdepot.com/2018/08/colbert-on-backup-qb-competition-obviously-landrys-our-number-two/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><div class="twitter-share"><span class="twitter-but1"><i class="fa fa-twitter fa-2"></i></span><span class="social-text">Tweet</span></div></a>
			<a href="whatsapp://send?text=Colbert On Backup QB Competition: &#8216;Obviously, Landry&#8217;s Our Number Two&#8217; https://www.steelersdepot.com/2018/08/colbert-on-backup-qb-competition-obviously-landrys-our-number-two/"><div class="whatsapp-share"><span class="whatsapp-but1"><i class="fa fa-whatsapp fa-2"></i></span><span class="social-text">Share</span></div></a>
			<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://www.steelersdepot.com/2018/08/colbert-on-backup-qb-competition-obviously-landrys-our-number-two/&amp;media=https://www.steelersdepot.com/wp-content/uploads/2018/06/Landry-Jones-OTAs.jpg&amp;description=Colbert On Backup QB Competition: &#8216;Obviously, Landry&#8217;s Our Number Two&#8217;', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><div class="pinterest-share"><span class="pinterest-but1"><i class="fa fa-pinterest-p fa-2"></i></span><span class="social-text">Share</span></div></a>
			<a href="/cdn-cgi/l/email-protection#f1ce8284939b949285ccb29e9d93948385d1be9fd1b390929a8481d1a0b3d1b29e9c8194859885989e9fcbd1d7d2c9c3c0c7cabe9387989e84829d88ddd1bd909f958388d7d2c9c3c0c6ca82d1be8483d1bf849c939483d1a5869ed7d2c9c3c0c6cad7909c81cab3beb5a8ccb8d1979e849f95d185999882d190838598929d94d1989f859483948285989f96d1909f95d185999e84969985d19e97d182999083989f96d19885d186988599d1889e84dfd1b29994929ad19885d19e8485cbd19985858182cbdede868686df828594949d9483829594819e85df929e9cdec3c1c0c9dec1c9de929e9d93948385dc9e9fdc9390929a8481dc8093dc929e9c8194859885989e9fdc9e9387989e84829d88dc9d909f95838882dc9e8483dc9f849c939483dc85869ede"><div class="email-share"><span class="email-but"><i class="fa fa-envelope fa-2"></i></span><span class="social-text">Email</span></div></a>
																	<a href="#disqus_thread"><div class="social-comments comment-click-495907"><i class="fa fa-commenting fa-2"></i></div></a>
									</section><!--social-sharing-top-->
	


																					<div class="left" id="post-feat-img-wrapper">
							<div id="post-feat-img" class="relative" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
								<img width="777" height="437" src="https://www.steelersdepot.com/wp-content/uploads/2018/06/Landry-Jones-OTAs.jpg" class="attachment- size- wp-post-image" alt="" srcset="https://www.steelersdepot.com/wp-content/uploads/2018/06/Landry-Jones-OTAs.jpg 777w, https://www.steelersdepot.com/wp-content/uploads/2018/06/Landry-Jones-OTAs-300x169.jpg 300w, https://www.steelersdepot.com/wp-content/uploads/2018/06/Landry-Jones-OTAs-768x432.jpg 768w" sizes="(max-width: 777px) 100vw, 777px" />																<meta itemprop="url" content="https://www.steelersdepot.com/wp-content/uploads/2018/06/Landry-Jones-OTAs.jpg">
								<meta itemprop="width" content="777">
								<meta itemprop="height" content="437">
								<div class="post-feat-text">
																										</div><!--post-feat-text-->
							</div><!--post-feat-img-->
						</div>
																<div id="content-area" itemprop="articleBody" class="post-495907 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-joshua-dobbs tag-kevin-colbert tag-landry-jones tag-mason-rudolph">
		<div class="post-cont-out">
			<div class="post-cont-in">
				<div id="content-main" class="left relative">

						
	
		<div class="post-specific-content">
<p>In case you&#8217;re wondering how the competition is going at the backup quarterback positions so far during the <strong>Pittsburgh Steelers</strong> 2018 training camp, it&#8217;s going just like you should have thought it would way before the team even reported to Saint Vincent College in Latrobe over a week ago. In short, <strong>Landry Jones</strong> is still the backup behind starter <strong>Ben Roethlisberger</strong> with <strong>Joshua Dobbs</strong> and rookie <strong>Mason Rudolph</strong> lined up behind those two, respectively.</p>
<p><a href="https://937thefan.radio.com/articles/steelers-general-manager-kevin-colbert-stands-steelers-negotiation-tactics">During a morning interview</a> a few days ago on <em>93.7 The Fan</em>, Steelers general manager <strong>Kevin Colbert</strong> was essentially asked if Jones is currently having to battle Rudolph, the team&#8217;s first of two third-round draft picks this year, for the right to be the backup to Roethlisberger by the time the 2018 season gets underway.</p>
<p>&#8220;Well, I think Landry obviously has the experience advantage against a guy like Mason Rudolph and they come in here and they compete,&#8221; Colbert said. &#8220;I mean, obviously, Landry&#8217;s our number two. Joshua Dobbs is our number three right now and Mason has to work his way through the rotation. They&#8217;ll get their reps and Coach [Mike Tomlin] likes to mix the reps up to make it a fair competition so that when Landry and Mason and Joshua are working, they work with different groups so as to balance it out. You know, Mason&#8217;s not always with the fours, Landry&#8217;s not always with the twos and Josh isn&#8217;t always with the threes. So, the days that Ben doesn&#8217;t work, which are scheduled days, it helps to get those guys the extra reps and again, Coach we&#8217;ll mix those up.&#8221;</p>
<p>None of what Colbert said about the current quarterback pecking order should be surprising to anyone and especially with only six days of training camp practices now in the books. If anyone thought Rudolph would be higher than the fourth and final spot on the quarterback depth chart at this point of training camp, they were delirious.</p>
<p>It&#8217;s a given that Rudolph is going to make the team&#8217;s 53-man roster this year as long as he remains fully healthy and isn&#8217;t ultimately placed on the Reserve/Injured list. Assuming he sticks on the 53-man roster, Dobbs will more than likely be the odd man out and especially if Rudolph can&#8217;t earn the right to backup Roethlisberger over the course of the next four weeks.</p>
<p>It will be interesting to see how head coach <strong>Mike Tomlin</strong> ultimately works the quarterback rotation in the team&#8217;s first two games, however, and especially if Roethlisberger sits both contests out just as he did last year. While Jones could obviously see a little bit of playing time in both of those first two preseason games, Dobbs and Rudolph figure to see the lion&#8217;s share of snaps against the <strong>Philadelphia Eagles</strong> and <strong>Green Bay Packers</strong> just the same.</p>
<p>Last year, Dobbs and then No. 4 quarterback <strong>Bart Houston</strong> were the only two signal callers to see action in the Steelers preseason opener against the <strong>New York Giants</strong> and that&#8217;s likely because Jones was nursing an abdominal strain at the time. Those two quarterbacks also were the only two to see snaps against the <strong>Atlanta Falcons</strong> the following week and quite honestly, both played pretty bad.</p>
<p>By now, the Steelers should have a pretty good idea as to what kind of quarterback Jones is and isn&#8217;t entering his sixth year and thus him seeing any playing time in the Steelers first two preseason games probably isn&#8217;t overly necessary. Instead, the Steelers should let Dobbs and Rudolph play exclusively in the team&#8217;s first two preseason games this year and go from there.</p>
</div>

	<div id="taboola-below-article">
	<div id="custom_html-26" class="widget_text side-widget widget_custom_html"><div class="textwidget custom-html-widget"><div id="taboola-below-article-thumbnails"></div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({
    mode: 'thumbnails-a',
    container: 'taboola-below-article-thumbnails',
    placement: 'Below Article Thumbnails',
    target_type: 'mix'
  });
</script></div></div></div>

															<div class="mvp-org-wrap" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
						<div class="mvp-org-logo" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
															<img src="https://www.steelersdepot.com/wp-content/uploads/2015/07/cropped-cropped-depot-logo1.png"/>
								<meta itemprop="url" content="https://www.steelersdepot.com/wp-content/uploads/2015/07/cropped-cropped-depot-logo1.png">
													</div><!--mvp-org-logo-->
						<meta itemprop="name" content="Steelers Depot">
					</div><!--mvp-org-wrap-->
					<div class="posts-nav-link">
											</div><!--posts-nav-link-->
											<div class="post-tags">
							<span class="post-tags-header">Related Items:</span><span itemprop="keywords"><a href="https://www.steelersdepot.com/tag/joshua-dobbs/" rel="tag">Joshua Dobbs</a>, <a href="https://www.steelersdepot.com/tag/kevin-colbert/" rel="tag">Kevin Colbert</a>, <a href="https://www.steelersdepot.com/tag/landry-jones/" rel="tag">Landry Jones</a>, <a href="https://www.steelersdepot.com/tag/mason-rudolph/" rel="tag">Mason Rudolph</a></span>
						</div><!--post-tags-->
																<div class="social-sharing-bot">
							<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://www.steelersdepot.com/2018/08/colbert-on-backup-qb-competition-obviously-landrys-our-number-two/&amp;t=Colbert On Backup QB Competition: &#8216;Obviously, Landry&#8217;s Our Number Two&#8217;', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><div class="facebook-share"><span class="fb-but1"><i class="fa fa-facebook fa-2"></i></span><span class="social-text">Share</span> <span style="color: #fff; font-family: 'Montserrat', sans-serif; font-size: 10px; font-weight: 400; line-height: 100%; padding: 8px 0; text-transform: uppercase;"></span></div></a>
							<a href="#" onclick="window.open('http://twitter.com/share?text=Colbert On Backup QB Competition: &#8216;Obviously, Landry&#8217;s Our Number Two&#8217; -&amp;url=https://www.steelersdepot.com/2018/08/colbert-on-backup-qb-competition-obviously-landrys-our-number-two/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><div class="twitter-share"><span class="twitter-but1"><i class="fa fa-twitter fa-2"></i></span><span class="social-text">Tweet</span></div></a>
							<a href="whatsapp://send?text=Colbert On Backup QB Competition: &#8216;Obviously, Landry&#8217;s Our Number Two&#8217; https://www.steelersdepot.com/2018/08/colbert-on-backup-qb-competition-obviously-landrys-our-number-two/"><div class="whatsapp-share"><span class="whatsapp-but1"><i class="fa fa-whatsapp fa-2"></i></span><span class="social-text">Share</span></div></a>
							<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://www.steelersdepot.com/2018/08/colbert-on-backup-qb-competition-obviously-landrys-our-number-two/&amp;media=https://www.steelersdepot.com/wp-content/uploads/2018/06/Landry-Jones-OTAs.jpg&amp;description=Colbert On Backup QB Competition: &#8216;Obviously, Landry&#8217;s Our Number Two&#8217;', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><div class="pinterest-share"><span class="pinterest-but1"><i class="fa fa-pinterest-p fa-2"></i></span><span class="social-text">Share</span></div></a>
							<a href="/cdn-cgi/l/email-protection#48773b3d2a222d2b3c750b27242a2d3a3c680726680a292b233d3868190a680b2725382d3c213c21272672686e6b707a797e73072a3e21273d3b243164680429262c3a316e6b707a797f733b68073d3a68063d252a2d3a681c3f276e6b707a797f736e292538730a070c117501682e273d262c683c20213b68293a3c212b242d6821263c2d3a2d3b3c21262f6829262c683c20273d2f203c68272e683b20293a21262f68213c683f213c206831273d66680b202d2b2368213c68273d3c7268203c3c383b7267673f3f3f663b3c2d2d242d3a3b2c2d38273c662b2725677a787970677870672b27242a2d3a3c652726652a292b233d3865392a652b2725382d3c213c21272665272a3e21273d3b2431652429262c3a313b65273d3a65263d252a2d3a653c3f2767"><div class="email-share"><span class="email-but"><i class="fa fa-envelope fa-2"></i></span><span class="social-text">Email</span></div></a>
						</div><!--social-sharing-bot-->
																            <div class="mvp-related-posts left relative">
		<h4 class="post-header"><span class="post-header">Recommended for you</span></h4>
			<ul>
            		            			<li>
                		<div class="mvp-related-img left relative">
										<a href="https://www.steelersdepot.com/2018/08/the-terrible-podcast-talking-steelers-possibly-extending-boswell-bell-clubbing-camp-continuing-on-more/" rel="bookmark" title="The Terrible Podcast – Talking Steelers Possibly Extending Boswell, Bell Clubbing, Camp Continuing On &#038; More">
						<img width="170" height="170" src="https://www.steelersdepot.com/wp-content/uploads/2013/08/terriblepodcast.jpg" class="reg-img wp-post-image" alt="" srcset="https://www.steelersdepot.com/wp-content/uploads/2013/08/terriblepodcast.jpg 170w, https://www.steelersdepot.com/wp-content/uploads/2013/08/terriblepodcast-150x150.jpg 150w, https://www.steelersdepot.com/wp-content/uploads/2013/08/terriblepodcast-144x144.jpg 144w" sizes="(max-width: 170px) 100vw, 170px" />						<img width="80" height="80" src="https://www.steelersdepot.com/wp-content/uploads/2013/08/terriblepodcast.jpg" class="mob-img wp-post-image" alt="" srcset="https://www.steelersdepot.com/wp-content/uploads/2013/08/terriblepodcast.jpg 170w, https://www.steelersdepot.com/wp-content/uploads/2013/08/terriblepodcast-150x150.jpg 150w, https://www.steelersdepot.com/wp-content/uploads/2013/08/terriblepodcast-144x144.jpg 144w" sizes="(max-width: 80px) 100vw, 80px" />					</a>
									</div><!--related-img-->
				<div class="mvp-related-text left relative">
					<a href="https://www.steelersdepot.com/2018/08/the-terrible-podcast-talking-steelers-possibly-extending-boswell-bell-clubbing-camp-continuing-on-more/">The Terrible Podcast – Talking Steelers Possibly Extending Boswell, Bell Clubbing, Camp Continuing On &#038; More</a>
				</div><!--related-text-->
            			</li>
            		            			<li>
                		<div class="mvp-related-img left relative">
										<a href="https://www.steelersdepot.com/2018/08/kevin-colberts-tenure-as-steelers-gm-unrivaled/" rel="bookmark" title="Kevin Colbert&#8217;s Tenure As Steelers GM Unrivaled">
						<img width="300" height="180" src="https://www.steelersdepot.com/wp-content/uploads/2018/04/StockColbert2-300x180.jpg" class="reg-img wp-post-image" alt="" srcset="https://www.steelersdepot.com/wp-content/uploads/2018/04/StockColbert2-300x180.jpg 300w, https://www.steelersdepot.com/wp-content/uploads/2018/04/StockColbert2-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px" />						<img width="80" height="80" src="https://www.steelersdepot.com/wp-content/uploads/2018/04/StockColbert2-80x80.jpg" class="mob-img wp-post-image" alt="" srcset="https://www.steelersdepot.com/wp-content/uploads/2018/04/StockColbert2-80x80.jpg 80w, https://www.steelersdepot.com/wp-content/uploads/2018/04/StockColbert2-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />					</a>
									</div><!--related-img-->
				<div class="mvp-related-text left relative">
					<a href="https://www.steelersdepot.com/2018/08/kevin-colberts-tenure-as-steelers-gm-unrivaled/">Kevin Colbert&#8217;s Tenure As Steelers GM Unrivaled</a>
				</div><!--related-text-->
            			</li>
            		            			<li>
                		<div class="mvp-related-img left relative">
										<a href="https://www.steelersdepot.com/2018/07/fear-of-steelers-eventually-losing-dobbs-to-waivers-this-year-probably-overblown/" rel="bookmark" title="Fear Of Steelers Eventually Losing Dobbs To Waivers This Year Probably Overblown">
						<img width="300" height="180" src="https://www.steelersdepot.com/wp-content/uploads/2018/06/StockDobbs4-300x180.jpg" class="reg-img wp-post-image" alt="" srcset="https://www.steelersdepot.com/wp-content/uploads/2018/06/StockDobbs4-300x180.jpg 300w, https://www.steelersdepot.com/wp-content/uploads/2018/06/StockDobbs4-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px" />						<img width="80" height="80" src="https://www.steelersdepot.com/wp-content/uploads/2018/06/StockDobbs4-80x80.jpg" class="mob-img wp-post-image" alt="" srcset="https://www.steelersdepot.com/wp-content/uploads/2018/06/StockDobbs4-80x80.jpg 80w, https://www.steelersdepot.com/wp-content/uploads/2018/06/StockDobbs4-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />					</a>
									</div><!--related-img-->
				<div class="mvp-related-text left relative">
					<a href="https://www.steelersdepot.com/2018/07/fear-of-steelers-eventually-losing-dobbs-to-waivers-this-year-probably-overblown/">Fear Of Steelers Eventually Losing Dobbs To Waivers This Year Probably Overblown</a>
				</div><!--related-text-->
            			</li>
            		</ul></div>																					<div id="disqus_thread"></div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
    /**
     *  RECOMMENDED CONFIGURATION VARIABLES: EDIT AND UNCOMMENT 
     *  THE SECTION BELOW TO INSERT DYNAMIC VALUES FROM YOUR 
     *  PLATFORM OR CMS.
     *  
     *  LEARN WHY DEFINING THESE VARIABLES IS IMPORTANT: 
     *  https://disqus.com/admin/universalcode/#configuration-variables
     */
    /*
    var disqus_config = function () {
        // Replace PAGE_URL with your page's canonical URL variable
        this.page.url = PAGE_URL;  
        
        // Replace PAGE_IDENTIFIER with your page's unique identifier variable
        this.page.identifier = PAGE_IDENTIFIER; 
    };
    */
    
    (function() {
        var d = document, s = d.createElement('script');
        
        // s.src = 'https://steelersdepot.disqus.com/embed.js';
        s.src = '/wp-content/themes/flex-mag-child/assets/js/disqus-post.js';
        
        s.setAttribute('data-timestamp', +new Date());
        (d.head || d.body).appendChild(s);
    })();
</script>
<noscript>
    Please enable JavaScript to view the 
    <a href="https://disqus.com/?ref_noscript" rel="nofollow">
        comments powered by Disqus.
    </a>
</noscript>									</div><!--content-main-->
			</div><!--post-cont-in-->
					</div><!--post-cont-out-->
	</div><!--content-area-->
</article>
				</div><!--post-left-col-->
			</div><!--post-wrap-in1-->
			
							<div id="post-right-col" class="relative">
																		<div id="sidebar-wrap" class="left relative theiaStickySidebar">
	<div id="custom_html-19" class="widget_text side-widget widget_custom_html"><div class="textwidget custom-html-widget"><!-- top right -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-7138622909378284"
     data-ad-slot="2275390383"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div><div id="custom_html-20" class="widget_text side-widget widget_custom_html"><div class="textwidget custom-html-widget"><center><a target="_blank" href="https://shareasale.com/r.cfm?b=537844&amp;u=275818&amp;m=7124&amp;urllink=&amp;afftrack="><img src="https://dou14x5jx22mo.cloudfront.net/image/7124/NFL_Pittsburg_Steelers_300x250.jpg" border="0" alt="Shop the newest Pittsburgh Steelers fan gear at Fanatics!" /></a></center></div></div></div><!--sidebar-wrap-->															</div><!--post-right-col-->
					</div><!--post-wrap-out1-->
</div><!--post-main-wrap-->
											</div><!--body-main-cont-->
				</div><!--body-main-in-->
			</div><!--body-main-out-->
		</div><!--body-main-wrap-->

		<footer id="foot-wrap" class="left relative">
			<div id="foot-top-wrap" class="left relative">
				<div class="body-main-out relative">
					<div class="body-main-in">
						<div id="foot-widget-wrap" class="left relative">
															<div class="foot-widget left relative">
																			<div class="foot-logo left realtive">
											<img src="https://www.steelersdepot.com/wp-content/themes/flex-mag/images/logos/logo-foot.png" alt="Steelers Depot" data-rjs="2" />
										</div><!--foot-logo-->
																		<div class="foot-info-text left relative">
																			</div><!--footer-info-text-->
									<div class="foot-soc left relative">
										<ul class="foot-soc-list relative">
																																		<li class="foot-soc-twit">
													<a href="https://twitter.com/Steelersdepot" target="_blank"><i class="fa fa-twitter-square fa-2"></i></a>
												</li>
																																																																																																				<li class="foot-soc-rss">
													<a href="https://www.steelersdepot.com/feed/rss/" target="_blank"><i class="fa fa-rss-square fa-2"></i></a>
												</li>
																					</ul>
									</div><!--foot-soc-->
								</div><!--foot-widget-->
																				</div><!--foot-widget-wrap-->
					</div><!--body-main-in-->
				</div><!--body-main-out-->
			</div><!--foot-top-->
			<div id="foot-bot-wrap" class="left relative">
				<div class="body-main-out relative">
					<div class="body-main-in">
						<div id="foot-bot" class="left relative">
							<div class="foot-menu relative">
								<div class="menu-header-container"><ul id="menu-header-2" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37673"><a href="/">Home</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154806"><a href="/category/news/">Steelers News</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38055"><a href="/steelers-news/">Steelers Wire</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-163626"><a href="/category/podcast/">Podcast</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-240752"><a>NFL Draft Info</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-456507"><a href="/2017-nfl-scouting-combine-results-tracker/">2017 NFL Combine Results</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-240753"><a href="/2016/03/steelers-2016-pre-draft-visit-tracker/">2016 Pre-Draft Visits</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-225936"><a title="2016 NFL Combine Results" href="/2016-nfl-scouting-combine-results/">2016 NFL Combine Results</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38058"><a href="http://www.dpbolvw.net/click-2334271-10539967?url=http%3A%2F%2Fwww.zinio.com%2Fwww%2Fbrowse%2Fproduct.jsp%3FproductId%3D500215550%26affId%3Dcj%26rf%3Dcjaffcatalog&#038;cjsku=500073101">Steelers Digest</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-158274"><a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&#038;hosted_button_id=XZ97MFHPQZYX4">Donate</a></li>
<li class="logged-out menu-item menu-item-type-post_type menu-item-object-page menu-item-493253"><a href="https://www.steelersdepot.com/go-ad-free/">Go Ad-Free</a></li>
<li class="logged-out menu-item menu-item-type-custom menu-item-object-custom menu-item-493254"><a href="/wp-login.php">Login</a></li>
<li class="logged-in menu-item menu-item-type-custom menu-item-object-custom menu-item-493255"><a href="/wp-login.php?action=logout">Logout</a></li>
</ul></div>							</div><!--foot-menu-->
							<div class="foot-copy relative">
								<p>&copy; 2018 Steelers Depot</p>
							</div><!--foot-copy-->
						</div><!--foot-bot-->
					</div><!--body-main-in-->
				</div><!--body-main-out-->
			</div><!--foot-bot-->
		</footer>
	</div><!--site-wrap-->
</div><!--site-->
<div class="fly-to-top back-to-top">
	<i class="fa fa-angle-up fa-3"></i>
	<span class="to-top-text">To Top</span>
</div><!--fly-to-top-->
<div class="fly-fade">
</div><!--fly-fade-->
			<script data-cfasync="false" type="text/javascript">
			function arm_open_modal_box_in_nav_menu(menu_id, form_id) {
                           
				jQuery(".arm_nav_menu_link_" + form_id).find("." + form_id).trigger("click");
				return false;
			}
			</script>
					<div data-theiaStickySidebar-sidebarSelector='"#tab-col2"'
		     data-theiaStickySidebar-options='{"containerSelector":"#home-main-wrap","additionalMarginTop":0,"additionalMarginBottom":0,"updateSidebarHeight":false,"minWidth":0,"sidebarBehavior":"modern","disableOnResponsiveLayouts":true}'></div>
				<div data-theiaStickySidebar-sidebarSelector='"#tab-col3"'
		     data-theiaStickySidebar-options='{"containerSelector":"#home-main-wrap","additionalMarginTop":90,"additionalMarginBottom":0,"updateSidebarHeight":false,"minWidth":0,"sidebarBehavior":"modern","disableOnResponsiveLayouts":true}'></div>
				<div data-theiaStickySidebar-sidebarSelector='"#post-right-col"'
		     data-theiaStickySidebar-options='{"containerSelector":"#home-main-wrap","additionalMarginTop":90,"additionalMarginBottom":0,"updateSidebarHeight":false,"minWidth":0,"sidebarBehavior":"modern","disableOnResponsiveLayouts":true}'></div>
		
<script type="text/javascript">
jQuery(document).ready(function($) {

	// Back to Top Button
    	var duration = 500;
    	$('.back-to-top').click(function(event) {
          event.preventDefault();
          $('html, body').animate({scrollTop: 0}, duration);
          return false;
	});

	// Main Menu Dropdown Toggle
	$('.menu-item-has-children a').click(function(event){
	  event.stopPropagation();
	  location.href = this.href;
  	});

	$('.menu-item-has-children').click(function(){
    	  $(this).addClass('toggled');
    	  if($('.menu-item-has-children').hasClass('toggled'))
    	  {
    	  $(this).children('ul').toggle();
	  $('.fly-nav-menu').getNiceScroll().resize();
	  }
	  $(this).toggleClass('tog-minus');
    	  return false;
  	});

	// Main Menu Scroll
	$(window).load(function(){
	  $('.fly-nav-menu').niceScroll({cursorcolor:"#888",cursorwidth: 7,cursorborder: 0,zindex:999999});
	});

	  	$(".comment-click-495907").on("click", function(){
  	  $(".com-click-id-495907").show();
	  $(".disqus-thread-495907").show();
  	  $(".com-but-495907").hide();
  	});
	

$(window).load(function() {
  // The slider being synced must be initialized first
  $('.post-gallery-bot').flexslider({
    animation: "slide",
    controlNav: false,
    animationLoop: true,
    slideshow: false,
    itemWidth: 80,
    itemMargin: 10,
    asNavFor: '.post-gallery-top'
  });

  $('.post-gallery-top').flexslider({
    animation: "fade",
    controlNav: false,
    animationLoop: true,
    slideshow: false,
    	  prevText: "&lt;",
          nextText: "&gt;",
    sync: ".post-gallery-bot"
  });
});

});

</script>

<script type='text/javascript' src='https://www.steelersdepot.com/wp-includes/js/comment-reply.min.js?ver=4.9.7'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"steelersdepot"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.steelersdepot.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.16'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.16"},"disqusIdentifier":"495907 http:\/\/www.steelersdepot.com\/?p=495907","disqusShortname":"steelersdepot","disqusTitle":"Colbert On Backup QB Competition: \u2018Obviously, Landry\u2019s Our Number Two\u2019","disqusUrl":"https:\/\/www.steelersdepot.com\/2018\/08\/colbert-on-backup-qb-competition-obviously-landrys-our-number-two\/","postId":"495907"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.steelersdepot.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.16'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201831'></script>
<script type='text/javascript' src='https://www.steelersdepot.com/wp-content/plugins/theia-sticky-sidebar/js/theia-sticky-sidebar.js?ver=1.6.3'></script>
<script type='text/javascript' src='https://www.steelersdepot.com/wp-content/plugins/theia-sticky-sidebar/js/main.js?ver=1.6.3'></script>
<script type='text/javascript' src='https://www.steelersdepot.com/wp-content/themes/flex-mag/js/scripts.js?ver=4.9.7'></script>
<script type='text/javascript' src='https://www.steelersdepot.com/wp-content/themes/flex-mag/js/autoloadpost.js?ver=4.9.7'></script>
<script type='text/javascript' src='https://www.steelersdepot.com/wp-content/themes/flex-mag/js/retina.js?ver=4.9.7'></script>
<script type='text/javascript' src='https://www.steelersdepot.com/wp-content/themes/flex-mag-child/assets/js/_main.min.js?ver=4.9.7'></script>
<script type='text/javascript' src='https://www.steelersdepot.com/wp-includes/js/wp-embed.min.js?ver=4.9.7'></script>
<script type="text/javascript" id="slb_context">/* <![CDATA[ */if ( !!window.jQuery ) {(function($){$(document).ready(function(){if ( !!window.SLB ) { {$.extend(SLB, {"context":["public","user_guest"]});} }})})(jQuery);}/* ]]> */</script>
<script type='text/javascript' src='https://stats.wp.com/e-201831.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.3.3',blog:'12286105',post:'495907',tz:'-4',srv:'www.steelersdepot.com'} ]);
	_stq.push([ 'clickTrackerInit', '12286105', '495907' ]);
</script>

	<style>
.modal {
	margin-top:200px;
}
.modal-backdrop {
	background: rgba(0,0,0,0.6);
}
.modal-body a {
	text-decoration: underline;
}
</style>
<div class="modal" id="ad-free-modal" tabindex="-1" role="dialog">
	<div class="modal-dialog" role="document">
		<div class="modal-content">
			<div class="modal-header">
				<h5 class="modal-title">Adblocker is on</h5>
				<button type="button" class="close" data-dismiss="modal" aria-label="Close">
					<span aria-hidden="true">&times;</span>
				</button>
			</div>
			<div class="modal-body">
				<p>We noticed your adblocker is on.  We use ads to fund this site and continue to bring you premium Steelers content.</p>
				<p>If you like what you see on this site, we now have an <a href="/go-ad-free">ad-free option</a> available for a donation of $25 per year, and you can enjoy the site entirely ad-free!</p>
				<p>Additionally, if you'd like to donate above and beyond the ad-free option, you can <a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=XZ97MFHPQZYX4" target="_blank">donate via PayPal</a> as well.</p>
				<p>Finally, if you wish to not see this dialog box, please turn off your adblocker, and enjoy content normally</p>
				<p>Thank you for visiting Steelers Depot!</p>
			</div>
			<div class="modal-footer">
				<a href="/go-ad-free" class="btn btn-warning" style="color:white">Go Ad-Free</a>
				<button type="button" class="btn btn-dark" data-dismiss="modal">Close</button>
			</div>
		</div>
	</div>
</div>	<script type="text/javascript">
	jQuery(function($) {
		window._taboola = window._taboola || [];
		_taboola.push({flush: true});

		var adBlockEnabled = false;
		var testAd = document.createElement('div');
		testAd.innerHTML = '&nbsp;';
		testAd.className = 'adsbox';
		document.body.appendChild(testAd);
		window.setTimeout(function() {
			if(testAd.offsetHeight === 0) {
				adBlockEnabled = true;
				$('#ad-free-modal').modal('show');
			}
			testAd.remove();
			console.log('AdBlock Enabled? ', adBlockEnabled)
		}, 5000);
	});
	</script>
</body>
</html>
<!--
Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Page Caching using disk: enhanced 
Content Delivery Network Full Site Delivery via cloudflare
Fragment Caching 47/48 fragments using disk

Served from: steelersdepot.com @ 2018-08-02 12:24:39 by W3 Total Cache
-->