<!DOCTYPE html><html class="no-js" lang="en-US" prefix="og: http://ogp.me/ns#"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1.0"><link rel="profile" href="http://gmpg.org/xfn/11" /><link rel="pingback" href="http://www.steelersdepot.com/xmlrpc.php" /><title>Steelers Backups Do Enough To Hold Off Browns In 28-24 Win - Steelers Depot</title><meta name="description" content="The Pittsburgh Steelers may not have had their ‘Killer Bs’ on the field today but their backups still did enough to cruise to a 28-24 victory over the Clev"/><link rel="canonical" href="http://www.steelersdepot.com/2017/12/steelers-backups-enough-hold-off-browns-28-24-win/" /><link rel="publisher" href="https://plus.google.com/+DaveBryan"/><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Steelers Backups Do Enough To Hold Off Browns In 28-24 Win - Steelers Depot" /><meta property="og:description" content="The Pittsburgh Steelers may not have had their ‘Killer Bs’ on the field today but their backups still did enough to cruise to a 28-24 victory over the Clev" /><meta property="og:url" content="http://www.steelersdepot.com/2017/12/steelers-backups-enough-hold-off-browns-28-24-win/" /><meta property="og:site_name" content="Steelers Depot" /><meta property="article:tag" content="Cleveland Browns" /><meta property="article:tag" content="Pittsburgh Steelers" /><meta property="article:section" content="Article" /><meta property="article:published_time" content="2017-12-31T16:13:05+00:00" /><meta property="article:modified_time" content="2017-12-31T16:14:08+00:00" /><meta property="og:updated_time" content="2017-12-31T16:14:08+00:00" /><meta property="og:image" content="http://www.steelersdepot.com/wp-content/uploads/2017/12/StockWatt8.jpg" /><meta property="og:image:width" content="836" /><meta property="og:image:height" content="462" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="The Pittsburgh Steelers may not have had their ‘Killer Bs’ on the field today but their backups still did enough to cruise to a 28-24 victory over the Clev" /><meta name="twitter:title" content="Steelers Backups Do Enough To Hold Off Browns In 28-24 Win - Steelers Depot" /><meta name="twitter:site" content="@Steelersdepot" /><meta name="twitter:image" content="http://www.steelersdepot.com/wp-content/uploads/2017/12/StockWatt8.jpg" /><meta name="twitter:creator" content="@Steelersdepot" /> <script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"http:\/\/www.steelersdepot.com\/","name":"Steeles Depot","potentialAction":{"@type":"SearchAction","target":"http:\/\/www.steelersdepot.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script> <script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","url":"http:\/\/www.steelersdepot.com\/2017\/12\/steelers-backups-enough-hold-off-browns-28-24-win\/","sameAs":["https:\/\/plus.google.com\/+DaveBryan","https:\/\/twitter.com\/Steelersdepot"],"@id":"#organization","name":"Steelers Depot","logo":"http:\/\/www.steelersdepot.com\/wp-content\/uploads\/2015\/07\/SteelersDepot.jpg"}</script> <link rel='dns-prefetch' href='//www.steelersdepot.com' /><link rel='dns-prefetch' href='//s0.wp.com' /><link rel='dns-prefetch' href='//vjs.zencdn.net' /><link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Steelers Depot &raquo; Feed" href="http://www.steelersdepot.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Steelers Depot &raquo; Comments Feed" href="http://www.steelersdepot.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Steelers Depot &raquo; Steelers Backups Do Enough To Hold Off Browns In 28-24 Win Comments Feed" href="http://www.steelersdepot.com/2017/12/steelers-backups-enough-hold-off-browns-28-24-win/feed/" /> <script type="text/javascript">/*<![CDATA[*/window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.steelersdepot.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.1"}};!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56794,8205,9794,65039],[55358,56794,8203,9794,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);/*]]>*/</script> <style type="text/css">img.wp-smiley,img.emoji{display:inline !important;border:none !important;box-shadow:none !important;height:1em !important;width:1em !important;margin:0
.07em !important;vertical-align:-0.1em !important;background:none !important;padding:0
!important}</style><link rel='stylesheet' id='wpts_ui_css-css'  href='http://www.steelersdepot.com/wp-content/plugins/wordpress-post-tabs/css/styles/default/style.css?ver=1.6.2' type='text/css' media='all' /><link rel='stylesheet' id='videojs-css'  href='//vjs.zencdn.net/5.9.2/video-js.css?ver=4.9.1' type='text/css' media='all' /><link rel='stylesheet' id='videojs-style-css'  href='http://www.steelersdepot.com/wp-content/plugins/videojs-hls-player/videojs-hls-player.css?ver=4.9.1' type='text/css' media='all' /><link rel='stylesheet' id='videojs-airplay-css'  href='http://www.steelersdepot.com/wp-content/plugins/videojs-hls-player/videojs-airplay/videojs.airplay.css?ver=4.9.1' type='text/css' media='all' /><link rel='stylesheet' id='wp-pagenavi-css'  href='http://www.steelersdepot.com/wp-content/plugins/wp-pagenavi/pagenavi-css.css?ver=2.70' type='text/css' media='all' /><link rel='stylesheet' id='parent-style-css'  href='http://www.steelersdepot.com/wp-content/themes/mh_newsdesk/style.css?ver=4.9.1' type='text/css' media='all' /><link rel='stylesheet' id='mh-style-css'  href='http://www.steelersdepot.com/wp-content/themes/mh_newsdesk-child/style.css?ver=1.1.0' type='text/css' media='all' /><link rel='stylesheet' id='mh-font-awesome-css'  href='//maxcdn.bootstrapcdn.com/font-awesome/4.3.0/css/font-awesome.min.css' type='text/css' media='all' /><link rel='stylesheet' id='mh-google-fonts-css'  href='//fonts.googleapis.com/css?family=PT+Serif:300,400,400italic,600,700|Oswald:300,400,400italic,600,700' type='text/css' media='all' /><link rel='stylesheet' id='simple-social-icons-font-css'  href='http://www.steelersdepot.com/wp-content/plugins/simple-social-icons/css/style.css?ver=2.0.1' type='text/css' media='all' /><link rel='stylesheet' id='slb_core-css'  href='http://www.steelersdepot.com/wp-content/plugins/simple-lightbox/client/css/app.css?ver=2.6.0' type='text/css' media='all' /><link rel='stylesheet' id='social-logos-css'  href='http://www.steelersdepot.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' /><link rel='stylesheet' id='jetpack_css-css'  href='http://www.steelersdepot.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.6.1' type='text/css' media='all' /><link rel='https://api.w.org/' href='http://www.steelersdepot.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.steelersdepot.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.steelersdepot.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 4.9.1" /><link rel='shortlink' href='https://wp.me/pPyaZ-212M' /><link rel="alternate" type="application/json+oembed" href="http://www.steelersdepot.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.steelersdepot.com%2F2017%2F12%2Fsteelers-backups-enough-hold-off-browns-28-24-win%2F" /><link rel="alternate" type="text/xml+oembed" href="http://www.steelersdepot.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.steelersdepot.com%2F2017%2F12%2Fsteelers-backups-enough-hold-off-browns-28-24-win%2F&#038;format=xml" /> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>(adsbygoogle=window.adsbygoogle||[]).push({google_ad_client:"ca-pub-7138622909378284",enable_page_level_ads:true});</script> <script data-cfasync="false" type="text/javascript">(function(w,d){var s=d.createElement('script');s.src='//delivery.adrecover.com/15913/adRecover.js';s.type='text/javascript';s.async=true;(d.getElementsByTagName('head')[0]||d.getElementsByTagName('body')[0]).appendChild(s);})(window,document);</script><script type='text/javascript'>window._taboola=window._taboola||[];_taboola.push({article:'auto'});_taboola.push({listenTo:'render',handler:function(p){TRC.modDebug.logMessageToServer(2,"wordpress-integ");}});_taboola.push({additional_data:{sdkd:{"os":"Wordpress","osv":"4.9.1","sdkt":"Taboola Wordpress Plugin","sdkv":"1.0.9"}}});!function(e,f,u){e.async=1;e.src=u;f.parentNode.insertBefore(e,f);}(document.createElement('script'),document.getElementsByTagName('script')[0],'//cdn.taboola.com/libtrc/steelersdepot/loader.js');</script> <script type="text/javascript">var _tmip=_tmip||[];_tmip.push({"tags":{"author":"Daniel Valente"}});</script> <style type='text/css'>img#wpstats{display:none}</style><style type="text/css">.social-nav a:hover, .logo-title, .entry-content a, a:hover, .entry-meta .entry-meta-author, .entry-meta a, .comment-info, blockquote, .pagination a:hover
.pagelink{color:#f1c000}.main-nav li:hover, .slicknav_menu, .ticker-title, .breadcrumb a, .breadcrumb .bc-text, .button span, .widget-title span, input[type=submit], table th, .comment-section-title .comment-count, #cancel-comment-reply-link:hover, .pagination .current, .pagination
.pagelink{background:#f1c000}blockquote,input[type=text]:hover,input[type=email]:hover,input[type=tel]:hover,input[type=url]:hover,textarea:hover{border-color:#f1c000}.widget-title, .pagination a.page-numbers:hover, .dots:hover, .pagination a:hover .pagelink,.comment-section-title{background:#000}.commentlist .depth-1, .commentlist .bypostauthor
.avatar{border-color:#000}.main-nav, .main-nav ul li:hover>ul,.mh-footer{background:#000}.header-top, .header-nav ul li:hover>ul,.footer-ad-wrap,.footer-1,.footer-2,.footer-3,.footer-bottom{background:#000}.social-nav
a{color:#000}.footer-widgets .widget-title{background:#000}</style><link rel="shortcut icon" href="http://www.steelersdepot.com/wp-content/uploads/2015/07/favicon.ico"> <!--[if lt IE 9]> <script src="http://www.steelersdepot.com/wp-content/themes/mh_newsdesk/js/css3-mediaqueries.js"></script> <![endif]--><style type="text/css" media="screen">.simple-social-icons ul li a, .simple-social-icons ul li a:hover, .simple-social-icons ul li a:focus{background-color:#999 !important;border-radius:3px;color:#fff !important;border:0px
#fff solid !important;font-size:18px;padding:9px}.simple-social-icons ul li a:hover, .simple-social-icons ul li a:focus{background-color:#666 !important;border-color:#fff !important;color:#fff !important}.simple-social-icons ul li a:focus{outline:1px
dotted #666 !important}</style></head><body class="post-template-default single single-post postid-480672 single-format-standard mh-right-sb"><div id="mh-wrapper"> <header class="mh-header"><div class="header-wrap clearfix"><div class="mh-col mh-1-3 header-logo"> <a href="http://www.steelersdepot.com/" title="Steelers Depot" rel="home"><div class="logo-wrap" role="banner"> <img src="http://www.steelersdepot.com/wp-content/uploads/2015/07/cropped-cropped-depot-logo1.png" height="100" width="384" alt="Steelers Depot" /></div> </a></div> <aside class="widget_text mh-col mh-2-3"><div class="widget_text header-ad"><div class="textwidget custom-html-widget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-7138622909378284" data-ad-slot="3074123274" data-ad-format="auto"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div></div></aside></div><div class="header-menu clearfix"> <nav class="main-nav clearfix"><div class="menu-header-container"><ul id="menu-header" class="menu"><li id="menu-item-37673" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-37673"><a href="http://www.steelersdepot.com">Home</a></li><li id="menu-item-154806" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154806"><a href="http://www.steelersdepot.com/category/news/">Steelers News</a></li><li id="menu-item-38055" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38055"><a href="http://www.steelersdepot.com/steelers-news/">Steelers Wire</a></li><li id="menu-item-163626" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-163626"><a href="http://www.steelersdepot.com/category/podcast/">Podcast</a></li><li id="menu-item-38056" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38056"><a href="http://www.shareasale.com/r.cfm?b=375840&#038;u=275818&#038;m=7124&#038;urllink=&#038;afftrack=">Steelers Merchandise</a></li><li id="menu-item-38057" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38057"><a href="http://www.jdoqocy.com/click-2334271-10858765?sid=&#038;url=http://www.ticketliquidator.com/tix/Pittsburgh-Steelers-tickets.aspx?utm_source=CJID&#038;utm_medium=2334271">Tickets</a></li><li id="menu-item-240752" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-240752"><a>NFL Draft Info</a><ul class="sub-menu"><li id="menu-item-456507" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-456507"><a href="http://www.steelersdepot.com/2017-nfl-scouting-combine-results-tracker/">2017 NFL Combine Results</a></li><li id="menu-item-240753" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-240753"><a href="http://www.steelersdepot.com/2016/03/steelers-2016-pre-draft-visit-tracker/">2016 Pre-Draft Visits</a></li><li id="menu-item-225936" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-225936"><a title="2016 NFL Combine Results" href="http://www.steelersdepot.com/2016-nfl-scouting-combine-results/">2016 NFL Combine Results</a></li></ul></li><li id="menu-item-38058" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38058"><a href="http://www.dpbolvw.net/click-2334271-10539967?url=http%3A%2F%2Fwww.zinio.com%2Fwww%2Fbrowse%2Fproduct.jsp%3FproductId%3D500215550%26affId%3Dcj%26rf%3Dcjaffcatalog&#038;cjsku=500073101">Steelers Digest</a></li><li id="menu-item-158274" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-158274"><a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&#038;hosted_button_id=XZ97MFHPQZYX4">Donate</a></li></ul></div>		</nav><div class="header-sub clearfix"> <section id="ticker" class="news-ticker mh-col mh-2-3 clearfix"> <span class="ticker-title">Hot Topics</span><ul class="ticker-content"></ul> </section>						<aside class="mh-col mh-1-3 header-search"><form role="search" method="get" class="search-form" action="http://www.steelersdepot.com/"> <label> <span class="screen-reader-text">Search for:</span> <input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" /> </label> <input type="submit" class="search-submit" value="Search" /></form>			</aside></div></div> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');ga('create','UA-11437002-3','auto');ga('send','pageview');</script> </header><div class="mh-section mh-group"><div id="main-content" class="mh-content"> <nav class="breadcrumb"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="http://www.steelersdepot.com" itemprop="url" class="bc-home"><span itemprop="title">Home</span></a></span> <span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="http://www.steelersdepot.com/category/article/" itemprop="url"><span itemprop="title">Article</span></a></span></nav> <article id="post-480672" class="post-480672 post type-post status-publish format-standard has-post-thumbnail hentry category-article tag-cleveland-browns tag-pittsburgh-steelers"> <header class="entry-header clearfix"><h1 class="entry-title">Steelers Backups Do Enough To Hold Off Browns In 28-24 Win</h1> </header><div class="entry-thumbnail"> <img width="777" height="437" src="http://www.steelersdepot.com/wp-content/uploads/2017/12/StockWatt8-777x437.jpg" class="attachment-content-single size-content-single wp-post-image" alt="" srcset="http://www.steelersdepot.com/wp-content/uploads/2017/12/StockWatt8-777x437.jpg 777w, http://www.steelersdepot.com/wp-content/uploads/2017/12/StockWatt8-180x101.jpg 180w, http://www.steelersdepot.com/wp-content/uploads/2017/12/StockWatt8-260x146.jpg 260w, http://www.steelersdepot.com/wp-content/uploads/2017/12/StockWatt8-373x210.jpg 373w, http://www.steelersdepot.com/wp-content/uploads/2017/12/StockWatt8-120x67.jpg 120w" sizes="(max-width: 777px) 100vw, 777px" /></div><div class="advertisement"><div class="widget_text sb-widget post-ad"><div class="textwidget custom-html-widget"></div></div></div><p class="entry-meta"> <span class="entry-meta-author vcard author">By <a class="fn" href="http://www.steelersdepot.com/author/daniel-waterman/">Daniel Valente</a></span> <span class="entry-meta-date updated">December 31, 2017 at 04:13 pm</span></p><div class="entry-content clearfix"><p>The <strong>Pittsburgh Steelers</strong> may not have had their ‘Killer Bs’ on the field today but their backups still did enough to cruise to a 28-24 victory over the <strong>Cleveland Browns</strong>. While the Steelers may have lacked their usual stars, it was the combination of backup quarterback <strong>Landry Jones</strong> and rookie receiver <strong>JuJu Smith-Schuster</strong> who pushed the Steelers to victory, gifting the Browns an imperfect 0-16 season.</p><p>Smith-Schuster finished with 143 receiving yards, breaking the Steelers rookie record for most receiving yards in a season. Smith-Schuster also added two touchdowns on the day, the first wide open reception in the end zone and the second coming from a rare kickoff return. The rookie wide receiver took a third quarter kick off 96 yards to give the Steelers a 28-21 lead.</p><p><strong>DeShone Kizer</strong> was able to make this meaningless game interesting as the Browns battled back from 14-0 and 21-7 deficits to tie the game at 21 all. Though Kizer struggled with accuracy all afternoon, it was the few passes he connected on that hurt the Steelers the most. A 54-yard pass to <strong>Josh Gordon</strong> and 56-yard touchdown to <strong>Rashard Higgins </strong>powered the Browns back into the ballgame.</p><p>Kizer would be gifted one last opportunity at the end of the game, driving into Steelers territory down four. Unfortunately facing a fourth and two, Kizer’s pass was dropped by <strong>Corey Coleman</strong> in typical Browns fashion.</p><p>With the Steelers resting their starters, some forgotten faces had their chance to shine. <strong>Darrius Heyward-Bey </strong>opened the scoring, taking an end around handoff 29 yards for a Steelers touchdown. Heyward-Bey has fallen down the receiver depth chart this season but his contributions have remained consistent in spot duty.</p><div class="gNeeKsUD" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"></div><p>Another new face in running back <strong>Stevan Ridley</strong> was able to punch in another touchdown before halftime. With the absence of <strong>Le’Veon Bell</strong>, Ridley filled in nicely, totalling 80 rushing yards and adding his first rushing touchdown since 2014.</p><p>The Steelers defense also broke a Pittsburgh all time record as their defense recorded six sacks on Kizer. The six sacks put the Steelers at 56 on the season, setting a new high for a Steelers season. In the absence of <strong>Cameron Heyward </strong>, <strong>Tyson Alualu </strong>finished with two sacks, notching the record breaking sack as well.</p><p><strong>Mike Tomlin</strong> and his squad will now enjoy a well needed bye week before resuming action in two weeks in the AFC Divisional Round. The Steelers will look to use the extra week off to get Pro Bowl wide receiver <strong>Antonio Brown</strong> back healthy from a calf injury.</p><div id='taboola-below-article'></div><script type='text/javascript'>window._taboola=window._taboola||[];_taboola.push({mode:'thumbnails-a',container:'taboola-below-article',placement:'below-article',target_type:'mix'});</script><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-480672" class="share-twitter sd-button share-icon" href="http://www.steelersdepot.com/2017/12/steelers-backups-enough-hold-off-browns-28-24-win/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-480672" class="share-facebook sd-button share-icon" href="http://www.steelersdepot.com/2017/12/steelers-backups-enough-hold-off-browns-28-24-win/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-480672" class="share-google-plus-1 sd-button share-icon" href="http://www.steelersdepot.com/2017/12/steelers-backups-enough-hold-off-browns-28-24-win/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span>Google</span></a></li><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon" href="http://www.steelersdepot.com/2017/12/steelers-backups-enough-hold-off-browns-28-24-win/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-pinterest"><a rel="nofollow" data-shared="sharing-pinterest-480672" class="share-pinterest sd-button share-icon" href="http://www.steelersdepot.com/2017/12/steelers-backups-enough-hold-off-browns-28-24-win/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span>Pinterest</span></a></li><li class="share-end"></li></ul></div></div></div><div class="entry-tags clearfix"><span>TOPICS:</span><a href="http://www.steelersdepot.com/tag/cleveland-browns/" rel="tag">Cleveland Browns</a><a href="http://www.steelersdepot.com/tag/pittsburgh-steelers/" rel="tag">Pittsburgh Steelers</a></div></div> </article><div class="mh-share-buttons mh-group"><div class="mh-col mh-1-4 mh-facebook"> <a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=http://www.steelersdepot.com/2017/12/steelers-backups-enough-hold-off-browns-28-24-win/&t=Steelers Backups Do Enough To Hold Off Browns In 28-24 Win', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><span class="mh-share-button"><i class="fa fa-facebook fa-2x"></i>SHARE</span></a></div><div class="mh-col mh-1-4 mh-twitter"> <a href="#" onclick="window.open('http://twitter.com/share?text=Steelers Backups Do Enough To Hold Off Browns In 28-24 Win -&url=http://www.steelersdepot.com/2017/12/steelers-backups-enough-hold-off-browns-28-24-win/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><span class="mh-share-button"><i class="fa fa-twitter fa-2x"></i>TWEET</span></a></div><div class="mh-col mh-1-4 mh-pinterest"> <a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=http://www.steelersdepot.com/2017/12/steelers-backups-enough-hold-off-browns-28-24-win/&media=http://www.steelersdepot.com/wp-content/uploads/2017/12/StockWatt8.jpg&description=Steelers Backups Do Enough To Hold Off Browns In 28-24 Win', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><span class="mh-share-button"><i class="fa fa-pinterest fa-2x"></i>PIN</span></a></div><div class="mh-col mh-1-4 mh-googleplus"> <a href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=http://www.steelersdepot.com/2017/12/steelers-backups-enough-hold-off-browns-28-24-win/', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank"><span class="mh-share-button"><i class="fa fa-google-plus fa-2x"></i>SHARE</span></a></div></div>			<nav class="post-nav-wrap" role="navigation"><ul class="post-nav clearfix"><li class="post-nav-prev"> <a href="http://www.steelersdepot.com/2017/12/2017-week-17-steelers-vs-browns-live-update-discussion-thread-second-half/" rel="prev"><i class="fa fa-chevron-left"></i>Previous post</a></li><li class="post-nav-next"> <a href="http://www.steelersdepot.com/2017/12/steelers-vs-browns-winners-losers/" rel="next">Next post<i class="fa fa-chevron-right"></i></a></li></ul> </nav><h4 class="widget-title"><span>About the Author</span></h4> <section class="author-box clearfix"><div class="author-box-avatar"><a href="http://www.steelersdepot.com/author/daniel-waterman/"><img alt='' src='http://0.gravatar.com/avatar/672f722b7b803a56da972a7f16fecb90?s=100&#038;d=mm&#038;r=g' srcset='http://0.gravatar.com/avatar/672f722b7b803a56da972a7f16fecb90?s=200&#038;d=mm&#038;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' /></a></div><h5 class="author-box-name"><a href="http://www.steelersdepot.com/author/daniel-waterman/">Daniel Valente</a></h5><div class="author-box-desc"><p>Steelers fan from birth, spending majority of my free time looking up statistics. Had the honor of meeting Mike Vanderjagt shortly after his infamous missed field goal in the 2005 Divisional Round. Currently pursuing a Journalism degree. Follow me on Twitter @StatsGuyDaniel</p></div> </section><div id="disqus_thread"><div id="dsq-content"><ul id="dsq-comments"><li class="comment even thread-even depth-1" id="dsq-comment-828065"><div id="dsq-comment-header-828065" class="dsq-comment-header"> <cite id="dsq-cite-828065"> <span id="dsq-author-user-828065">RJMcReady</span> </cite></div><div id="dsq-comment-body-828065" class="dsq-comment-body"><div id="dsq-comment-message-828065" class="dsq-comment-message"><p>Very happy Browns are 0-16.</p><p>On to the playoffs for Pittsburgh.</p></div></div></li><li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-828072"><div id="dsq-comment-header-828072" class="dsq-comment-header"> <cite id="dsq-cite-828072"> <span id="dsq-author-user-828072">will</span> </cite></div><div id="dsq-comment-body-828072" class="dsq-comment-body"><div id="dsq-comment-message-828072" class="dsq-comment-message"><p>NE played Brady and everyone today. Different philosophy than Tomlin.<br /> How did Deebo do??</p></div></div></li><li class="comment even thread-even depth-1" id="dsq-comment-828075"><div id="dsq-comment-header-828075" class="dsq-comment-header"> <cite id="dsq-cite-828075"> <span id="dsq-author-user-828075">RJMcReady</span> </cite></div><div id="dsq-comment-body-828075" class="dsq-comment-body"><div id="dsq-comment-message-828075" class="dsq-comment-message"><p>Got back to back sacks on the last two plays.</p></div></div></li><li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-828084"><div id="dsq-comment-header-828084" class="dsq-comment-header"> <cite id="dsq-cite-828084"> <span id="dsq-author-user-828084">Conserv_58</span> </cite></div><div id="dsq-comment-body-828084" class="dsq-comment-body"><div id="dsq-comment-message-828084" class="dsq-comment-message"><p>Back ups were playing, Finney goes down, Hubbard steps in at center, the defense couldn’t get off the field on third down in the second half, JuJu is game MVP, the defense gets a single season sack record, and they win in the final seconds, again, they win homefield advantage in the playoffs. What’s not to like? 🙄</p></div></div></li><li class="comment even thread-even depth-1" id="dsq-comment-828086"><div id="dsq-comment-header-828086" class="dsq-comment-header"> <cite id="dsq-cite-828086"> <span id="dsq-author-user-828086">Conserv_58</span> </cite></div><div id="dsq-comment-body-828086" class="dsq-comment-body"><div id="dsq-comment-message-828086" class="dsq-comment-message"><p>I hate the way that whole scenario played out.</p></div></div></li><li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-828087"><div id="dsq-comment-header-828087" class="dsq-comment-header"> <cite id="dsq-cite-828087"> <span id="dsq-author-user-828087">Matt Manzo</span> </cite></div><div id="dsq-comment-body-828087" class="dsq-comment-body"><div id="dsq-comment-message-828087" class="dsq-comment-message"><p>What happened to the middle of our defense? No defenders within 10 yards!</p></div></div></li><li class="comment even thread-even depth-1" id="dsq-comment-828088"><div id="dsq-comment-header-828088" class="dsq-comment-header"> <cite id="dsq-cite-828088"> <span id="dsq-author-user-828088">DoctorNoah</span> </cite></div><div id="dsq-comment-body-828088" class="dsq-comment-body"><div id="dsq-comment-message-828088" class="dsq-comment-message"><p>Sh&amp;t really? Ha. In meaningless Jets game. Good for him</p></div></div></li><li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-828089"><div id="dsq-comment-header-828089" class="dsq-comment-header"> <cite id="dsq-cite-828089"> <span id="dsq-author-user-828089">Danny Porter</span> </cite></div><div id="dsq-comment-body-828089" class="dsq-comment-body"><div id="dsq-comment-message-828089" class="dsq-comment-message"><p>13-3 not to shabby</p></div></div></li><li class="comment even thread-even depth-1" id="dsq-comment-828090"><div id="dsq-comment-header-828090" class="dsq-comment-header"> <cite id="dsq-cite-828090"> <span id="dsq-author-user-828090">DoctorNoah</span> </cite></div><div id="dsq-comment-body-828090" class="dsq-comment-body"><div id="dsq-comment-message-828090" class="dsq-comment-message"><p>Everyone in the world has now figured out how to burn the middle of our zone defense. I bet even the Browns could torch us for touchdowns in the middle of the field. Oh wait, they just did.</p></div></div></li><li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-828091"><div id="dsq-comment-header-828091" class="dsq-comment-header"> <cite id="dsq-cite-828091"> <span id="dsq-author-user-828091">Conserv_58</span> </cite></div><div id="dsq-comment-body-828091" class="dsq-comment-body"><div id="dsq-comment-message-828091" class="dsq-comment-message"><p>They were killin me.</p></div></div></li><li class="comment even thread-even depth-1" id="dsq-comment-828095"><div id="dsq-comment-header-828095" class="dsq-comment-header"> <cite id="dsq-cite-828095"> <span id="dsq-author-user-828095">Conserv_58</span> </cite></div><div id="dsq-comment-body-828095" class="dsq-comment-body"><div id="dsq-comment-message-828095" class="dsq-comment-message"><p>The fall on the ball at the end of the game was Mitchell’s best play of the game. He was invisible otherwise.</p></div></div></li><li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-828127"><div id="dsq-comment-header-828127" class="dsq-comment-header"> <cite id="dsq-cite-828127"> <span id="dsq-author-user-828127">PaeperCup</span> </cite></div><div id="dsq-comment-body-828127" class="dsq-comment-body"><div id="dsq-comment-message-828127" class="dsq-comment-message"><p>Good job by the guys upfront&#8230;..guys in the back? ehhhhhh</p></div></div></li><li class="comment even thread-even depth-1" id="dsq-comment-828128"><div id="dsq-comment-header-828128" class="dsq-comment-header"> <cite id="dsq-cite-828128"> <span id="dsq-author-user-828128">Kevin Schwartz</span> </cite></div><div id="dsq-comment-body-828128" class="dsq-comment-body"><div id="dsq-comment-message-828128" class="dsq-comment-message"><p>All the games with Playoff implications on now. Ravens down 7-0.</p></div></div></li><li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-828131"><div id="dsq-comment-header-828131" class="dsq-comment-header"> <cite id="dsq-cite-828131"> <span id="dsq-author-user-828131">Milton Farfara</span> </cite></div><div id="dsq-comment-body-828131" class="dsq-comment-body"><div id="dsq-comment-message-828131" class="dsq-comment-message"><p>A win is a win is a win. Now time to heal up and get ready to win 3 more games.<br /> GO STEELERS! ! !</p></div></div></li><li class="comment even thread-even depth-1" id="dsq-comment-828132"><div id="dsq-comment-header-828132" class="dsq-comment-header"> <cite id="dsq-cite-828132"> <span id="dsq-author-user-828132">Kevin Schwartz</span> </cite></div><div id="dsq-comment-body-828132" class="dsq-comment-body"><div id="dsq-comment-message-828132" class="dsq-comment-message"><p>Offense moved a lot better than I though considering all the people they were missing.</p></div></div></li><li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-828137"><div id="dsq-comment-header-828137" class="dsq-comment-header"> <cite id="dsq-cite-828137"> <span id="dsq-author-user-828137">Wayde Philpot</span> </cite></div><div id="dsq-comment-body-828137" class="dsq-comment-body"><div id="dsq-comment-message-828137" class="dsq-comment-message"><p>Im not mad at the decision to play or rest starters. Finney got hurt in game, so sitting guys is justifiable for that reason alone. Belichick was ballsy for playing his guys. Thatll help them minimize rust, but its a dangerous thing to do. Esp with Gronk and Brady.</p></div></div></li><li class="comment even thread-even depth-1" id="dsq-comment-828139"><div id="dsq-comment-header-828139" class="dsq-comment-header"> <cite id="dsq-cite-828139"> <span id="dsq-author-user-828139">PaeperCup</span> </cite></div><div id="dsq-comment-body-828139" class="dsq-comment-body"><div id="dsq-comment-message-828139" class="dsq-comment-message"><p>guys step up.  JuJu of course is the real deal.  Landry&#8217;s not great, but he played decently.  Enough to beat the browns at least</p></div></div></li><li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-828141"><div id="dsq-comment-header-828141" class="dsq-comment-header"> <cite id="dsq-cite-828141"> <span id="dsq-author-user-828141">Milton Farfara</span> </cite></div><div id="dsq-comment-body-828141" class="dsq-comment-body"><div id="dsq-comment-message-828141" class="dsq-comment-message"><p>^this</p></div></div></li><li class="comment even thread-even depth-1" id="dsq-comment-828186"><div id="dsq-comment-header-828186" class="dsq-comment-header"> <cite id="dsq-cite-828186"> <span id="dsq-author-user-828186">PaeperCup</span> </cite></div><div id="dsq-comment-body-828186" class="dsq-comment-body"><div id="dsq-comment-message-828186" class="dsq-comment-message"><p>fire tomlin</p></div></div></li><li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-828278"><div id="dsq-comment-header-828278" class="dsq-comment-header"> <cite id="dsq-cite-828278"> <span id="dsq-author-user-828278">treeher</span> </cite></div><div id="dsq-comment-body-828278" class="dsq-comment-body"><div id="dsq-comment-message-828278" class="dsq-comment-message"><p>Back-ups?  Not on defense, by and large.  Our 3rd down performance was unacceptable.</p></div></div></li><li class="comment even thread-even depth-1" id="dsq-comment-828292"><div id="dsq-comment-header-828292" class="dsq-comment-header"> <cite id="dsq-cite-828292"> <span id="dsq-author-user-828292">Doogie</span> </cite></div><div id="dsq-comment-body-828292" class="dsq-comment-body"><div id="dsq-comment-message-828292" class="dsq-comment-message"><p>NE has home field until the lose</p></div></div></li><li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-828318"><div id="dsq-comment-header-828318" class="dsq-comment-header"> <cite id="dsq-cite-828318"> <span id="dsq-author-user-828318">RJMcReady</span> </cite></div><div id="dsq-comment-body-828318" class="dsq-comment-body"><div id="dsq-comment-message-828318" class="dsq-comment-message"><p>Gave up third and long all day, very annoying.</p><p>Got the win though, rested our core starters on offense and have the bye.</p></div></div></li><li class="comment even thread-even depth-1" id="dsq-comment-828440"><div id="dsq-comment-header-828440" class="dsq-comment-header"> <cite id="dsq-cite-828440"> <span id="dsq-author-user-828440">Generic Steelers Fan</span> </cite></div><div id="dsq-comment-body-828440" class="dsq-comment-body"><div id="dsq-comment-message-828440" class="dsq-comment-message"><p>A dismal way to limp to a 13-3 record. I think this performance will put tomlin squarely in the hot seat</p></div></div></li></ul></div></div> <script type="text/javascript">/*<![CDATA[*/var disqus_url='http://www.steelersdepot.com/2017/12/steelers-backups-enough-hold-off-browns-28-24-win/';var disqus_identifier='480672 http://www.steelersdepot.com/?p=480672';var disqus_container_id='disqus_thread';var disqus_shortname='steelersdepot';var disqus_title="Steelers Backups Do Enough To Hold Off Browns In 28-24 Win";var disqus_config_custom=window.disqus_config;var disqus_config=function(){this.language='';this.callbacks.onReady.push(function(){var script=document.createElement('script');script.async=true;script.src='?cf_action=sync_comments&post_id=480672';var firstScript=document.getElementsByTagName('script')[0];firstScript.parentNode.insertBefore(script,firstScript);});if(disqus_config_custom){disqus_config_custom.call(this);}};(function(){var dsq=document.createElement('script');dsq.type='text/javascript';dsq.async=true;dsq.src='//'+disqus_shortname+'.disqus.com/embed.js';(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(dsq);})();/*]]>*/</script> </div> <aside class="mh-sidebar"><div class="widget_text sb-widget clearfix"><div class="textwidget custom-html-widget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-7138622909378284" data-ad-slot="2275390383" data-ad-format="auto"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div></div><div class="sb-widget clearfix"><div id="inner-taboola-3"></div><script type="text/javascript">window._taboola=window._taboola||[];_taboola.push({mode:'thumbnails-rr',container:'inner-taboola-3',placement:'sidebar-3',target_type:'mix'});</script></div><div class="sb-widget clearfix"><ul class="mh-rp-widget widget-list"><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2017/12/tomlin-praises-cam-sutton-late-season-impact/" title="Tomlin Praises Cam Sutton For Late Season Impact" rel="bookmark">Tomlin Praises Cam Sutton For Late Season Impact</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2017/12/bud-dupree-defenders-freelanced-break-sack-record-blames-big-plays-allowed/" title="Bud Dupree: Defenders Freelanced To Break Sack Record, Blames It On Big Plays Allowed" rel="bookmark">Bud Dupree: Defenders Freelanced To Break Sack Record, Blames It On Big Plays Allowed</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2017/12/james-harrison-registers-two-late-sacks-debut-patriots/" title="James Harrison Registers Two Late Sacks In Debut For Patriots" rel="bookmark">James Harrison Registers Two Late Sacks In Debut For Patriots</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2017/12/stevan-ridley-seizes-opportunity-cement-role-backup-rb/" title="Stevan Ridley Seizes Opportunity To Cement Role As Backup RB" rel="bookmark">Stevan Ridley Seizes Opportunity To Cement Role As Backup RB</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2017/12/steelers-break-franchise-record-56-sacks-2017/" title="Steelers Break Franchise Record with 56 Sacks In 2017" rel="bookmark">Steelers Break Franchise Record with 56 Sacks In 2017</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2017/12/steelers-injury-report-finney-player-listed-tomlin-browns-game/" title="Steelers Injury Report: Finney Only Player Listed By Tomlin After Browns Game" rel="bookmark">Steelers Injury Report: Finney Only Player Listed By Tomlin After Browns Game</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2017/12/stats-weird-steelers-vs-browns-4/" title="Stats Of The Weird: Steelers Vs Browns" rel="bookmark">Stats Of The Weird: Steelers Vs Browns</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2017/12/juju-smith-schuster-breaks-59-year-old-steelers-rookie-receiving-yardage-record-season-finale/" title="JuJu Smith-Schuster Breaks 59-Year-Old Steelers Rookie Receiving Yardage Record In Season Finale" rel="bookmark">JuJu Smith-Schuster Breaks 59-Year-Old Steelers Rookie Receiving Yardage Record In Season Finale</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2017/12/steelers-vs-browns-winners-losers/" title="Steelers Vs Browns Winners/Losers" rel="bookmark">Steelers Vs Browns Winners/Losers</a></li><li class="rp-widget-item"><a href="http://www.steelersdepot.com/2017/12/steelers-backups-enough-hold-off-browns-28-24-win/" title="Steelers Backups Do Enough To Hold Off Browns In 28-24 Win" rel="bookmark">Steelers Backups Do Enough To Hold Off Browns In 28-24 Win</a></li></ul></div><div class="widget_text sb-widget clearfix"><div class="textwidget custom-html-widget"><center><a target="_blank" href="http://shareasale.com/r.cfm?b=537844&amp;u=275818&amp;m=7124&amp;urllink=&amp;afftrack="><img src="http://static.shareasale.com/image/7124/NFL_Pittsburg_Steelers_300x250.jpg" border="0" alt="Shop the newest Pittsburgh Steelers fan gear at Fanatics!" /></a></center></div></div></aside></div></div> <footer class="mh-footer"><div class="wrapper-inner clearfix"></div><div class="footer-bottom"><div class="wrapper-inner clearfix"><div class="copyright-wrap"><p class="copyright">Copyright 2017 | Theme by <a href="http://spencer.vegas/" title="Las Vegas WordPress">WordPress</a> | <a href="http://www.steelersdepot.com/privacy-policy/" title="Privacy Policy" rel="nofollow">Privacy Policy</a></p></div><div class="sv-footer">Optimized by <a href="http://spencer.vegas/" title="Las Vegas WordPress">Las Vegas WordPress</a></div></div></div> </footer> <script type="text/javascript">/*<![CDATA[*/var disqus_shortname='steelersdepot';(function(){var nodes=document.getElementsByTagName('span');for(var i=0,url;i<nodes.length;i++){if(nodes[i].className.indexOf('dsq-postid')!=-1&&nodes[i].parentNode.tagName=='A'){nodes[i].parentNode.setAttribute('data-disqus-identifier',nodes[i].getAttribute('data-dsqidentifier'));url=nodes[i].parentNode.href.split('#',1);if(url.length==1){url=url[0];}
else{url=url[1];}
nodes[i].parentNode.href=url+'#disqus_thread';}}
var s=document.createElement('script');s.async=true;s.type='text/javascript';s.src='//'+disqus_shortname+'.disqus.com/count.js';(document.getElementsByTagName('HEAD')[0]||document.getElementsByTagName('BODY')[0]).appendChild(s);}());/*]]>*/</script> <script type="text/javascript">var sectionCode=sectionCode||[];sectionCode.push("a70f4eaa-a346-43eb-98ae-f8e6526f5f12");(function(){var script=document.createElement("script");script.async=true;script.src="https://s.yimg.com/av/gemini/ga/gemini.js";document.body.appendChild(script);})();</script><script type='text/javascript'>window._taboola=window._taboola||[];_taboola.push({flush:true});</script><div style="line-height:16px;text-align:center;"><script type="text/javascript" src="//s3.tracemyip.org/tracker/lgUrl.php?stlVar2=1217&amp;rgtype=4684NR-IPIB&amp;pidnVar2=45152&amp;prtVar2=4&amp;scvVar2=12"></script><noscript><a href="https://www.tracemyip.org/"><img src="//s3.tracemyip.org/tracker/1217/4684NR-IPIB/45152/4/12/ans/" alt="tracemyip" style="border:0px;"></a></noscript></div>  <script type="text/javascript">window.WPCOM_sharing_counts={"http:\/\/www.steelersdepot.com\/2017\/12\/steelers-backups-enough-hold-off-browns-28-24-win\/":480672};</script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-content/plugins/wordpress-post-tabs/js/jquery.posttabs.js?ver=1.6.2'></script> <script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201752'></script> <script type='text/javascript' src='//vjs.zencdn.net/5.9.2/video.js?ver=1.0.2'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-content/plugins/videojs-hls-player/videojs-contrib-hls/videojs-contrib-hls.min.js?ver=1.0.2'></script> <script type='text/javascript' src='//vjs.zencdn.net/ie8/1.1.2/videojs-ie8.min.js?ver=1.0.2'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-content/plugins/videojs-hls-player/videojs-airplay/videojs.airplay.js?ver=1.0.2'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-content/plugins/videojs-hls-player/videojs-hls-player.js?ver=1.0.2'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-content/themes/mh_newsdesk/js/scripts.js?ver=4.9.1'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-content/plugins/simple-social-icons/svgxuse.js?ver=1.1.21'></script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-includes/js/wp-embed.min.js?ver=4.9.1'></script> <script type='text/javascript'>var sharing_js_options={"lang":"en","counts":"1"};</script> <script type='text/javascript' src='http://www.steelersdepot.com/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=5.6.1'></script> <script type='text/javascript'>var windowOpen;jQuery(document.body).on('click','a.share-twitter',function(){if('undefined'!==typeof windowOpen){windowOpen.close();}
windowOpen=window.open(jQuery(this).attr('href'),'wpcomtwitter','menubar=1,resizable=1,width=600,height=350');return false;});var windowOpen;jQuery(document.body).on('click','a.share-facebook',function(){if('undefined'!==typeof windowOpen){windowOpen.close();}
windowOpen=window.open(jQuery(this).attr('href'),'wpcomfacebook','menubar=1,resizable=1,width=600,height=400');return false;});var windowOpen;jQuery(document.body).on('click','a.share-google-plus-1',function(){if('undefined'!==typeof windowOpen){windowOpen.close();}
windowOpen=window.open(jQuery(this).attr('href'),'wpcomgoogle-plus-1','menubar=1,resizable=1,width=480,height=550');return false;});</script> <script type="text/javascript" id="slb_context">if(!!window.jQuery){(function($){$(document).ready(function(){if(!!window.SLB){{$.extend(SLB,{"context":["public","user_guest"]});}}})})(jQuery);}</script> <script type='text/javascript' src='https://stats.wp.com/e-201752.js' async defer></script> <script type='text/javascript'>_stq=window._stq||[];_stq.push(['view',{v:'ext',j:'1:5.6.1',blog:'12286105',post:'480672',tz:'-5',srv:'www.steelersdepot.com'}]);_stq.push(['clickTrackerInit','12286105','480672']);</script> </body></html>